[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: broken broker



On Mon, Dec 03, 2012 at 01:59:47PM -0200, Diego Spinola Castro wrote:
HI guys, i build my own rubygem-openshift-origin-controller package and
upgraded original one. After that my broker crashed, i can't list neither
create applications but sshkeys calls works fine.
After that i removed my package and reinstalled original without luck.

bash history:

rpm -Uvh
rubygem-openshift-origin-controller-1.0.5-1.git.0.68ff4b1.el6.noarch.rpm
/etc/init.d/openshift-broker restart
cd /var/www/openshift/broker/
bundle exec rake tmp:clear
rpm -e rubygem-openshift-origin-controller --nodeps
yum install rubygem-openshift-origin-controller.noarch
/etc/init.d/openshift-broker restart



StackTrace: http://pastebin.com/Awj8f84T

Do you have any cartridges installed on your node or nodes? Having no
cartridges installed is one possible cause for this error message.

We also have a diagnostic script you can try running on your broker and
node hosts:
https://github.com/openshift/origin-server/blob/master/util/oo-diagnostics

This script runs the oo-accept-broker or oo-accept-node script, as
appropriate, as well as some other tests for common problems.  If you
still have problems, please look over and forward the output of the
oo-diagnostics script.

Best regards,

--
Miciah Dashiel Butler Masters <mmasters redhat com>


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]