[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: OpenShift Origin Management Console



I added some additional notes in the README - here's what I added:


Step 5: The console uses the Rails Asset Pipeline to compile JS and CSS.  In order to do that compilation Rails needs to know about a JS runtime.  The [ExecJS gem](https://github.com/sstephenson/execjs)
will attempt to locate a suitable candidate at startup.  If you have Node.js installed it should
detect that automatically.  If you have Firefox installed, you should be able to use SpiderMonkey (the Firefox JS engine) by setting the environment variable:

    $ export EXECJS_RUNTIME=SpiderMonkey

Otherwise you may need to add 'therubyracer' in your Gemfile and re-run 'bundle install'.

------

Let me know if that helps.

----- Original Message -----
> ExecJS will attempt to load whatever version of JS it can find on
> your system
> 
> Openshift origin includes node.js - when the console is in that env
> it can use that version of the V8 js engine.  In a dev system
> therubyracer can also provide it, but because its a gem it will only
> load if you add it to the Gemfile.
> 
> Short answer is that installing node is what most real origin systems
> will have,  adding ruby racer locally won't hurt, but adding it to
> the gemfile may not work in all environments.
> 
> I pushed a change last night to remove our forced use of the
> spidermonkey engine in application.rb, which may also help.
> 
> On Sep 28, 2012, at 9:45 AM, Daniel Ankers <md1clv md1clv com> wrote:
> 
> > Hi Clayton / List
> >> 
> >> Interesting - might be that this is a step I forgot to right down.
> >>  During push the ruby cart will invoke rake assets:precompile -
> >> it could be that I forgot to include a step.  You can compare
> >> with http://console-claytondev.rhcloud.com/ which is a slightly
> >> older version of the source.  I'll take a look this afternoon and
> >> see if I can spot anything.
> >> 
> >> Any and all pull requests are greatly appreciated! :)
> > 
> > I've not managed to get to the bottom of this problem yet (I'm not
> > really a Ruby guy,) so I tried a local install.
> > This is on Ubuntu 12.10 beta 2.
> > 
> > When I run "bundle exec rake test" it errors since it cannot find a
> > Javascript runtime.  I've hacked around this by adding "gem
> > "therubyracer", :require => 'v8'" at the bottom of the Gemfile and
> > re-running "bundle install," but that does not look like a clean
> > solution to me (which is why I've not done a pull request for it.)
> > Do you have any suggestions for a clean way to fix this?
> > 
> > Thanks,
> > Dan
> 
> _______________________________________________
> dev mailing list
> dev lists openshift redhat com
> http://lists.openshift.redhat.com/openshiftmm/listinfo/dev
> 


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]