[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: OpenShift Origin in ec2



Hey Shabna--

On Dec 3, 2013, at 4:49 , <s madathilthattantav accenture com> <s madathilthattantav accenture com> wrote:

> Hi All
> 
> I am using http://openshift.github.io/documentation/oo_install_users_guide.html
> to install Origin in aws
> 
> 
> But I am hitting  the following error while running the script --->
> 
> Error: Execution of '/usr/bin/yum -d 0 -e 0 -y install rubygem-openshift-origin-frontend-apache-mod-rewrite' returned 1: Error: Package: nodejs-ws-0.4.25-2.fc19.x86_64 (origin-deps)
>           Requires: nodejs(engine) >= 0.4.0
> Error: Package: rubygem-openshift-origin-frontend-apachedb-0.3.0-1.git.232.caadcbc.fc19.noarch (origin-base)
>           Requires: ruby(release)
> Error: Package: rubygem-openshift-origin-common-1.18.0-1.git.183.693bfee.fc19.noarch (origin-base)
>           Requires: ruby(release)
> Error: Package: openshift-origin-node-proxy-1.17.0-1.git.230.63afa8c.fc19.noarch (origin-base)
>           Requires: nodejs-async
> Error: Package: rubygem-openshift-origin-common-1.18.0-1.git.183.693bfee.fc19.noarch (origin-base)
>           Requires: rubygem(bundler)
> Error: Package: nodejs-ws-0.4.25-2.fc19.x86_64 (origin-deps)
>           Requires: nodejs(v8-abi) = 3.14
> Error: Package: openshift-origin-node-util-1.18.0-1.git.130.772cb11.fc19.noarch (origin-base)
>           Requires: systemd-units
> Error: Package: rubygem-openshift-origin-node-1.18.0-1.git.91.55e9554.fc19.noarch (origin-base)
>           Requires: rubygem(commander)
> Error: Package: nodejs-supervisor-0.5.2-1.fc19.noarch (origin-deps)
>           Requires: nodejs(engine) >= 0.3.7
> Error: Package: rubygem-openshift-origin-node-1.18.0-1.git.91.55e9554.fc19.noarch (origin-base)
>           Requires: rubygem(parseconfig)
> Error: Package: rubygem-openshift-origin-node-1.18.0-1.git.91.55e9554.fc19.noarch (origin-base)

The default repo for OpenShift Origin is a fedora repo; I think this may be causing problems for you. I need to think about a way to make oo-install a little more clever in this regard.

In the meantime, have a look at your config file (default location is ~/.openshift/oo-install-cfg.yml)

In the Subscription group, look for the 'repos_base' value. If it is:

    https://mirror.openshift.com/pub/openshift-origin/nightly/fedora-19

then change it to:

    https://mirror.openshift.com/pub/openshift-origin/nightly/rhel-6/

and rerun the installer.

If it is already a RHEL6 repo, please let me know which one you are using.

--Harrison

> 
> Any pointers will be helpful.
> 
> Thanks
> Shabna
> 
> -----Original Message-----
> From: Anthony Ananich [mailto:anton ananich inpun com]
> Sent: Tuesday, December 03, 2013 10:50 AM
> To: Madathilthattantav, S.
> Cc: dev lists openshift redhat com
> Subject: Re: OpenShift Origin in ec2
> 
> You can give a try to this tool:
> https://github.com/openshift/openshift-extras/tree/master/oo-install
> 
> On Tue, Dec 3, 2013 at 7:41 AM,  <s madathilthattantav accenture com> wrote:
>> Hi All
>> 
>> 
>> 
>> Need to understand which is the best way to implement OpenShift origin
>> in
>> AWS- ec2 Instance.I am looking for automation and 1 Broker / 1 Node setup.
>> 
>> 
>> 
>> I was referring to
>> http://openshift.github.io/documentation/oo_deployment_guide_puppet.ht
>> ml but hitting a lot of errors and broker installation is failing.
>> 
>> I am trying the origin installation in RHEL6.
>> 
>> 
>> 
>> I am sure this would have been tried and tested ,so any pointers will
>> be greatly appreciated.
>> 
>> 
>> 
>> I have also come across this blog-series as well :
>> 
>> http://cloud-mechanic.blogspot.in/2013/05/openshift-on-aws-ec2-part-1-
>> from-wheels.html
>> 
>> but that list quite a lot of things to be done.So was looking for a
>> simple way out if any !!Appreciate any help.
>> 
>> 
>> 
>> 
>> 
>> Thanks
>> 
>> Shabna
>> 
>> 
>> 
>> 
>> ________________________________
>> 
>> This message is for the designated recipient only and may contain
>> privileged, proprietary, or otherwise confidential information. If you
>> have received it in error, please notify the sender immediately and
>> delete the original. Any other use of the e-mail by you is prohibited.
>> Where allowed by local law, electronic communications with Accenture
>> and its affiliates, including e-mail and instant messaging (including
>> content), may be scanned by our systems for the purposes of
>> information security and assessment of internal compliance with Accenture policy. .
>> ______________________________________________________________________
>> ________________
>> 
>> www.accenture.com
>> 
>> _______________________________________________
>> dev mailing list
>> dev lists openshift redhat com
>> http://lists.openshift.redhat.com/openshiftmm/listinfo/dev
>> 
> 
> 
> This message is for the designated recipient only and may contain privileged, proprietary, or otherwise confidential information. If you have received it in error, please notify the sender immediately and delete the original. Any other use of the e-mail by you is prohibited.
> 
> Where allowed by local law, electronic communications with Accenture and its affiliates, including e-mail and instant messaging (including content), may be scanned by our systems for the purposes of information security and assessment of internal compliance with Accenture policy.
> 
> ______________________________________________________________________________________
> 
> www.accenture.com
> 
> _______________________________________________
> dev mailing list
> dev lists openshift redhat com
> http://lists.openshift.redhat.com/openshiftmm/listinfo/dev



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]