[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Installing Openshift on CentOS 6] Ruby Gems issue



OK, worked with RH and got the repo issue resolved, so back to the Bundler.

[root broker gorilla dev opal broker]# ruby -v
ruby 1.8.7 (2011-06-30 patchlevel 352) [x86_64-linux]

Based on my research, it appears that I will have to run a make install on Ruby 1.9.x. Not ideal. I'm surprised that the openshift infrastructure build does not make sure that the 1.9 dependency is installed.

Anyway, so, I ran yum to install the rubygem-bundler. Now, I get--

[root broker gorilla dev opal broker]# bundle --local
Could not find gem 'rails (~> 3.0.13) ruby' in the gems available on this machine.

Checking more out, confirm that rails gem is not installed--

[root broker gorilla dev opal broker]# gem list --local

*** LOCAL GEMS ***

bundler (1.2.3)
net-ping (1.3.2)
semver (1.0.1)
stomp (1.1.9)
sys-proctable (0.8.1 x86_64-linux)
[root broker gorilla dev opal broker]# which ruby
/usr/bin/ruby

Decided to install rails 3.0.13 via gems, and then follow the trail ^_^ --

[root broker gorilla dev opal broker]# gem install rails -v 3.0.13

[...]

Long story made short, I came to the following end--

[root broker gorilla dev opal broker]# bundle --local
Bundler could not find compatible versions for gem "activesupport":
  In Gemfile:
    rails (~> 3.0.13) ruby depends on
      activesupport (= 3.0.13) ruby

    openshift-origin-controller (>= 0) ruby depends on
      activesupport (3.2.11)

My guess would be that this is due to me running Ruby 1.8.7. However, using the repo that Mike shared through this thread. I still get the same error.

I attempted uninstalling activesupport 3.0.12, and then ran an gem update.

Verifying the ruby version, system still on Ruby 1.8.7. I'm going to try starting over, unless anyone has any suggestions.

Thanks.


On Tue, Jan 22, 2013 at 6:10 PM, Clayton Coleman <ccoleman redhat com> wrote:
You'll need to be running ruby 1.9 unfortunately, but this error is because you need the bundler gem installed.  You can run 'yum install rubygem-bundler' to do that.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]