[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Moving between nodes,when apps have same address-done with error



Not sure what is going on for you. Those 127.x.x.x IPs are private gear IPs; each gear should have a different one, based on the gear user ID. So when you move over a gear from one node to another, they shouldn't clash. I.e. nothing should be listening on the ip:port already, so the question is, why is it?

I note that you have a v1 cartridge in play... curious where you have installed OpenShift from? 

----- Original Message -----
> From: "AlexZ" <alexz kh ua gmail com>
> To: dev lists openshift redhat com
> Sent: Wednesday, July 10, 2013 9:45:53 AM
> Subject: Moving between nodes,when apps have same address-done with error
> 
> 
> 
> 
> Hi, I have interesting situation.
> I have 2 node, on each of them I have installed clear app only with
> php-5.3
> (app name like php1 and php2).
> I want to move php1 from node1 to node2, I run
> oo-admin-move --gear_uuid 51dd36bea29925997500002c
> --target_server_identity oscnode2.
> 
> But their didn't move via error
> DEBUG: Moving failed. Rolling back gear 'php2' in 'php2' with destroy
> on 'oscnode2'Node execution failure (invalid exit code from node).
> 
> So I went to node logs and saw:
> 
> 
> DEBUG -- : Shell command '/usr/sbin/httxt2dbm -f DB -i
> /etc/httpd/conf.d/openshift/nodes.txt -o
> /etc/httpd/conf.d/openshift/nodes.db-20130710-1438-q81yix/new.db'
> ran. rc=0 out=
> DEBUG -- : httxt2dbm: /etc/httpd/conf.d/openshift/nodes: 0: stdout:
> stderr:
> DEBUG -- : Creating v1 model for 51dd36bea29925997500002c: initialize
> INFO -- : handle_cartridge_action executing /usr/bin/runcon -l
> s0-s0:c0.c1023
> /usr/libexec/openshift/cartridges/php-5.3/info/hooks/start php2
> admin 51dd36bea29925997500002c 2>&1
> INFO -- : ERROR: (121)
> ------
> httpd: Could not reliably determine the server's fully qualified
> domain name, using oscnode2 for ServerName
> (98)Address already in use: make_sock: could not bind to address
> 127.0.250.1:8080
> no listening sockets available, shutting down
> Unable to open logs
> Failed to start php-5.3
> 
> 
> So, if app use 127.0.250.1:8080 on node1, the are cannot be moved on
> node2 where this addressee already used?? or i do something wrong?
> 
> 
> 
> 
> 
> _______________________________________________
> dev mailing list
> dev lists openshift redhat com
> http://lists.openshift.redhat.com/openshiftmm/listinfo/dev
> 


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]