[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Error can't find gems dependencies



So there are two possible errors - if you don't have the gem, then gem install sass-rails will fix it for you.  However, in your case it's trying to get a package rubygem-sass-rails, so that may just be either a missing RPM from the setup, or a differently named RPM.  Can't be sure, although Krishna or Troy may know.

Going to cross list this onto dev openshift

----- Original Message -----
> Update:
> Maybe it was a syntax error, after trying:
> 
> > scl enable ruby193 "gem install sass-rails"
> 
> it has installed the gems, however, I still get the same error:
> 
> > puppet apply --verbose configure_origin.pp
> >> Error: Could not find dependency Package[rubygem-sass-rails] for
> >> Exec[Console gem dependencies]
> 
> I tried as well:
> 
> > scl enable ruby193 "puppet apply --verbose configure_origin.pp"
> >> Error: Could not find dependency Package[rubygem-sass-rails] for
> >> Exec[Console gem dependencies]
> 
> Any thoughts?
> 
> On 15 Jul 2013, at 11:54, Jose G N Alban <jgalbandebritto1 sheffield ac uk>
> wrote:
> 
> > I tried to execute:
> > 
> >> scl enable ruby193 gem install
> > 
> > but I got the output:
> > 
> >>> Unable to open /etc/scl/prefixes/ruby193!
> > 
> > Then, I realised I didn't have the ruby193 collection, and followed the
> > instructions on this link to install it:
> > http://developerblog.redhat.com/2013/01/31/ruby-on-rails-3-2-on-red-hat-enterprise-linux-6-with-software-collections/
> > 
> > After that, the file /etc/scl/prefixes/ruby193 was created, and I tried
> > again:
> > 
> >> scl enable ruby193 gem install
> > 
> > giving me the output:
> > 
> >>> Unable to open /etc/scl/prefixes/gem!
> > 
> > I tried as well:
> > 
> >> scl enable ruby193 gem install sass-rails
> >>> Unable to open /etc/scl/prefixes/gem!
> > 
> > Could you please provide me an example, or point out what am I missing?
> > 
> > On 13 Jul 2013, at 18:49, Clayton Coleman <ccoleman redhat com> wrote:
> > 
> >> Are you using scl?  If so, you have to install to the scl ruby:
> >> 
> >>   scl enable ruby193 gem install ....
> >> 
> >> On Jul 13, 2013, at 11:31 AM, Jose G N Alban
> >> <jgalbandebritto1 sheffield ac uk> wrote:
> >> 
> >>> Hi all,
> >>> 
> >>> I'm trying to install openshift origin following the official website
> >>> instructions on a Scientific Linux EL 6 with puppet version 2.7.22
> >>> 
> >>> I've been trying to run
> >>> 
> >>>> puppet apply --verbose configure_origin.pp
> >>> 
> >>> and I've come across that problem:
> >>> 
> >>>>> Could not find dependency Package[rubygem-sass-rails] for Exec[Console
> >>>>> gem dependencies] at
> >>>>> /usr/share/puppet/modules/openshift_origin/manifests/console.pp:283
> >>> 
> >>> Even though I have installed this gem after
> >>> 
> >>>> gem install sass-rails
> >>> 
> >>> … and it installed successfully, however while running the puppet
> >>> manifest, it couldn't find the dependency.
> >>> Could someone please help me?
> >>> 
> >>> Where does puppet search for dependencies declared in Package[xxx] ,
> >>> where could I configure it, or is there any other solution?
> >>> 
> >>> --ja
> >>> 
> >>> _______________________________________________
> >>> users mailing list
> >>> users lists openshift redhat com
> >>> http://lists.openshift.redhat.com/openshiftmm/listinfo/users
> > 
> 
> 


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]