[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

PassengerRoot value seems to be ignored in our gears



Recently I've been upgrading passenger for my cartridges and I'm interested to
know if others have noticed that the value for PassengerRoot in our gears
appears to be completely ignored.  I've found this true for all flavors of
OpenShift.

In my gear's ruby/etc/conf.d/openshift.conf:

* PassengerRoot was originally set to
  /usr/lib/ruby/gems/1.8/gems/passenger-3.0.2.  This directory has not
  existed for a long time in OpenShift Enterprise.

* I set the value to 'NotUsed' and after stopping and starting my
  application it still worked

* I removed the PassengerRoot setting altogether and after
  stop/starting my application it no longer worked.  The error in the
  gear log stated that PassengerRoot was missing.

I've found no documentation stating that passenger should work like this.
However ext/common/ResourceLocator.h does show why this is working.  We use the
rubygem-passenger-native and we're hitting the logic in ResourceLocator.h that
defaults to using the files it was built with.

I see no reason for us to go through the trouble of migrating gear
configuration for this but I'd like to change the value for PassengerRoot to
something like "NativelyPackaged".  I'll have a pull request shortly.  If
anyone has concerns please let me know.

--Brenton


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]