[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Problems with cartridges



On 31/07/13 09:30 -0400, Brenton Leanhardt wrote:
+++ ligia abigail arghir [31/07/13 03:37 -0700]:
Hello everyone,

I have installed Openshift on Fedora 19 using the Puppet scripts
provided in the documentation (on openshift.github.io) and it looks
really good. Except for the fact that I cannot create applications.
I get the following error: "There are no cartridges that match
[cartridge-name]" no matter what cartridge I try to use. The
web-frontend also shows no web cartridges. I tried to check on the
server and the list of cartridges seems to be ok (but with no version identifiers). I must mention that I
did get some errors when running the scripts (I read a previous thread
and they are similar).
I would appreciate any help.
Thank you!
Liaabi

I'm wondering if your broker has a stale cache.  Try the following on
your broker host.

oo-admin-broker-cache --clear --console

Others are more familiar with the current state of the Origin puppet
scripts on Fedora 19 so they will likely chime in.


If oo-cartridge-list does not show all the cartridges after the
oo-admin-broker-cache --clear --console, then you can run this to add
the installed cartridges to the cartridge repository:

oo-admin-cartridge -a install -R -s /usr/libexec/openshift/cartridges/

This will install any cartridges found in the
/usr/libexec/openshift/cartridges/ directory.
--
Jason DeTiberus


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]