[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: oo-admin-move redirection loop



Thank you, the curl proves that the problem is related to the proxy we have in our company.

$ http_proxy="http://proxy:3128" curl -IL --max-redirs 3 http://gdgf-filirom1.apps.zone52.org/
HTTP/1.0 302 Moved Temporarily
Server: nginx/1.4.1
Date: Thu, 06 Jun 2013 14:40:13 GMT
Content-Type: text/html; charset=iso-8859-1
Location: http://gdgf-filirom1.apps.zone52.org/getting_started.html
X-Cache: MISS from office-proxy
X-Cache-Lookup: MISS from office-proxy:3128
Connection: keep-alive

HTTP/1.0 302 Moved Temporarily
Server: nginx/1.4.1
Date: Thu, 06 Jun 2013 14:40:13 GMT
Content-Type: text/html; charset=iso-8859-1
Location: http://gdgf-filirom1.apps.zone52.org/getting_started.html
X-Cache: MISS from office-proxy
X-Cache-Lookup: MISS from office-proxy:3128
Connection: keep-alive

HTTP/1.0 302 Moved Temporarily
Server: nginx/1.4.1
Date: Thu, 06 Jun 2013 14:40:13 GMT
Content-Type: text/html; charset=iso-8859-1
Location: http://gdgf-filirom1.apps.zone52.org/getting_started.html
X-Cache: MISS from office-proxy
X-Cache-Lookup: MISS from office-proxy:3128
Connection: keep-alive

HTTP/1.0 302 Moved Temporarily
Server: nginx/1.4.1
Date: Thu, 06 Jun 2013 14:40:13 GMT
Content-Type: text/html; charset=iso-8859-1
Location: http://gdgf-filirom1.apps.zone52.org/getting_started.html
X-Cache: MISS from office-proxy
X-Cache-Lookup: MISS from office-proxy:3128
Connection: keep-alive

curl: (47) Maximum (3) redirects followed

If I disable it, it works.

$  curl -IL --max-redirs 3 http://gdgf-filirom1.apps.zone52.org/
HTTP/1.1 200 OK
Server: nginx/1.4.1
Date: Thu, 06 Jun 2013 14:42:25 GMT
Content-Type: text/html; charset=UTF-8
Connection: keep-alive



2013/6/6 Luke Meyer <lmeyer redhat com>
That does sound like a node proxy problem.

No idea how that would happen, but the first step would be to figure out exactly what it's doing... something like:

curl -IL --max-redirs 3 <app address>

That should show the headers on a few redirects. Then figure out where that is coming from...

----- Original Message -----
From: "Romain" <filirom1 gmail com>
To: "Openshift Dev" <dev lists openshift redhat com>
Sent: Friday, May 31, 2013 6:23:17 AM
Subject: oo-admin-move redirection loop



Hi,


I have a district with two nodes.
When I try oo-admin-move, the gear is moved to the other node, the DNS is updated, /etc/httpd/conf.d/openshift/nodes.txt and /etc/httpd/conf.d/openshift/routes.json are updated too.


But my browser tell me Erreur 310 (net::ERR_TOO_MANY_REDIRECTS)



On the node I can curl to the private URL it works : curl 127.7.153.1:8080


I think there is a problem with the node Apache, but I don't know how to fix it.


Cheers
Romain
_______________________________________________
dev mailing list
dev lists openshift redhat com
http://lists.openshift.redhat.com/openshiftmm/listinfo/dev


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]