[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: getting "invalid option: --include-dependencies" on puppet install



I believe that RubyGems 2.x has removed '--ignore-dependencies' flag (which is now default, since 1.8.x maybe?).

Our install should reflect that.

I opened a Bugzilla ticket on your behalf: https://bugzilla.redhat.com/show_bug.cgi?id=973702

Feel free to add further details.

Thank you.

On Jun 10, 2013, at 6:25 PM, Tomohisa Igarashi <tm igarashi gmail com> wrote:

Hello,

I'm trying to install origin on Fedora19 Beta since I just heard
current upstream master is now based on Fedora19, but I'm getting
following kind of errors on puppet install:

Error: /Stage[main]/Openshift_origin::Broker/Package[mysql]/ensure:
change from absent to present failed: Execution of '/bin/gem install
--include-dependencies --no-rdoc --no-ri mysql' returned 1: ERROR:
While executing gem ... (OptionParser::InvalidOption)
   invalid option: --include-dependencies

Is the upstream master based on Fedora19 rawhide but not Beta? or am I
missing something?

Thanks,
Tomo

--
IGARASHI Tomohisa    mailto:tm igarashi gmail com

_______________________________________________
dev mailing list
dev lists openshift redhat com
http://lists.openshift.redhat.com/openshiftmm/listinfo/dev


-- 
Hirotsugu Asari
Sr Software Engineer, Red Hat


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]