[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: 500 Server error on invoking /broker/rest/[domains|cartridges] after installing Origin on RHEL 6.4



I am working on create RHEL install documentation. Will send out an alert to the list once it is completed.

--Krishna

On Jun 14, 2013, at 3:36 PM, Marek Śmigielski <marek smigielski gmail com> wrote:

Hi,

I have exactly the same problem. Have you found any solution?

Cheers,
Marek

On 13 June 2013 00:17, Shiva Bhanujan <sxb075 gmail com> wrote:
Hello,

I've installed OpenShift Origin on RHEL 6.4 w/ EPEL.  The node/broker are installed on the same host.  After the installation, the invocation of /broker/rest/domains and /broker/rest/cartridges returns a '500 Internal Server Error'.  The STOMP configuration for host/port/user/password in /etc/mcollective/[client|server].cfg looks correct.  The DNS lookup for the broker/node succeeds, and 'mco ping' also returns success.

The following logs from /var/log/openshift/broker/production.log seems to be interesting :

<<...snip...>>

Error processing custom_request for action cartridge-list: no current connection exists
["/opt/rh/ruby193/root/usr/local/share/gems/gems/stomp-1.2.9/lib/stomp/connection.rb:243:in `subscribe'", "/opt/rh/ruby193/root/usr/libexec/mcollective/mcollective/connector/stomp.rb:242:in `subscribe'", "/opt/rh/ruby193/root/usr/share/ruby/mcollective/util.rb:192:in `block in subscribe'", "/opt/rh/ruby193/root/usr/share/ruby/mcollective/util.rb:191:in `each'", "/opt/rh/ruby193/root/usr/share/ruby/mcollective/util.rb:191:in `subscribe'", "/opt/rh/ruby193/root/usr/share/ruby/mcollective/client.rb:65:in `subscribe'", "/opt/rh/ruby193/root/usr/share/ruby/mcollective/client.rb:53:in `sendreq'", "/opt/rh/ruby193/root/usr/share/ruby/mcollective/client.rb:149:in `block in req'", "/opt/rh/ruby193/root/usr/share/ruby/timeout.rb:68:in `timeout'", "/opt/rh/ruby193/root/usr/share/ruby/mcollective/client.rb:148:in `req'", "/opt/rh/ruby193/root/usr/share/ruby/mcollective/rpc/client.rb:822:in `call_agent'",

<<...snip...>> 


Right where connection.subscribe is invoked in self.subscribe@/opt/rh/ruby193/root/usr/share/ruby/mcollective/util.rb, the values for the parameters being passed are as follows :

util.rb:192:in `block in subscribe' connection.subscribe - :agent = 'openshift', :type = 'reply', :collective = 'collective'


I have tried executing 'rhc setup --server <host>', but because /broker/rest/domains doesn't pass, the setup also fails.


This is as far as my debugging goes.  Can somebody suggest based on the above what to look for?  Or, what other information might be required to debug this?


Regards,

Shiva



_______________________________________________
dev mailing list
dev lists openshift redhat com
http://lists.openshift.redhat.com/openshiftmm/listinfo/dev


_______________________________________________
dev mailing list
dev lists openshift redhat com
http://lists.openshift.redhat.com/openshiftmm/listinfo/dev


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]