[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Problem with jenkins with v2 cartridges



Sorry I actually gave the wrong url below to curl.  But can you try to curl your jenkins server while sshed into the app you want to build.  Just want to make sure it's contactable from the other app and all the env vars are in place.

JENKINS_DNS_NAME=${JENKINS_URL:8}
curl -s -w %{http_code} --output /dev/null --insecure https://${JENKINS_USERNAME}:${JENKINS_PASSWORD} ${JENKINS_DNS_NAME}

----- Original Message -----
> Yes it is running, I can login to it via webbrowser using username and
> password from log file.
> 
> I didn't change any password so it is set default. In jenkins log there
> isn't anything, even a single line with the information that some build was
> add to it or any other failure.
> 
> I paste http://pastebin.com/V2nxaBgA log
> from /var/log/openshift/node/platform-trace.log related to creating jenkins
> build. After CLIENT_ERROR there  is only information with error:
> June 20 09:11:05 INFO oo_spawn buffer(11/) CLIENT_ERROR:    create_job
> status:
> CLIENT_ERROR: build config does not exist
> CLIENT_ERROR: You'll need to correct this error before attempting to embed
> the Jenkins client again.
> 
> 
> On 20 June 2013 16:31, Daniel McPherson <dmcphers redhat com> wrote:
> 
> > Hi Marek,
> >
> > It's failing creating the job on your jenkins server.
> >
> > Few questions:
> >
> > - Is your jenkins server running?  You can try this to confirm:
> >   JENKINS_DNS_NAME=${JENKINS_URL:8} #remove https://
> >   curl -s -w %{http_code} --output /dev/null --insecure https://
> > ${JENKINS_USERNAME}:${JENKINS_PASSWORD}@
> > ${JENKINS_DNS_NAME}computer/${OPENSHIFT_APP_NAME}bldr/
> >
> > - Have you changed the admin or system_builder password for your jenkins
> > server?  I only ask because there was an issue fixed yesterday with
> > changing the admin password.
> > - Is there anything in the jenkins logs about the create job failure?
> >
> > -Dan
> >
> > ----- Original Message -----
> > > Hi,
> > >
> > > I have a problem enabling v2 jenkins cartridge for php and jboss
> > aplication.
> > > In logs there is only:
> > >
> > > June 20 09:11:05 INFO oo_spawn buffer(11/) CLIENT_ERROR: create_job
> > status:
> > > CLIENT_ERROR: build config does not exist
> > > CLIENT_ERROR: You'll need to correct this error before attempting to
> > embed
> > > the Jenkins client again.
> > >
> > > My installation is on Centos6.4 from latest nightly build from openshift
> > yum
> > > repo.
> > >
> > > I would appreciate any hint what to do next.
> > >
> > > Cheers,
> > > Marek
> > >
> > > _______________________________________________
> > > dev mailing list
> > > dev lists openshift redhat com
> > > http://lists.openshift.redhat.com/openshiftmm/listinfo/dev
> > >
> >
> 


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]