[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Packages needed in Fedora for OpenShift Origin




On Mar 22, 2013, at 5:31 PM, Krishna Raman <kraman gmail com> wrote:

> Those are mostly console dependencies. Clayton can answer this better.
> 
> --kr
> 
> On Mar 22, 2013, at 2:26 PM, Troy Dawson <tdawson redhat com> wrote:
> 
>> Hi Krishna,
>> How many of these are needed versions, and how many of them are just that we haven't tested on the version in Fedora.
>> 
>> Remember, that by changing a version, means that you change it for everyone in Fedora.  And think about how you would like it if your gem version got changed on you.
>> 
>> The time to get the right gem versions for F19 is right now.  It's easy to change the version for F19 and F20, because F19 is in Alpha, and F20 is still rawhide.
>> 
>> Actually, several of the gems that you want upgraded, already are upgraded in F19 and F20.  The rest of my comments will be inline.
>> 
>> On 03/22/2013 03:11 PM, Krishna Raman wrote:
>>> Hi Troy,
>>> 
>>> Some of the rpms you mentioned below exist on Fedora but the versions don't match what we need.
>>> 
>>> --Kr
>>> 
>>> On Mar 22, 2013, at 12:28 PM, Troy Dawson <tdawson redhat com> wrote:
>>> 
>>>> Hi,
>>>> This is a list of packages that need to get into Fedora so that we don't have to keep pulling gems from rubygems.org.
>>>> This is not the Troy Dawson work list, but open to anyone who is a Fedora packager and wants to help out with OpenShift Origin.
>>>> That being said, if nobody takes them, I will work on them as my time frees up on other items/packages.
>>>> 
>>>> rubygem-mongoid
>>>> rubygem-moped
>>>> rubygem-mysql
>>>> rubygem-origin
>>>> 
>>>> The following packages were mentioned on #openshift-dev, but are already in Fedora 17+.
>>>> 
>>>> rubygem-i18n
>>>> rubygem-activesupport
>>>> rubygem-minitest
>>> 
>>> Need version 320. Fedora has 2.10.1
>>> 
>> 
>> minitest 4.2 is in F19+

This is just rails, we can probably tolerate any version rails can.

>> 
>>>> rubygem-rdiscount
>>> 
>>> Need 1.6.8. Fedora has 2.0.7
>>> 
>> 
>> Going down in versions.  I'm not sure how to do that.
>> Are we sure we need this older version?

We don't, we should be able to tolerate 2

>> 
>>>> rubygem-formtastic
>>> 
>>> Need 1.2.4. Fedora has 1.2.3
>>> 
>> 
>> We can ask the formtastic maintainers if they wouldn't mind bumping it up a version.

We can probably tolerate 1.2.3

>> 
>>>> rubygem-net-http-persistent
>>> 
>>> Need 2.7. Fedora has 2.1
>>> 
>> 
>> net-http-persistent 2.8 is in F19+

We need 2.7+ because of bugs in 2.1

>> 
>>>> rubygem-haml
>>> 
>>> Need 3.1.7. Fedora has 3.1.6
>>> 
>> 
>> haml 3.1.7 is in F19+

We can tolerate 3.1.6

>> 
>> 
>> So, for F19, we're pretty close to having everything.
>> 
>> Troy
>>>> 
>>>> Thanks
>>>> Troy
>>>> 
>>>> _______________________________________________
>>>> dev mailing list
>>>> dev lists openshift redhat com
>>>> http://lists.openshift.redhat.com/openshiftmm/listinfo/dev
>>> 
>> 
>> _______________________________________________
>> dev mailing list
>> dev lists openshift redhat com
>> http://lists.openshift.redhat.com/openshiftmm/listinfo/dev
> 


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]