[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: OSO on CentOS 6.x?

On 11/11/2013 07:35 AM, N. Harrison Ripps wrote:
Hey Mike--

On Nov 11, 2013, at 1:50 , The Dude <michael mcconachie hotmail com>

Hi all,

....Please don't shoot the messenger.  I have been tasked (kicking
and screaming) with identifying and verifying an install procedure
for OSO 2.0 on Centos (Puppet, Ansible, BASH based, w/e).

Why shoot the messenger? Red Hat <3's CentOS:

At one time vagrant was the culprit of failed (puppet driven)
installs.  Krishna, Jamey, Ben Klank, and Ben Langfeld fixed it
several months ago.  Info can be found here --->
https://github.com/worldline/openshift-vagrant-centos.  Has anyone
had recent success re: installing 2.0 on CentOS since then?

Have you tried this with oo-install yet? Krishna can correct me if
I'm out to lunch on this, and I'll set up a test case right now, but
my understanding is that oo-install's (Puppet-based) Origin
installation workflow functions correctly on RHEL, so it -should-
function correctly on CentOS. Anyone who knows better, please feel
free to contradict me...


Hi Harrison,
When I tried it before on Scientific Linux it wouldn't define Scientific Linux as a "rhel" machine. I had to hack the code to fool it. After that, things ran fine.

It looks like that section of code has changed, but I believe it still will not recognize either Scientific Linux or CentOS as a rhel machine.

p.s. I will verify later today if needs be, but right now my virtual machine is misbehaving.

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]