[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

oo-admin-upgrade



Hi, i'm running into a issue when i try use oo-admin-upgrade script.

This is release 2 origin install. Looks like it is missing --version param and running the upgrade only in one gear.

[root dev-diego ~]#  /usr/sbin/oo-admin-upgrade --version 2.0.0 --ignore-cartridge-version 
Performing upgrade with options: {:version=>"2.0.0", :continue=>false, :ignore_cartridge_version=>true, :target_server_identity=>nil, :upgrade_position=>1, :num_upgraders=>1, :rerun=>false}
Getting all active gears...
Getting all logins...
........
logins.length: 3
Writing 8 gears for node dev-diego.ops.getupcloud.com_active to file /tmp/oo-upgrade/upgrade_dev-diego.ops.getupcloud.com_active
#####################################################
#####################################################
Migrating gears on node dev-diego.ops.getupcloud.com_active
Performing upgrade with options: {:version=>nil, :continue=>false, :ignore_cartridge_version=>false, :target_server_identity=>nil, :upgrade_position=>1, :num_upgraders=>1, :rerun=>false}
Getting all active gears...
Getting all logins...
........
logins.length: 3
Writing 8 gears for node dev-diego.ops.getupcloud.com_active to file /tmp/oo-upgrade/upgrade_dev-diego.ops.getupcloud.com_active
#####################################################
#####################################################
Migrating gears on node dev-diego.ops.getupcloud.com_active

Migrating app 'prephp54' gear 'prephp54' with uuid '5294d204a665b7663500002c' on node 'dev-diego.ops.getupcloud.com' for user: test getupcloud com
Failed to upgrade with cmd: '/usr/sbin/oo-admin-upgrade --login 'test getupcloud com' --upgrade-gear '5294d204a665b7663500002c' --app-name 'prephp54' --version '' ' after 2 tries with exception: Cannot validate input version: value should match ^.+$
["/opt/rh/ruby193/root/usr/share/ruby/mcollective/ddl/base.rb:144:in `rescue in validate_input_argument'", "/opt/rh/ruby193/root/usr/share/ruby/mcollective/ddl/base.rb:125:in `validate_input_argument'", "/opt/rh/ruby193/root/usr/share/ruby/mcollective/ddl/agentddl.rb:167:in `block in validate_rpc_request'", "/opt/rh/ruby193/root/usr/share/ruby/mcollective/ddl/agentddl.rb:159:in `each'", "/opt/rh/ruby193/root/usr/share/ruby/mcollective/ddl/agentddl.rb:159:in `validate_rpc_request'", "/opt/rh/ruby193/root/usr/share/ruby/mcollective/rpc/client.rb:219:in `method_missing'", "/usr/sbin/oo-admin-upgrade:50:in `block (2 levels) in upgrade_gear'", "/opt/rh/ruby193/root/usr/share/gems/gems/openshift-origin-msg-broker-mcollective-1.13.0.2/lib/openshift/mcollective_application_container_proxy.rb:2189:in `rpc_exec'", "/usr/sbin/oo-admin-upgrade:49:in `block in upgrade_gear'", "/opt/rh/ruby193/root/usr/share/ruby/timeout.rb:69:in `timeout'", "/usr/sbin/oo-admin-upgrade:41:in `upgrade_gear'", "/usr/sbin/oo-admin-upgrade:458:in `block in upgrade_from_file'", "/usr/sbin/oo-admin-upgrade:456:in `each'", "/usr/sbin/oo-admin-upgrade:456:in `upgrade_from_file'", "/usr/sbin/oo-admin-upgrade:608:in `<main>'"]
Output:
Migrating gear on node with: /usr/sbin/oo-admin-upgrade --login 'test getupcloud com' --upgrade-gear '5294d204a665b7663500002c' --app-name 'prephp54' --version '' --ignore-cartridge-version
Upgrading on node...
Migrating app 'prephp55' gear 'prephp55' with uuid '5294d2a6a665b76635000042' on node 'dev-diego.ops.getupcloud.com' for user: test getupcloud com
Failed to upgrade with cmd: '/usr/sbin/oo-admin-upgrade --login 'test getupcloud com' --upgrade-gear '5294d2a6a665b76635000042' --app-name 'prephp55' --version '' ' after 2 tries with exception: Cannot validate input version: value should match ^.+$
["/opt/rh/ruby193/root/usr/share/ruby/mcollective/ddl/base.rb:144:in `rescue in validate_input_argument'", "/opt/rh/ruby193/root/usr/share/ruby/mcollective/ddl/base.rb:125:in `validate_input_argument'", "/opt/rh/ruby193/root/usr/share/ruby/mcollective/ddl/agentddl.rb:167:in `block in validate_rpc_request'", "/opt/rh/ruby193/root/usr/share/ruby/mcollective/ddl/agentddl.rb:159:in `each'", "/opt/rh/ruby193/root/usr/share/ruby/mcollective/ddl/agentddl.rb:159:in `validate_rpc_request'", "/opt/rh/ruby193/root/usr/share/ruby/mcollective/rpc/client.rb:219:in `method_missing'", "/usr/sbin/oo-admin-upgrade:50:in `block (2 levels) in upgrade_gear'", "/opt/rh/ruby193/root/usr/share/gems/gems/openshift-origin-msg-broker-mcollective-1.13.0.2/lib/openshift/mcollective_application_container_proxy.rb:2189:in `rpc_exec'", "/usr/sbin/oo-admin-upgrade:49:in `block in upgrade_gear'", "/opt/rh/ruby193/root/usr/share/ruby/timeout.rb:69:in `timeout'", "/usr/sbin/oo-admin-upgrade:41:in `upgrade_gear'", "/usr/sbin/oo-admin-upgrade:458:in `block in upgrade_from_file'", "/usr/sbin/oo-admin-upgrade:456:in `each'", "/usr/sbin/oo-admin-upgrade:456:in `upgrade_from_file'", "/usr/sbin/oo-admin-upgrade:608:in `<main>'"]
Output:
Migrating gear on node with: /usr/sbin/oo-admin-upgrade --login 'test getupcloud com' --upgrade-gear '5294d2a6a665b76635000042' --app-name 'prephp55' --version '' --ignore-cartridge-version
Upgrading on node...
Migrating app 'preruby' gear 'preruby' with uuid '5294dd06a665b7841d000001' on node 'dev-diego.ops.getupcloud.com' for user: test getupcloud com
Failed to upgrade with cmd: '/usr/sbin/oo-admin-upgrade --login 'test getupcloud com' --upgrade-gear '5294dd06a665b7841d000001' --app-name 'preruby' --version '' ' after 2 tries with exception: Cannot validate input version: value should match ^.+$
["/opt/rh/ruby193/root/usr/share/ruby/mcollective/ddl/base.rb:144:in `rescue in validate_input_argument'", "/opt/rh/ruby193/root/usr/share/ruby/mcollective/ddl/base.rb:125:in `validate_input_argument'", "/opt/rh/ruby193/root/usr/share/ruby/mcollective/ddl/agentddl.rb:167:in `block in validate_rpc_request'", "/opt/rh/ruby193/root/usr/share/ruby/mcollective/ddl/agentddl.rb:159:in `each'", "/opt/rh/ruby193/root/usr/share/ruby/mcollective/ddl/agentddl.rb:159:in `validate_rpc_request'", "/opt/rh/ruby193/root/usr/share/ruby/mcollective/rpc/client.rb:219:in `method_missing'", "/usr/sbin/oo-admin-upgrade:50:in `block (2 levels) in upgrade_gear'", "/opt/rh/ruby193/root/usr/share/gems/gems/openshift-origin-msg-broker-mcollective-1.13.0.2/lib/openshift/mcollective_application_container_proxy.rb:2189:in `rpc_exec'", "/usr/sbin/oo-admin-upgrade:49:in `block in upgrade_gear'", "/opt/rh/ruby193/root/usr/share/ruby/timeout.rb:69:in `timeout'", "/usr/sbin/oo-admin-upgrade:41:in `upgrade_gear'", "/usr/sbin/oo-admin-upgrade:458:in `block in upgrade_from_file'", "/usr/sbin/oo-admin-upgrade:456:in `each'", "/usr/sbin/oo-admin-upgrade:456:in `upgrade_from_file'", "/usr/sbin/oo-admin-upgrade:608:in `<main>'"]
Output:
Migrating gear on node with: /usr/sbin/oo-admin-upgrade --login 'test getupcloud com' --upgrade-gear '5294dd06a665b7841d000001' --app-name 'preruby' --version '' --ignore-cartridge-version
Upgrading on node...
Migrating app '54' gear '54' with uuid '5294f3a1a665b78897000025' on node 'dev-diego.ops.getupcloud.com' for user: test getupcloud com
Failed to upgrade with cmd: '/usr/sbin/oo-admin-upgrade --login 'test getupcloud com' --upgrade-gear '5294f3a1a665b78897000025' --app-name '54' --version '' ' after 2 tries with exception: Cannot validate input version: value should match ^.+$
["/opt/rh/ruby193/root/usr/share/ruby/mcollective/ddl/base.rb:144:in `rescue in validate_input_argument'", "/opt/rh/ruby193/root/usr/share/ruby/mcollective/ddl/base.rb:125:in `validate_input_argument'", "/opt/rh/ruby193/root/usr/share/ruby/mcollective/ddl/agentddl.rb:167:in `block in validate_rpc_request'", "/opt/rh/ruby193/root/usr/share/ruby/mcollective/ddl/agentddl.rb:159:in `each'", "/opt/rh/ruby193/root/usr/share/ruby/mcollective/ddl/agentddl.rb:159:in `validate_rpc_request'", "/opt/rh/ruby193/root/usr/share/ruby/mcollective/rpc/client.rb:219:in `method_missing'", "/usr/sbin/oo-admin-upgrade:50:in `block (2 levels) in upgrade_gear'", "/opt/rh/ruby193/root/usr/share/gems/gems/openshift-origin-msg-broker-mcollective-1.13.0.2/lib/openshift/mcollective_application_container_proxy.rb:2189:in `rpc_exec'", "/usr/sbin/oo-admin-upgrade:49:in `block in upgrade_gear'", "/opt/rh/ruby193/root/usr/share/ruby/timeout.rb:69:in `timeout'", "/usr/sbin/oo-admin-upgrade:41:in `upgrade_gear'", "/usr/sbin/oo-admin-upgrade:458:in `block in upgrade_from_file'", "/usr/sbin/oo-admin-upgrade:456:in `each'", "/usr/sbin/oo-admin-upgrade:456:in `upgrade_from_file'", "/usr/sbin/oo-admin-upgrade:608:in `<main>'"]
Output:
Migrating gear on node with: /usr/sbin/oo-admin-upgrade --login 'test getupcloud com' --upgrade-gear '5294f3a1a665b78897000025' --app-name '54' --version '' --ignore-cartridge-version
Upgrading on node...
Migrating app '55' gear '55' with uuid '5294f908a665b7af6400002d' on node 'dev-diego.ops.getupcloud.com' for user: test getupcloud com
Failed to upgrade with cmd: '/usr/sbin/oo-admin-upgrade --login 'test getupcloud com' --upgrade-gear '5294f908a665b7af6400002d' --app-name '55' --version '' ' after 2 tries with exception: Cannot validate input version: value should match ^.+$
["/opt/rh/ruby193/root/usr/share/ruby/mcollective/ddl/base.rb:144:in `rescue in validate_input_argument'", "/opt/rh/ruby193/root/usr/share/ruby/mcollective/ddl/base.rb:125:in `validate_input_argument'", "/opt/rh/ruby193/root/usr/share/ruby/mcollective/ddl/agentddl.rb:167:in `block in validate_rpc_request'", "/opt/rh/ruby193/root/usr/share/ruby/mcollective/ddl/agentddl.rb:159:in `each'", "/opt/rh/ruby193/root/usr/share/ruby/mcollective/ddl/agentddl.rb:159:in `validate_rpc_request'", "/opt/rh/ruby193/root/usr/share/ruby/mcollective/rpc/client.rb:219:in `method_missing'", "/usr/sbin/oo-admin-upgrade:50:in `block (2 levels) in upgrade_gear'", "/opt/rh/ruby193/root/usr/share/gems/gems/openshift-origin-msg-broker-mcollective-1.13.0.2/lib/openshift/mcollective_application_container_proxy.rb:2189:in `rpc_exec'", "/usr/sbin/oo-admin-upgrade:49:in `block in upgrade_gear'", "/opt/rh/ruby193/root/usr/share/ruby/timeout.rb:69:in `timeout'", "/usr/sbin/oo-admin-upgrade:41:in `upgrade_gear'", "/usr/sbin/oo-admin-upgrade:458:in `block in upgrade_from_file'", "/usr/sbin/oo-admin-upgrade:456:in `each'", "/usr/sbin/oo-admin-upgrade:456:in `upgrade_from_file'", "/usr/sbin/oo-admin-upgrade:608:in `<main>'"]
Output:
Migrating gear on node with: /usr/sbin/oo-admin-upgrade --login 'test getupcloud com' --upgrade-gear '5294f908a665b7af6400002d' --app-name '55' --version '' --ignore-cartridge-version
Upgrading on node...
Migrating app '544' gear '544' with uuid '529505d7a665b7af64000043' on node 'dev-diego.ops.getupcloud.com' for user: test getupcloud com
Failed to upgrade with cmd: '/usr/sbin/oo-admin-upgrade --login 'test getupcloud com' --upgrade-gear '529505d7a665b7af64000043' --app-name '544' --version '' ' after 2 tries with exception: Cannot validate input version: value should match ^.+$
["/opt/rh/ruby193/root/usr/share/ruby/mcollective/ddl/base.rb:144:in `rescue in validate_input_argument'", "/opt/rh/ruby193/root/usr/share/ruby/mcollective/ddl/base.rb:125:in `validate_input_argument'", "/opt/rh/ruby193/root/usr/share/ruby/mcollective/ddl/agentddl.rb:167:in `block in validate_rpc_request'", "/opt/rh/ruby193/root/usr/share/ruby/mcollective/ddl/agentddl.rb:159:in `each'", "/opt/rh/ruby193/root/usr/share/ruby/mcollective/ddl/agentddl.rb:159:in `validate_rpc_request'", "/opt/rh/ruby193/root/usr/share/ruby/mcollective/rpc/client.rb:219:in `method_missing'", "/usr/sbin/oo-admin-upgrade:50:in `block (2 levels) in upgrade_gear'", "/opt/rh/ruby193/root/usr/share/gems/gems/openshift-origin-msg-broker-mcollective-1.13.0.2/lib/openshift/mcollective_application_container_proxy.rb:2189:in `rpc_exec'", "/usr/sbin/oo-admin-upgrade:49:in `block in upgrade_gear'", "/opt/rh/ruby193/root/usr/share/ruby/timeout.rb:69:in `timeout'", "/usr/sbin/oo-admin-upgrade:41:in `upgrade_gear'", "/usr/sbin/oo-admin-upgrade:458:in `block in upgrade_from_file'", "/usr/sbin/oo-admin-upgrade:456:in `each'", "/usr/sbin/oo-admin-upgrade:456:in `upgrade_from_file'", "/usr/sbin/oo-admin-upgrade:608:in `<main>'"]
Output:
Migrating gear on node with: /usr/sbin/oo-admin-upgrade --login 'test getupcloud com' --upgrade-gear '529505d7a665b7af64000043' --app-name '544' --version '' --ignore-cartridge-version
Upgrading on node...
Migrating app '533' gear '533' with uuid '529506efa665b7af64000059' on node 'dev-diego.ops.getupcloud.com' for user: test getupcloud com
Failed to upgrade with cmd: '/usr/sbin/oo-admin-upgrade --login 'test getupcloud com' --upgrade-gear '529506efa665b7af64000059' --app-name '533' --version '' ' after 2 tries with exception: Cannot validate input version: value should match ^.+$
["/opt/rh/ruby193/root/usr/share/ruby/mcollective/ddl/base.rb:144:in `rescue in validate_input_argument'", "/opt/rh/ruby193/root/usr/share/ruby/mcollective/ddl/base.rb:125:in `validate_input_argument'", "/opt/rh/ruby193/root/usr/share/ruby/mcollective/ddl/agentddl.rb:167:in `block in validate_rpc_request'", "/opt/rh/ruby193/root/usr/share/ruby/mcollective/ddl/agentddl.rb:159:in `each'", "/opt/rh/ruby193/root/usr/share/ruby/mcollective/ddl/agentddl.rb:159:in `validate_rpc_request'", "/opt/rh/ruby193/root/usr/share/ruby/mcollective/rpc/client.rb:219:in `method_missing'", "/usr/sbin/oo-admin-upgrade:50:in `block (2 levels) in upgrade_gear'", "/opt/rh/ruby193/root/usr/share/gems/gems/openshift-origin-msg-broker-mcollective-1.13.0.2/lib/openshift/mcollective_application_container_proxy.rb:2189:in `rpc_exec'", "/usr/sbin/oo-admin-upgrade:49:in `block in upgrade_gear'", "/opt/rh/ruby193/root/usr/share/ruby/timeout.rb:69:in `timeout'", "/usr/sbin/oo-admin-upgrade:41:in `upgrade_gear'", "/usr/sbin/oo-admin-upgrade:458:in `block in upgrade_from_file'", "/usr/sbin/oo-admin-upgrade:456:in `each'", "/usr/sbin/oo-admin-upgrade:456:in `upgrade_from_file'", "/usr/sbin/oo-admin-upgrade:608:in `<main>'"]
Output:
Migrating gear on node with: /usr/sbin/oo-admin-upgrade --login 'test getupcloud com' --upgrade-gear '529506efa665b7af64000059' --app-name '533' --version '' --ignore-cartridge-version
Upgrading on node...
Migrating app '53' gear '53' with uuid '52950c04a665b7af6400006f' on node 'dev-diego.ops.getupcloud.com' for user: test getupcloud com
Failed to upgrade with cmd: '/usr/sbin/oo-admin-upgrade --login 'test getupcloud com' --upgrade-gear '52950c04a665b7af6400006f' --app-name '53' --version '' ' after 2 tries with exception: Cannot validate input version: value should match ^.+$
["/opt/rh/ruby193/root/usr/share/ruby/mcollective/ddl/base.rb:144:in `rescue in validate_input_argument'", "/opt/rh/ruby193/root/usr/share/ruby/mcollective/ddl/base.rb:125:in `validate_input_argument'", "/opt/rh/ruby193/root/usr/share/ruby/mcollective/ddl/agentddl.rb:167:in `block in validate_rpc_request'", "/opt/rh/ruby193/root/usr/share/ruby/mcollective/ddl/agentddl.rb:159:in `each'", "/opt/rh/ruby193/root/usr/share/ruby/mcollective/ddl/agentddl.rb:159:in `validate_rpc_request'", "/opt/rh/ruby193/root/usr/share/ruby/mcollective/rpc/client.rb:219:in `method_missing'", "/usr/sbin/oo-admin-upgrade:50:in `block (2 levels) in upgrade_gear'", "/opt/rh/ruby193/root/usr/share/gems/gems/openshift-origin-msg-broker-mcollective-1.13.0.2/lib/openshift/mcollective_application_container_proxy.rb:2189:in `rpc_exec'", "/usr/sbin/oo-admin-upgrade:49:in `block in upgrade_gear'", "/opt/rh/ruby193/root/usr/share/ruby/timeout.rb:69:in `timeout'", "/usr/sbin/oo-admin-upgrade:41:in `upgrade_gear'", "/usr/sbin/oo-admin-upgrade:458:in `block in upgrade_from_file'", "/usr/sbin/oo-admin-upgrade:456:in `each'", "/usr/sbin/oo-admin-upgrade:456:in `upgrade_from_file'", "/usr/sbin/oo-admin-upgrade:608:in `<main>'"]
Output:
Migrating gear on node with: /usr/sbin/oo-admin-upgrade --login 'test getupcloud com' --upgrade-gear '52950c04a665b7af6400006f' --app-name '53' --version '' --ignore-cartridge-version
Upgrading on node...
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
Failures:
/usr/sbin/oo-admin-upgrade --login 'test getupcloud com' --upgrade-gear '5294d204a665b7663500002c' --app-name 'prephp54' --version '' 
/usr/sbin/oo-admin-upgrade --login 'test getupcloud com' --upgrade-gear '5294d2a6a665b76635000042' --app-name 'prephp55' --version '' 
/usr/sbin/oo-admin-upgrade --login 'test getupcloud com' --upgrade-gear '5294dd06a665b7841d000001' --app-name 'preruby' --version '' 
/usr/sbin/oo-admin-upgrade --login 'test getupcloud com' --upgrade-gear '5294f3a1a665b78897000025' --app-name '54' --version '' 
/usr/sbin/oo-admin-upgrade --login 'test getupcloud com' --upgrade-gear '5294f908a665b7af6400002d' --app-name '55' --version '' 
/usr/sbin/oo-admin-upgrade --login 'test getupcloud com' --upgrade-gear '529505d7a665b7af64000043' --app-name '544' --version '' 
/usr/sbin/oo-admin-upgrade --login 'test getupcloud com' --upgrade-gear '529506efa665b7af64000059' --app-name '533' --version '' 
/usr/sbin/oo-admin-upgrade --login 'test getupcloud com' --upgrade-gear '52950c04a665b7af6400006f' --app-name '53' --version '' 
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

#####################################################
Summary:
# of users: 3
# of gears: 8
# of failures: 8
Gear counts per thread: [8]
Additional timings:
Time gathering users: 0.063s
Time gathering active gears: 20.078s
Total execution time: 58.673s
#####################################################
Migrating app 'prephp54' gear 'prephp54' with uuid '5294d204a665b7663500002c' on node 'dev-diego.ops.getupcloud.com' for user: test getupcloud com
Failed to upgrade with cmd: '/usr/sbin/oo-admin-upgrade --login 'test getupcloud com' --upgrade-gear '5294d204a665b7663500002c' --app-name 'prephp54' --version '' ' after 2 tries with exception: Cannot validate input version: value should match ^.+$
["/opt/rh/ruby193/root/usr/share/ruby/mcollective/ddl/base.rb:144:in `rescue in validate_input_argument'", "/opt/rh/ruby193/root/usr/share/ruby/mcollective/ddl/base.rb:125:in `validate_input_argument'", "/opt/rh/ruby193/root/usr/share/ruby/mcollective/ddl/agentddl.rb:167:in `block in validate_rpc_request'", "/opt/rh/ruby193/root/usr/share/ruby/mcollective/ddl/agentddl.rb:159:in `each'", "/opt/rh/ruby193/root/usr/share/ruby/mcollective/ddl/agentddl.rb:159:in `validate_rpc_request'", "/opt/rh/ruby193/root/usr/share/ruby/mcollective/rpc/client.rb:219:in `method_missing'", "/usr/sbin/oo-admin-upgrade:50:in `block (2 levels) in upgrade_gear'", "/opt/rh/ruby193/root/usr/share/gems/gems/openshift-origin-msg-broker-mcollective-1.13.0.2/lib/openshift/mcollective_application_container_proxy.rb:2189:in `rpc_exec'", "/usr/sbin/oo-admin-upgrade:49:in `block in upgrade_gear'", "/opt/rh/ruby193/root/usr/share/ruby/timeout.rb:69:in `timeout'", "/usr/sbin/oo-admin-upgrade:41:in `upgrade_gear'", "/usr/sbin/oo-admin-upgrade:458:in `block in upgrade_from_file'", "/usr/sbin/oo-admin-upgrade:456:in `each'", "/usr/sbin/oo-admin-upgrade:456:in `upgrade_from_file'", "/usr/sbin/oo-admin-upgrade:608:in `<main>'"]
Output:
Migrating gear on node with: /usr/sbin/oo-admin-upgrade --login 'test getupcloud com' --upgrade-gear '5294d204a665b7663500002c' --app-name 'prephp54' --version '' --ignore-cartridge-version
Upgrading on node...
Migrating app 'prephp55' gear 'prephp55' with uuid '5294d2a6a665b76635000042' on node 'dev-diego.ops.getupcloud.com' for user: test getupcloud com
Failed to upgrade with cmd: '/usr/sbin/oo-admin-upgrade --login 'test getupcloud com' --upgrade-gear '5294d2a6a665b76635000042' --app-name 'prephp55' --version '' ' after 2 tries with exception: Cannot validate input version: value should match ^.+$
["/opt/rh/ruby193/root/usr/share/ruby/mcollective/ddl/base.rb:144:in `rescue in validate_input_argument'", "/opt/rh/ruby193/root/usr/share/ruby/mcollective/ddl/base.rb:125:in `validate_input_argument'", "/opt/rh/ruby193/root/usr/share/ruby/mcollective/ddl/agentddl.rb:167:in `block in validate_rpc_request'", "/opt/rh/ruby193/root/usr/share/ruby/mcollective/ddl/agentddl.rb:159:in `each'", "/opt/rh/ruby193/root/usr/share/ruby/mcollective/ddl/agentddl.rb:159:in `validate_rpc_request'", "/opt/rh/ruby193/root/usr/share/ruby/mcollective/rpc/client.rb:219:in `method_missing'", "/usr/sbin/oo-admin-upgrade:50:in `block (2 levels) in upgrade_gear'", "/opt/rh/ruby193/root/usr/share/gems/gems/openshift-origin-msg-broker-mcollective-1.13.0.2/lib/openshift/mcollective_application_container_proxy.rb:2189:in `rpc_exec'", "/usr/sbin/oo-admin-upgrade:49:in `block in upgrade_gear'", "/opt/rh/ruby193/root/usr/share/ruby/timeout.rb:69:in `timeout'", "/usr/sbin/oo-admin-upgrade:41:in `upgrade_gear'", "/usr/sbin/oo-admin-upgrade:458:in `block in upgrade_from_file'", "/usr/sbin/oo-admin-upgrade:456:in `each'", "/usr/sbin/oo-admin-upgrade:456:in `upgrade_from_file'", "/usr/sbin/oo-admin-upgrade:608:in `<main>'"]
Output:
Migrating gear on node with: /usr/sbin/oo-admin-upgrade --login 'test getupcloud com' --upgrade-gear '5294d2a6a665b76635000042' --app-name 'prephp55' --version '' --ignore-cartridge-version
Upgrading on node...
Migrating app 'preruby' gear 'preruby' with uuid '5294dd06a665b7841d000001' on node 'dev-diego.ops.getupcloud.com' for user: test getupcloud com
Failed to upgrade with cmd: '/usr/sbin/oo-admin-upgrade --login 'test getupcloud com' --upgrade-gear '5294dd06a665b7841d000001' --app-name 'preruby' --version '' ' after 2 tries with exception: Cannot validate input version: value should match ^.+$
["/opt/rh/ruby193/root/usr/share/ruby/mcollective/ddl/base.rb:144:in `rescue in validate_input_argument'", "/opt/rh/ruby193/root/usr/share/ruby/mcollective/ddl/base.rb:125:in `validate_input_argument'", "/opt/rh/ruby193/root/usr/share/ruby/mcollective/ddl/agentddl.rb:167:in `block in validate_rpc_request'", "/opt/rh/ruby193/root/usr/share/ruby/mcollective/ddl/agentddl.rb:159:in `each'", "/opt/rh/ruby193/root/usr/share/ruby/mcollective/ddl/agentddl.rb:159:in `validate_rpc_request'", "/opt/rh/ruby193/root/usr/share/ruby/mcollective/rpc/client.rb:219:in `method_missing'", "/usr/sbin/oo-admin-upgrade:50:in `block (2 levels) in upgrade_gear'", "/opt/rh/ruby193/root/usr/share/gems/gems/openshift-origin-msg-broker-mcollective-1.13.0.2/lib/openshift/mcollective_application_container_proxy.rb:2189:in `rpc_exec'", "/usr/sbin/oo-admin-upgrade:49:in `block in upgrade_gear'", "/opt/rh/ruby193/root/usr/share/ruby/timeout.rb:69:in `timeout'", "/usr/sbin/oo-admin-upgrade:41:in `upgrade_gear'", "/usr/sbin/oo-admin-upgrade:458:in `block in upgrade_from_file'", "/usr/sbin/oo-admin-upgrade:456:in `each'", "/usr/sbin/oo-admin-upgrade:456:in `upgrade_from_file'", "/usr/sbin/oo-admin-upgrade:608:in `<main>'"]
Output:
Migrating gear on node with: /usr/sbin/oo-admin-upgrade --login 'test getupcloud com' --upgrade-gear '5294dd06a665b7841d000001' --app-name 'preruby' --version '' --ignore-cartridge-version
Upgrading on node...
Migrating app '54' gear '54' with uuid '5294f3a1a665b78897000025' on node 'dev-diego.ops.getupcloud.com' for user: test getupcloud com
Failed to upgrade with cmd: '/usr/sbin/oo-admin-upgrade --login 'test getupcloud com' --upgrade-gear '5294f3a1a665b78897000025' --app-name '54' --version '' ' after 2 tries with exception: Cannot validate input version: value should match ^.+$
["/opt/rh/ruby193/root/usr/share/ruby/mcollective/ddl/base.rb:144:in `rescue in validate_input_argument'", "/opt/rh/ruby193/root/usr/share/ruby/mcollective/ddl/base.rb:125:in `validate_input_argument'", "/opt/rh/ruby193/root/usr/share/ruby/mcollective/ddl/agentddl.rb:167:in `block in validate_rpc_request'", "/opt/rh/ruby193/root/usr/share/ruby/mcollective/ddl/agentddl.rb:159:in `each'", "/opt/rh/ruby193/root/usr/share/ruby/mcollective/ddl/agentddl.rb:159:in `validate_rpc_request'", "/opt/rh/ruby193/root/usr/share/ruby/mcollective/rpc/client.rb:219:in `method_missing'", "/usr/sbin/oo-admin-upgrade:50:in `block (2 levels) in upgrade_gear'", "/opt/rh/ruby193/root/usr/share/gems/gems/openshift-origin-msg-broker-mcollective-1.13.0.2/lib/openshift/mcollective_application_container_proxy.rb:2189:in `rpc_exec'", "/usr/sbin/oo-admin-upgrade:49:in `block in upgrade_gear'", "/opt/rh/ruby193/root/usr/share/ruby/timeout.rb:69:in `timeout'", "/usr/sbin/oo-admin-upgrade:41:in `upgrade_gear'", "/usr/sbin/oo-admin-upgrade:458:in `block in upgrade_from_file'", "/usr/sbin/oo-admin-upgrade:456:in `each'", "/usr/sbin/oo-admin-upgrade:456:in `upgrade_from_file'", "/usr/sbin/oo-admin-upgrade:608:in `<main>'"]
Output:
Migrating gear on node with: /usr/sbin/oo-admin-upgrade --login 'test getupcloud com' --upgrade-gear '5294f3a1a665b78897000025' --app-name '54' --version '' --ignore-cartridge-version
Upgrading on node...
Migrating app '55' gear '55' with uuid '5294f908a665b7af6400002d' on node 'dev-diego.ops.getupcloud.com' for user: test getupcloud com
Failed to upgrade with cmd: '/usr/sbin/oo-admin-upgrade --login 'test getupcloud com' --upgrade-gear '5294f908a665b7af6400002d' --app-name '55' --version '' ' after 2 tries with exception: Cannot validate input version: value should match ^.+$
["/opt/rh/ruby193/root/usr/share/ruby/mcollective/ddl/base.rb:144:in `rescue in validate_input_argument'", "/opt/rh/ruby193/root/usr/share/ruby/mcollective/ddl/base.rb:125:in `validate_input_argument'", "/opt/rh/ruby193/root/usr/share/ruby/mcollective/ddl/agentddl.rb:167:in `block in validate_rpc_request'", "/opt/rh/ruby193/root/usr/share/ruby/mcollective/ddl/agentddl.rb:159:in `each'", "/opt/rh/ruby193/root/usr/share/ruby/mcollective/ddl/agentddl.rb:159:in `validate_rpc_request'", "/opt/rh/ruby193/root/usr/share/ruby/mcollective/rpc/client.rb:219:in `method_missing'", "/usr/sbin/oo-admin-upgrade:50:in `block (2 levels) in upgrade_gear'", "/opt/rh/ruby193/root/usr/share/gems/gems/openshift-origin-msg-broker-mcollective-1.13.0.2/lib/openshift/mcollective_application_container_proxy.rb:2189:in `rpc_exec'", "/usr/sbin/oo-admin-upgrade:49:in `block in upgrade_gear'", "/opt/rh/ruby193/root/usr/share/ruby/timeout.rb:69:in `timeout'", "/usr/sbin/oo-admin-upgrade:41:in `upgrade_gear'", "/usr/sbin/oo-admin-upgrade:458:in `block in upgrade_from_file'", "/usr/sbin/oo-admin-upgrade:456:in `each'", "/usr/sbin/oo-admin-upgrade:456:in `upgrade_from_file'", "/usr/sbin/oo-admin-upgrade:608:in `<main>'"]
Output:
Migrating gear on node with: /usr/sbin/oo-admin-upgrade --login 'test getupcloud com' --upgrade-gear '5294f908a665b7af6400002d' --app-name '55' --version '' --ignore-cartridge-version
Upgrading on node...
Migrating app '544' gear '544' with uuid '529505d7a665b7af64000043' on node 'dev-diego.ops.getupcloud.com' for user: test getupcloud com
Failed to upgrade with cmd: '/usr/sbin/oo-admin-upgrade --login 'test getupcloud com' --upgrade-gear '529505d7a665b7af64000043' --app-name '544' --version '' ' after 2 tries with exception: Cannot validate input version: value should match ^.+$
["/opt/rh/ruby193/root/usr/share/ruby/mcollective/ddl/base.rb:144:in `rescue in validate_input_argument'", "/opt/rh/ruby193/root/usr/share/ruby/mcollective/ddl/base.rb:125:in `validate_input_argument'", "/opt/rh/ruby193/root/usr/share/ruby/mcollective/ddl/agentddl.rb:167:in `block in validate_rpc_request'", "/opt/rh/ruby193/root/usr/share/ruby/mcollective/ddl/agentddl.rb:159:in `each'", "/opt/rh/ruby193/root/usr/share/ruby/mcollective/ddl/agentddl.rb:159:in `validate_rpc_request'", "/opt/rh/ruby193/root/usr/share/ruby/mcollective/rpc/client.rb:219:in `method_missing'", "/usr/sbin/oo-admin-upgrade:50:in `block (2 levels) in upgrade_gear'", "/opt/rh/ruby193/root/usr/share/gems/gems/openshift-origin-msg-broker-mcollective-1.13.0.2/lib/openshift/mcollective_application_container_proxy.rb:2189:in `rpc_exec'", "/usr/sbin/oo-admin-upgrade:49:in `block in upgrade_gear'", "/opt/rh/ruby193/root/usr/share/ruby/timeout.rb:69:in `timeout'", "/usr/sbin/oo-admin-upgrade:41:in `upgrade_gear'", "/usr/sbin/oo-admin-upgrade:458:in `block in upgrade_from_file'", "/usr/sbin/oo-admin-upgrade:456:in `each'", "/usr/sbin/oo-admin-upgrade:456:in `upgrade_from_file'", "/usr/sbin/oo-admin-upgrade:608:in `<main>'"]
Output:
Migrating gear on node with: /usr/sbin/oo-admin-upgrade --login 'test getupcloud com' --upgrade-gear '529505d7a665b7af64000043' --app-name '544' --version '' --ignore-cartridge-version
Upgrading on node...
Migrating app '533' gear '533' with uuid '529506efa665b7af64000059' on node 'dev-diego.ops.getupcloud.com' for user: test getupcloud com
Failed to upgrade with cmd: '/usr/sbin/oo-admin-upgrade --login 'test getupcloud com' --upgrade-gear '529506efa665b7af64000059' --app-name '533' --version '' ' after 2 tries with exception: Cannot validate input version: value should match ^.+$
["/opt/rh/ruby193/root/usr/share/ruby/mcollective/ddl/base.rb:144:in `rescue in validate_input_argument'", "/opt/rh/ruby193/root/usr/share/ruby/mcollective/ddl/base.rb:125:in `validate_input_argument'", "/opt/rh/ruby193/root/usr/share/ruby/mcollective/ddl/agentddl.rb:167:in `block in validate_rpc_request'", "/opt/rh/ruby193/root/usr/share/ruby/mcollective/ddl/agentddl.rb:159:in `each'", "/opt/rh/ruby193/root/usr/share/ruby/mcollective/ddl/agentddl.rb:159:in `validate_rpc_request'", "/opt/rh/ruby193/root/usr/share/ruby/mcollective/rpc/client.rb:219:in `method_missing'", "/usr/sbin/oo-admin-upgrade:50:in `block (2 levels) in upgrade_gear'", "/opt/rh/ruby193/root/usr/share/gems/gems/openshift-origin-msg-broker-mcollective-1.13.0.2/lib/openshift/mcollective_application_container_proxy.rb:2189:in `rpc_exec'", "/usr/sbin/oo-admin-upgrade:49:in `block in upgrade_gear'", "/opt/rh/ruby193/root/usr/share/ruby/timeout.rb:69:in `timeout'", "/usr/sbin/oo-admin-upgrade:41:in `upgrade_gear'", "/usr/sbin/oo-admin-upgrade:458:in `block in upgrade_from_file'", "/usr/sbin/oo-admin-upgrade:456:in `each'", "/usr/sbin/oo-admin-upgrade:456:in `upgrade_from_file'", "/usr/sbin/oo-admin-upgrade:608:in `<main>'"]
Output:
Migrating gear on node with: /usr/sbin/oo-admin-upgrade --login 'test getupcloud com' --upgrade-gear '529506efa665b7af64000059' --app-name '533' --version '' --ignore-cartridge-version
Upgrading on node...
Migrating app '53' gear '53' with uuid '52950c04a665b7af6400006f' on node 'dev-diego.ops.getupcloud.com' for user: test getupcloud com
Failed to upgrade with cmd: '/usr/sbin/oo-admin-upgrade --login 'test getupcloud com' --upgrade-gear '52950c04a665b7af6400006f' --app-name '53' --version '' ' after 2 tries with exception: Cannot validate input version: value should match ^.+$
["/opt/rh/ruby193/root/usr/share/ruby/mcollective/ddl/base.rb:144:in `rescue in validate_input_argument'", "/opt/rh/ruby193/root/usr/share/ruby/mcollective/ddl/base.rb:125:in `validate_input_argument'", "/opt/rh/ruby193/root/usr/share/ruby/mcollective/ddl/agentddl.rb:167:in `block in validate_rpc_request'", "/opt/rh/ruby193/root/usr/share/ruby/mcollective/ddl/agentddl.rb:159:in `each'", "/opt/rh/ruby193/root/usr/share/ruby/mcollective/ddl/agentddl.rb:159:in `validate_rpc_request'", "/opt/rh/ruby193/root/usr/share/ruby/mcollective/rpc/client.rb:219:in `method_missing'", "/usr/sbin/oo-admin-upgrade:50:in `block (2 levels) in upgrade_gear'", "/opt/rh/ruby193/root/usr/share/gems/gems/openshift-origin-msg-broker-mcollective-1.13.0.2/lib/openshift/mcollective_application_container_proxy.rb:2189:in `rpc_exec'", "/usr/sbin/oo-admin-upgrade:49:in `block in upgrade_gear'", "/opt/rh/ruby193/root/usr/share/ruby/timeout.rb:69:in `timeout'", "/usr/sbin/oo-admin-upgrade:41:in `upgrade_gear'", "/usr/sbin/oo-admin-upgrade:458:in `block in upgrade_from_file'", "/usr/sbin/oo-admin-upgrade:456:in `each'", "/usr/sbin/oo-admin-upgrade:456:in `upgrade_from_file'", "/usr/sbin/oo-admin-upgrade:608:in `<main>'"]
Output:
Migrating gear on node with: /usr/sbin/oo-admin-upgrade --login 'test getupcloud com' --upgrade-gear '52950c04a665b7af6400006f' --app-name '53' --version '' --ignore-cartridge-version
Upgrading on node...
Migrating gear on node with: /usr/sbin/oo-admin-upgrade --login 'test getupcloud com' --upgrade-gear '5294d204a665b7663500002c' --app-name 'prephp54' --version '2.0.0' --ignore-cartridge-version
Upgrading on node...
***time_upgrade_on_node_measured_from_broker=4449***
Upgrade on node output:
 Beginning 2.0.0 upgrade for 5294d204a665b7663500002c
Inspecting gear at /var/lib/openshift/5294d204a665b7663500002c
Pre-upgrade state: started
Marking step inspect_gear_state complete
Refreshing cartridge redhat:php:5.4:0.0.6, ignoring cartridge version.
Creating itinerary entry for incompatible upgrade of redhat:php:5.4:0.0.6
Marking step compute_itinerary complete
Migrating gear at /var/lib/openshift/5294d204a665b7663500002c
Stopping gear on node 'dev-diego'
Marking step stop_gear complete
Incompatible upgrade of cartridge redhat:php:5.4:0.0.6
Executed setup for php
rc: 
stdout: 
stderr: 
Marking step php_setup complete
Marking step php_erb complete
Ran upgrade script for php
rc: 0
stdout: 
stderr: 
Marking step upgrade_script_php complete
Marking step php_create_endpoints complete
Marking step php_connect_frontend complete
Marking step php_upgrade complete
Marking step php_rebuild_ident complete
Starting gear on node 'dev-diego'
Start gear output: 
Marking step start_gear complete
Gear restart time (ms): 225
Validating gear post-upgrade
Pre-upgrade state: started
Post-upgrade response code: 200
Marking step validate_gear complete
Cleaning up after upgrade
Total upgrade time on node (ms): 4012
gear_upgrade_json={"gear_uuid":"5294d204a665b7663500002c","hostname":"dev-diego","steps":{"inspect_gear_state":{"status":"complete","errors":[],"context":{"preupgrade_state":"started"}},"compute_itinerary":{"status":"complete","errors":[],"context":{}},"stop_gear":{"status":"complete","errors":[],"context":{}},"php_upgrade":{"status":"complete","errors":[],"context":{"cartridge":"php","compatible":false}},"php_setup":{"status":"complete","errors":[],"context":{"cartridge":"php","stdout":""}},"php_erb":{"status":"complete","errors":[],"context":{"cartridge":"php"}},"upgrade_script_php":{"status":"complete","errors":[],"context":{"cartridge":"php","rc":0,"stdout":"","stderr":""}},"php_create_endpoints":{"status":"complete","errors":[],"context":{"cartridge":"php"}},"php_connect_frontend":{"status":"complete","errors":[],"context":{"cartridge":"php"}},"php_rebuild_ident":{"status":"complete","errors":[],"context":{"cartridge":"php"}},"start_gear":{"status":"complete","errors":[],"context":{"output":""}},"validate_gear":{"status":"complete","errors":[],"context":{"preupgrade_state":"started","postupgrade_response_code":"200"}}},"upgrade_complete":true,"errors":[],"itinerary_entries":{"php-5.4":"incompatible"},"times":{"upgrade_on_node_measured_from_node":4012,"restart":225}}

***time_total_upgrade_gear_measured_from_broker=63128***
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
Failures:
/usr/sbin/oo-admin-upgrade --login 'test getupcloud com' --upgrade-gear '5294d204a665b7663500002c' --app-name 'prephp54' --version '' 
/usr/sbin/oo-admin-upgrade --login 'test getupcloud com' --upgrade-gear '5294d2a6a665b76635000042' --app-name 'prephp55' --version '' 
/usr/sbin/oo-admin-upgrade --login 'test getupcloud com' --upgrade-gear '5294dd06a665b7841d000001' --app-name 'preruby' --version '' 
/usr/sbin/oo-admin-upgrade --login 'test getupcloud com' --upgrade-gear '5294f3a1a665b78897000025' --app-name '54' --version '' 
/usr/sbin/oo-admin-upgrade --login 'test getupcloud com' --upgrade-gear '5294f908a665b7af6400002d' --app-name '55' --version '' 
/usr/sbin/oo-admin-upgrade --login 'test getupcloud com' --upgrade-gear '529505d7a665b7af64000043' --app-name '544' --version '' 
/usr/sbin/oo-admin-upgrade --login 'test getupcloud com' --upgrade-gear '529506efa665b7af64000059' --app-name '533' --version '' 
/usr/sbin/oo-admin-upgrade --login 'test getupcloud com' --upgrade-gear '52950c04a665b7af6400006f' --app-name '53' --version '' 
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

#####################################################
Summary:
# of users: 3
# of gears: 8
# of failures: 8
Gear counts per thread: [8]
Additional timings:
    upgrade_on_node_measured_from_broker=4.449s
    upgrade_on_node_measured_from_node=4.012s
    restart=0.225s
    total_upgrade_gear_measured_from_broker=63.128s
Time gathering users: 0.024s
Time gathering active gears: 20.488s
Total execution time: 89.472s
#####################################################

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]