[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Notice: Update Your Vagrant



> On Dec 17, 2014, at 15:16, N. Harrison Ripps <nhr redhat com> wrote:
> 
> Hey all--
> As of Vagrant 1.7.1 there are some syntax changes that make the current origin Vagrantfile error out. I have created a PR for the updated syntax, and I have upgraded Vagrant on our Jenkins server accordingly.
> 
> If you use Vagrant as part of your development workflow, you will also need to upgrade to the latest version of Vagrant. After the PR is merged, an error like this:
> 
> ======
> Setting `id` on a provisioner is deprecated. Please use the
> new syntax of `config.vm.provision "name", type: "type"
> where "name" is the replacement for `id`. This will be
> fully removed in Vagrant 1.8.
> Bringing machine 'openshiftdev' up with 'virtualbox' provider...
> There are errors in the configuration of this machine. Please fix
> the following errors and try again:
> 
> vm:
> * The following settings shouldn't exist: id
> 
> shell provisioner:
> * The following settings shouldn't exist: id
> ======
> 
> ...means you haven't upgraded yet.
> 
> You can track the merge status of the PR here:
> https://github.com/openshift/origin/pull/578

This is merged now. However, at the suggestion of cleverer folks, I have added a provision for devs who can't upgrade to Vagrant 1.7.1, so things should still work for you. Please let me know if you run into any issues.

--Harrison



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]