[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Accidentally ran rm -rf in app-root folder.

I executed those commands and got these error:

Shashanks-MacBook-Pro:sandbox shashank$ rhc deployment-list -a sandbox
Nov 12 10:20 PM, deployment 313b6f76
You have new mail in /var/mail/shashank
Shashanks-MacBook-Pro:sandbox shashank$ rhc deployment-activate 313b6f76 --app sandbox
Activating deployment '313b6f76' on application sandbox ...
Deployment id 313b6f76 is invalid
Error activating deployment. You can try to activate manually with:
ssh -t 540a83d45004465dde0001c7 sandbox-hugehop rhcloud com 'gear activate --all 313b6f76'
SSH command finished with exit status = 255
Shashanks-MacBook-Pro:sandbox shashank$ ssh -t 540a83d45004465dde0001c7 sandbox-hugehop rhcloud com 'gear activate --all 313b6f76'
Deployment id 313b6f76 is invalid
Connection to sandbox-hugehop.rhcloud.com closed.
Shashanks-MacBook-Pro:sandbox shashank$

Any idea whats going wrong here.


On 23-Dec-2014, at 12:29 am, Andy Goldstein <agoldste redhat com> wrote:

The argument to -a should be sandbox (your application’s name).

On Dec 22, 2014, at 1:58 PM, Shashank <shashank hugehop com> wrote:

I tried running this locally

Shashanks-MacBook-Pro:sandbox shashank$ pwd
Shashanks-MacBook-Pro:sandbox shashank$ ls -la
total 128
drwxr-xr-x  15 shashank  staff    510 Oct 12 18:52 .
drwxr-xr-x   3 shashank  staff    102 Oct 12 18:51 ..
drwxr-xr-x  17 shashank  staff    578 Dec 19 20:14 .git
drwxr-xr-x   7 shashank  staff    238 Oct 12 18:52 .openshift
-rwxr-xr-x   1 shashank  staff    146 Oct 12 18:52 CONTRIBUTING.md
drwxr-xr-x  14 shashank  staff    476 Oct 21 11:15 app
-rwxr-xr-x   1 shashank  staff   2452 Oct 12 18:52 artisan
drwxr-xr-x   5 shashank  staff    170 Oct 12 18:52 bootstrap
-rwxr-xr-x   1 shashank  staff    785 Oct 12 18:52 composer.json
-rw-r--r--   1 shashank  staff  39627 Oct 12 18:52 index_init.php
drwxr-xr-x   7 shashank  staff    238 Oct 12 18:52 php
-rwxr-xr-x   1 shashank  staff    680 Oct 12 18:52 phpunit.xml
drwxr-xr-x   7 shashank  staff    238 Oct 12 18:52 public
-rwxr-xr-x   1 shashank  staff   1912 Oct 12 18:52 readme.md
-rwxr-xr-x   1 shashank  staff    519 Oct 12 18:52 server.php
Shashanks-MacBook-Pro:sandbox shashank$ rhc apps
sandbox @ http://sandbox-hugehop.rhcloud.com/ (uuid: 540a83d45004465dde0001c7)
  Domain:     hugehop
  Created:    Sep 06  9:17 AM
  Gears:      1 (defaults to small)
  Deployment: auto (on git push)

  php-5.4 (PHP 5.4)
    Gears: Located with mysql-5.5, phpmyadmin-4, cron-1.4

  mysql-5.5 (MySQL 5.5)
    Gears:          Located with php-5.4, phpmyadmin-4, cron-1.4
    Database Name:  sandbox
    Password:       IUq5QSQ3-IvG
    Username:       adminqam9mnr

  phpmyadmin-4 (phpMyAdmin 4.0)
    Gears:          Located with php-5.4, mysql-5.5, cron-1.4

  cron-1.4 (Cron 1.4)
    Gears: Located with php-5.4, mysql-5.5, phpmyadmin-4

You have access to 1 application.
Shashanks-MacBook-Pro:sandbox shashank$ rhc deployment-list -a 540a83d45004465dde0001c7
Application '540a83d45004465dde0001c7' not found.
Shashanks-MacBook-Pro:sandbox shashank$

How to run rhc deployment-list ?
Any help is appreciated.

On 19-Dec-2014, at 8:12 pm, Shashank <shashank hugehop com> wrote:

Hi Andy
I did had data in app-root/data
Output of command before deleting it :
[sandbox-hugehop.rhcloud.com 540a83d45004465dde0001c7]\> cd app-root/
[sandbox-hugehop.rhcloud.com app-root]\> du -sh *
0 build-dependencies
81M data
0 dependencies
83M logs
0 repo
141M runtime

On 19-Dec-2014, at 7:44 pm, Andy Goldstein <agoldste redhat com> wrote:


You can use rhc deployment-list to see candidates to activate.

Note, if you had data in app-root/data, it’s not recoverable via this method.


On Dec 19, 2014, at 9:12 AM, Shashank <shashank hugehop com> wrote:

Where should I run this command ? on openshift server using ssh.
When i did that I was getting this
[sandbox-hugehop.rhcloud.com 540a83d45004465dde0001c7]\> rhc deployment-activate
bash: rhc: command not found
[sandbox-hugehop.rhcloud.com 540a83d45004465dde0001c7]\> rvm gemset use global
bash: rvm: command not found

Or should I need to run this locally?
This might be naive question but I am taking over this from my ex team mate and I am new to openshift. Really appreciate the help.

On 19-Dec-2014, at 7:21 pm, Andy Goldstein <agoldste redhat com> wrote:

rhc deployment-activate

dev mailing list
dev lists openshift redhat com

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]