[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Missing gem when running oo-admin-* script



Hi all,

I have installed OpenShift Origin with a 2-node deployment. One node for Broker/Namerserver/etc, and another node for "Node", with the "oo-install" method. Afterwards, I am trying to run admin tool such as `oo-admin-ctl-user -l <usernme>`, but returned with:

Error while loading gems for the broker:
Could not find activesupport-3.2.8 in any of the sources
This usually means gem RPMs have been updated and Gemfile.lock is stale.
Please restart the openshift-broker service to update it, and try again.

I have run `gem install -v <version> <gem>` manually for a few times, but realized this couldn't be the right solution. What is the proper way to install back all the gems required for all oo-* scripts?

fyi, I installed ruby 2.1.5 with rvm systemwide/multi-users installation.

Thanks,

- Jimmy Chu


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]