[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: dev Digest, Vol 23, Issue 31



Harisson, thank you for pointing that out, I have, I noticed that when I upgraded the PHP version to 5.4, it upgrade MySQL to 5.5 too and that broke the MySQL 5.1 cartridge as you suggested. I have repackaged the openshift-origin-cartridge-mysql cartridge to use the new MySQL 5.5 using Software Collections for MySQL 5.5 and everything works well now. I am using CentOS 6.5 x86_64 as the base OS.

Note: I had to force a refresh of the cache before it reflected the updated cartridge for MySQL by deleting the cached directories in /var/www/openshift/broker/tmp/cache. Also I restarted the broker service by issuing service openshift-broker restart and finally cleared the cache officially by issuing oo-admin-broker-cache --console

Kind Regards


On Tue, Feb 18, 2014 at 7:53 AM, <dev-request lists openshift redhat com> wrote:
Send dev mailing list submissions to
        dev lists openshift redhat com

To subscribe or unsubscribe via the World Wide Web, visit
        http://lists.openshift.redhat.com/openshiftmm/listinfo/dev
or, via email, send a message with subject or body 'help' to
        dev-request lists openshift redhat com

You can reach the person managing the list at
        dev-owner lists openshift redhat com

When replying, please edit your Subject line so it is more specific
than "Re: Contents of dev digest..."

Today's Topics:

   1. Re: Operation not permitted Failed to create mysqldb,
      (N. Harrison Ripps)
   2. Re: oo-install broker failing to load (N. Harrison Ripps)
   3. Re: error Moped::Cluster nodes after oo-install
      (N. Harrison Ripps)
   4. Re: oo-install broker failing to load (Aditi Ghag)
   5. Re: oo-install broker failing to load (N. Harrison Ripps)
   6. RE: Infinispan as Remote server mode with HotRod
      (priyanka e gupta accenture com)


---------- Forwarded message ----------
From: "N. Harrison Ripps" <hripps redhat com>
To: Mfawa Alfred Onen <muffycompoqm gmail com>
Cc: dev lists openshift redhat com
Date: Mon, 17 Feb 2014 14:53:35 -0500
Subject: Re: Operation not permitted Failed to create mysqldb,
Hey Mfawa—

On Feb 17, 2014, at 2:27 PM, Mfawa Alfred Onen <muffycompoqm gmail com> wrote:

> Hi All, I have been banging my head around this permission error. I get the following error when I tail the log files in the broker
>
> tail -f /var/log/openshift/node/platform.log
>
>
> Installing mysqld
> Cannot change ownership of the database directories to the 'mysql' user.  Check that you have the necessary permissions and try again.

How did you install mysql? A little googling suggests that this error occurs when mysql isn’t properly installed. Did you use oo-install? If so, do you have the install output anywhere? Which RPM are you getting mysql from?

>
> When I look at the web console I see the error message formatted as shown in the attachment.
>
> What am I doing wrong? Any input will be appreciated.
>
> Regards!
>
>
> --
> Mfawa Alfred Onen
> M.Sc Telecoms, B.Eng Elect/Elect, CCNA, RHCE(in view)
> System Administrator
> Department of Computer Science,
> Bingham University.
>
> E-Mail: systemadmin binghamuni edu ng
> Phone1: +234 805 944 3154
> Phone2: +234 803 079 6088
>
> <cartridge_error.png>_______________________________________________
> dev mailing list
> dev lists openshift redhat com
> http://lists.openshift.redhat.com/openshiftmm/listinfo/dev





---------- Forwarded message ----------
From: "N. Harrison Ripps" <hripps redhat com>
To: Aditi Ghag <aditivghag gmail com>
Cc: dev lists openshift redhat com
Date: Mon, 17 Feb 2014 14:59:35 -0500
Subject: Re: oo-install broker failing to load
Hi Aditi—
What OS are you trying this on?

On Feb 14, 2014, at 4:36 PM, Aditi Ghag <aditivghag gmail com> wrote:

> Hi,
>
> I have installed OpenShift Origin using the oo-install command(sh <(curl -s https://install.openshift.com/)).
> I have the components broker, msgserver, DBserver and node setup on four different machines.
>
> The broker application is failing to load. Here is the output of the oo-diagnostic script-
> /usr/sbin/oo-diagnostics
>
> FAIL: rescue in load_broker_rails_env
>
>         Broker application failed to load. This is often a gem dependency problem.
>
>         Updating rubygem RPMs and restarting openshift-broker
>
>         to regenerate the broker Gemfile.lock may fix the problem.
>
>         The actual error encountered was:
>
>         #<Moped::Errors::AuthenticationFailure: The operation: #<Moped::Protocol::Commands::Authenticate
>
>   @length=163
>
>   @request_id=3
>
>   @response_to=0
>
>   @op_code=2004
>
>   @flags=[]
>
>   @full_collection_name="openshift_broker.$cmd"
>
>   @skip=0
>
>   @limit=-1
>
>   @selector={:authenticate=>1, :user=>"openshift", :nonce=>"cfc0ea89ffac344b", :key=>"e0829b4e2c9a8d23aa483596011ac07d"}
>
>   @fields=nil>
>
> failed with error 18: "auth fails"
>
>
>
> See https://github.com/mongodb/mongo/blob/master/docs/errors.md
>
> for details about this error.>
>
>         ***
>
>         THIS PROBLEM NEEDS TO BE RESOLVED FOR THE BROKER TO WORK.
>
>         DISABLING BROKER TESTS.
>
>         ***
>
> When I googled this error, I came across a thread where this error message was mentioned. But, there was no fix mentioned.
>
> Please note that I have installed the ruby193-rubygem-sass-twitter-bootstrap package.
>
> Please suggest what the exact problem is and how to go about solving this error. Let me know if you need any other information.
>
>
>
> Thanks,
>
> Aditi
>
>
>
>
> _______________________________________________
> dev mailing list
> dev lists openshift redhat com
> http://lists.openshift.redhat.com/openshiftmm/listinfo/dev





---------- Forwarded message ----------
From: "N. Harrison Ripps" <hripps redhat com>
To: Mochamad Yusuf <fearleeee gmail com>
Cc: "dev lists openshift redhat com" <dev lists openshift redhat com>
Date: Mon, 17 Feb 2014 14:59:55 -0500
Subject: Re: error Moped::Cluster nodes after oo-install
Hi Mochamad—
What OS are you trying this on?

On Feb 15, 2014, at 7:46 PM, Mochamad Yusuf <fearleeee gmail com> wrote:

> i just finished install origin using oo-install
> fedora 19 minimal install, two machine ( 1 broker and 1 node)
> i get some error when running oo-accept-broker and oo-accept-node
> 10.11.227.32 ==> my broker's IP
> output from oo-accept-broker
> [root broker ~]# oo-accept-broker
> NOTICE: SELinux is Enforcing
> NOTICE: SELinux is  Enforcing
> exception: connect failed
> FAIL: error logging into mongo db:   MOPED: Retrying connection to primary for replica set <Moped::Cluster nodes=[<Moped::Node resolved_address="10.11.227.32:27017">]>:  MOPED: Retrying connection to primary for replica set <Moped::Cluster nodes=[<Moped::Node resolved_address="10.11.227.32:27017">]>/MOPED: --username Retrying, exit code: 1
> NOTICE: unknown auth class: MOPED: Retrying connection to primary for replica set <Moped::Cluster nodes=[<Moped::Node resolved_address="10.11.227.32:27017">]>
> NOTICE: unknown dns class: MOPED: Retrying connection to primary for replica set <Moped::Cluster nodes=[<Moped::Node resolved_address="10.11.227.32:27017">]>
> NOTICE: unknown messaging class: MOPED: Retrying connection to primary for replica set <Moped::Cluster nodes=[<Moped::Node resolved_address="10.11.227.32:27017">]>
> 1 ERRORS
>
> output from oo-accept-node
> [root node1 ~]# oo-accept-node
> FAIL: /etc/openshift/node.conf: BROKER_HOST broker.openshift.iard.com does not resolve (getaddrinfo: Name or service not known)
> FAIL: /etc/openshift/node.conf: PUBLIC_HOSTNAME node1.openshift.iard.com does not resolve as a FQDN (getaddrinfo: Name or service not known)
> FAIL: no manifest in the cart repo matches /usr/libexec/openshift/cartridges/php/metadata/manifest.yml
> FAIL: no manifest in the cart repo matches /usr/libexec/openshift/cartridges/jenkins-client/metadata/manifest.yml
> FAIL: no manifest in the cart repo matches /usr/libexec/openshift/cartridges/perl/metadata/manifest.yml
> 5 ERRORS
>
> mco ping -v
> The ping application failed to run, use -v for full error details: undefined method `body' for nil:NilClass
>
> undefined method `body' for nil:NilClass (NoMethodError)
>         from /usr/libexec/mcollective/mcollective/connector/activemq.rb:246:in `receive'  <----
>         from /usr/share/ruby/vendor_ruby/mcollective/client.rb:89:in `receive'
>         from /usr/share/ruby/vendor_ruby/mcollective/client.rb:152:in `block (2 levels) in req'
>         from /usr/share/ruby/vendor_ruby/mcollective/client.rb:151:in `loop'
>         from /usr/share/ruby/vendor_ruby/mcollective/client.rb:151:in `block in req'
>         from /usr/share/ruby/timeout.rb:66:in `timeout'
>         from /usr/share/ruby/vendor_ruby/mcollective/client.rb:148:in `req'
>         from /usr/libexec/mcollective/mcollective/application/ping.rb:58:in `main'
>         from /usr/share/ruby/vendor_ruby/mcollective/application.rb:285:in `run'
>         from /usr/share/ruby/vendor_ruby/mcollective/applications.rb:23:in `run'
>         from /usr/sbin/mco:20:in `<main>'
>
>
> what can i do to solve it ??
>
> _______________________________________________
> dev mailing list
> dev lists openshift redhat com
> http://lists.openshift.redhat.com/openshiftmm/listinfo/dev





---------- Forwarded message ----------
From: Aditi Ghag <aditivghag gmail com>
To: "N. Harrison Ripps" <hripps redhat com>
Cc: "dev lists openshift redhat com" <dev lists openshift redhat com>
Date: Mon, 17 Feb 2014 15:02:28 -0500
Subject: Re: oo-install broker failing to load
Hi Harrison,

Thanks for your reply.

I am using the redhat 6.5 OS.

Thanks,
Aditi



> On 17-Feb-2014, at 14:59, "N. Harrison Ripps" <hripps redhat com> wrote:
>
> Hi Aditi—
> What OS are you trying this on?
>
>> On Feb 14, 2014, at 4:36 PM, Aditi Ghag <aditivghag gmail com> wrote:
>>
>> Hi,
>>
>> I have installed OpenShift Origin using the oo-install command(sh <(curl -s https://install.openshift.com/)).
>> I have the components broker, msgserver, DBserver and node setup on four different machines.
>>
>> The broker application is failing to load. Here is the output of the oo-diagnostic script-
>> /usr/sbin/oo-diagnostics
>>
>> FAIL: rescue in load_broker_rails_env
>>
>>        Broker application failed to load. This is often a gem dependency problem.
>>
>>        Updating rubygem RPMs and restarting openshift-broker
>>
>>        to regenerate the broker Gemfile.lock may fix the problem.
>>
>>        The actual error encountered was:
>>
>>        #<Moped::Errors::AuthenticationFailure: The operation: #<Moped::Protocol::Commands::Authenticate
>>
>>   length=163
>>
>>   request_id=3
>>
>>   response_to=0
>>
>>   op_code=2004
>>
>>   flags=[]
>>
>>   full_collection_name="openshift_broker.$cmd"
>>
>>   skip=0
>>
>>   limit=-1
>>
>>   selector={:authenticate=>1, :user=>"openshift", :nonce=>"cfc0ea89ffac344b", :key=>"e0829b4e2c9a8d23aa483596011ac07d"}
>>
>>   fields=nil>
>>
>> failed with error 18: "auth fails"
>>
>>
>>
>> See https://github.com/mongodb/mongo/blob/master/docs/errors.md
>>
>> for details about this error.>
>>
>>        ***
>>
>>        THIS PROBLEM NEEDS TO BE RESOLVED FOR THE BROKER TO WORK.
>>
>>        DISABLING BROKER TESTS.
>>
>>        ***
>>
>> When I googled this error, I came across a thread where this error message was mentioned. But, there was no fix mentioned.
>>
>> Please note that I have installed the ruby193-rubygem-sass-twitter-bootstrap package.
>>
>> Please suggest what the exact problem is and how to go about solving this error. Let me know if you need any other information.
>>
>>
>>
>> Thanks,
>>
>> Aditi
>>
>>
>>
>>
>> _______________________________________________
>> dev mailing list
>> dev lists openshift redhat com
>> http://lists.openshift.redhat.com/openshiftmm/listinfo/dev
>




---------- Forwarded message ----------
From: "N. Harrison Ripps" <hripps redhat com>
To: Aditi Ghag <aditivghag gmail com>
Cc: "dev lists openshift redhat com" <dev lists openshift redhat com>
Date: Mon, 17 Feb 2014 15:33:46 -0500
Subject: Re: oo-install broker failing to load
Hey Aditi—

On Feb 17, 2014, at 3:02 PM, Aditi Ghag <aditivghag gmail com> wrote:

> Hi Harrison,
>
> Thanks for your reply.
>
> I am using the redhat 6.5 OS.

Okay, cool—see below.

>
> Thanks,
> Aditi
>
>
>
>> On 17-Feb-2014, at 14:59, "N. Harrison Ripps" <hripps redhat com> wrote:
>>
>> Hi Aditi—
>> What OS are you trying this on?
>>
>>> On Feb 14, 2014, at 4:36 PM, Aditi Ghag <aditivghag gmail com> wrote:
>>>
>>> Hi,
>>>
>>> I have installed OpenShift Origin using the oo-install command(sh <(curl -s https://install.openshift.com/)).
>>> I have the components broker, msgserver, DBserver and node setup on four different machines.
>>>
>>> The broker application is failing to load. Here is the output of the oo-diagnostic script-
>>> /usr/sbin/oo-diagnostics
>>>
>>> FAIL: rescue in load_broker_rails_env
>>>
>>>       Broker application failed to load. This is often a gem dependency problem.
>>>
>>>       Updating rubygem RPMs and restarting openshift-broker
>>>
>>>       to regenerate the broker Gemfile.lock may fix the problem.
>>>
>>>       The actual error encountered was:
>>>
>>>       #<Moped::Errors::AuthenticationFailure: The operation: #<Moped::Protocol::Commands::Authenticate

It is possible that MongoDB didn’t fully install. Try this:

1. Look at the MongoDB credentials in your broker config file. The config file is either:
    * /etc/openshift/broker.conf or
    * /etc/openshift/broker-dev.conf
   You want the MONGO_* values

2. Try to connect directly to MongoDB from the command line on the broker:
   `mongo localhost:27017/<MONGO_DB> -u <MONGO_USER> -p <MONGOPASSWORD>`

If you -can’t- connect that way, then the Broker mongo configuration needs some help. In that case, have a look at the “Configure mongos” portion of the Comprehensive Deployment Guide: http://openshift.github.io/documentation/oo_deployment_guide_comprehensive.html#configure-em-mongod-em

>>>
>>> @length=163
>>>
>>> @request_id=3
>>>
>>> @response_to=0
>>>
>>> @op_code=2004
>>>
>>> @flags=[]
>>>
>>> @full_collection_name="openshift_broker.$cmd"
>>>
>>> @skip=0
>>>
>>> @limit=-1
>>>
>>> @selector={:authenticate=>1, :user=>"openshift", :nonce=>"cfc0ea89ffac344b", :key=>"e0829b4e2c9a8d23aa483596011ac07d"}
>>>
>>> @fields=nil>
>>>
>>> failed with error 18: "auth fails"
>>>
>>>
>>>
>>> See https://github.com/mongodb/mongo/blob/master/docs/errors.md
>>>
>>> for details about this error.>
>>>
>>>       ***
>>>
>>>       THIS PROBLEM NEEDS TO BE RESOLVED FOR THE BROKER TO WORK.
>>>
>>>       DISABLING BROKER TESTS.
>>>
>>>       ***
>>>
>>> When I googled this error, I came across a thread where this error message was mentioned. But, there was no fix mentioned.
>>>
>>> Please note that I have installed the ruby193-rubygem-sass-twitter-bootstrap package.
>>>
>>> Please suggest what the exact problem is and how to go about solving this error. Let me know if you need any other information.
>>>
>>>
>>>
>>> Thanks,
>>>
>>> Aditi
>>>
>>>
>>>
>>>
>>> _______________________________________________
>>> dev mailing list
>>> dev lists openshift redhat com
>>> http://lists.openshift.redhat.com/openshiftmm/listinfo/dev
>>





---------- Forwarded message ----------
From: <priyanka e gupta accenture com>
To: <bparees redhat com>
Cc: dev lists openshift redhat com
Date: Tue, 18 Feb 2014 06:53:20 +0000
Subject: RE: Infinispan as Remote server mode with HotRod
Hi Ben,

Thanks again for reply. I have tried values for the environment variables in hotrod-client.properties file as :

$OPENSHIFT_GEAR_DNS:$OPENSHIFT_INFINISPAN_TCP_PROXY_PORT

Here $OPENSHIFT_GEAR_DNS is the variable which I get after doing ssh into Infinispan gear.

In Logs I can see its not able to connect with the Infinispan server running in scaled application. Error logs are:


java.lang.RuntimeException: org.infinispan.client.hotrod.exceptions.TransportException:: Could not fetch transport
org.jboss.weld.util.reflection.SecureReflectionAccess.runAsInstantiation(SecureReflectionAccess.java:186)
org.infinispan.client.hotrod.exceptions.TransportException:: Could not connect to server: 5302f1df1---a9a000037-test.rhcloud.com/50.17.194.185:38047
org.infinispan.client.hotrod.impl.transport.tcp.TcpTransport.<init>(TcpTransport.java:90)


Thanks,
Priyanka Gupta

-----Original Message-----
From: Ben Parees [mailto:bparees redhat com]
Sent: Monday, February 17, 2014 8:17 PM
To: Gupta, Priyanka E.
Cc: wdecoste redhat com; dev lists openshift redhat com
Subject: Re: Infinispan as Remote server mode with HotRod

----- Original Message -----
> From: "priyanka e gupta" <priyanka e gupta accenture com>
> To: bparees redhat com
> Cc: wdecoste redhat com, dev lists openshift redhat com
> Sent: Monday, February 17, 2014 9:39:23 AM
> Subject: RE: Infinispan as Remote server mode with HotRod
>
> Hi,
>
> Have already tried with OPENSHIFT_GEAR_DNS value which is something
> like 5301f6----38f00001a-unit.rhcloud.com. Still there is a issue.
> Mentioned in my previous mail also:
>
>  I Have also tried  replacing value of OPENSHIFT_INFINISPAN_PORT  with
> OPENSHIFT_GEAR_DNS, but still a issue as:

1) as mentioned earlier, OPENSHIFT_INFINISPAN_PORT is the wrong value to use, it is never going to work from a remote gear.

2) You can't replace the port with the dns (hostname).  You need to be using the hostname and the port in conjunction.

$GEAR_DNS:$OPENSHIFT_INFINISPAN_TCP_PROXY_PORT

>
>  org.infinispan.client.hotrod.exceptions.TransportException::
>  java.net.SocketTimeoutException
> >
>
> Thanks,
> Priyanka
> -----Original Message-----
> From: Ben Parees [mailto:bparees redhat com]
> Sent: Monday, February 17, 2014 7:55 PM
> To: Gupta, Priyanka E.
> Cc: wdecoste redhat com; dev lists openshift redhat com
> Subject: Re: Infinispan as Remote server mode with HotRod
>
> OPENSHIFT_INFINISPAN_IP is not the right variable to use..that is
> going to be the local ip (127.x.x.x) for infinispan which is only
> valid within the infinispan gear.  you need to use the DNS entry for
> the infinispan gear, which you can find as GEAR_DNS on the infinispan
> gear (same as the hostname you use to ssh into the infinispan gear).
>
>
> Ben Parees | OpenShift
>
> ----- Original Message -----
> > From: "priyanka e gupta" <priyanka e gupta accenture com>
> > To: bparees redhat com
> > Cc: wdecoste redhat com, dev lists openshift redhat com
> > Sent: Monday, February 17, 2014 7:19:09 AM
> > Subject: RE: Infinispan as Remote server mode with HotRod
> >
> > Hi Ben,
> >
> > Thanks a lot for response. Now I am able to get proxy varibles after
> > ssh into Infinispan cartridge.
> >
> > But I have an application deployed in separate gear. It has
> > hotrod-client.properties file as:
> >
> > infinispan.client.hotrod.server_list = $OPENSHIFT_INFINISPAN_IP:$
> > OPENSHIFT_INFINISPAN_TCP_PROXY_PORT;
> > infinispan.client.hotrod.socket_timeout = 500
> > infinispan.client.hotrod.connect_timeout = 10
> >
> > Variable are replaced by the actual  value. But it still gives error
> > saying could not fetch the transport:
> >
> > org.infinispan.client.hotrod.exceptions.TransportException:: Could
> > not fetch transport
> >
> >
> > I Have also tried  replacing value of OPENSHIFT_INFINISPAN_PORT
> > with OPENSHIFT_GEAR_DNS, but still a issue as:
> >
> > org.infinispan.client.hotrod.exceptions.TransportException::
> > java.net.SocketTimeoutException
> >
> > Is it possible to achieve it with application deployed in separate
> > gear. If yes, how?
> >
> > Thanks a ton in advance..
> >
> >
> > Thanks,
> > Priyanka
> >
> >
> > -----Original Message-----
> > From: Ben Parees [mailto:bparees redhat com]
> > Sent: Monday, February 17, 2014 2:54 AM
> > To: Gupta, Priyanka E.
> > Cc: wdecoste redhat com; dev lists openshift redhat com
> > Subject: Re: Infinispan as Remote server mode with HotRod
> >
> > Are you looking in the infinispan gear or your web framework gear?   The
> > env
> > variables will only appear in the infinispan gear.
> >
> > Here is how I deployed the infinispan cartridge you referenced and
> > confirmed the presence of the environment variables:
> >
> > 1) create app
> > rhc app create inf jbossews-2
> > http://cartreflect-claytondev.rhcloud.com/reflect?github=lunafromthe
> > mo on/openshift-origin-cartridge-infinispan
> > -s
> >
> > 2) ssh into the infinispan gear (important, this is the infinispan
> > gear and not the main gear.  You can list all the gears via "rhc app
> > show appname
> > --gears)
> >
> > ssh  5-----------e 5-----------e-bparees rhcloud com
> >
> > 3) display environment variables
> > [5-----------e-bparees.rhcloud.com 5-----------e]\> env | grep INF |
> > grep PROXY
> > OPENSHIFT_INFINISPAN_TCP_PROXY_PORT=43197
> > OPENSHIFT_INFINISPAN_CLUSTER_PROXY_PORT=43196
> >
> > Note that if the infinispan cartridge in question published its
> > environment variables, they would also appears in the jbossews gear
> > (or whatever other cartridge you use for a web framework) since
> > those subscribe to environment publications (see the mysql cartridge
> > for an example of a cartridge that publishes environment variables
> > to other
> > cartridges)
> >
> >
> > Ben Parees | OpenShift
> >
> > ----- Original Message -----
> > > From: "priyanka e gupta" <priyanka e gupta accenture com>
> > > To: bparees redhat com, wdecoste redhat com,
> > > dev lists openshift redhat com
> > > Sent: Saturday, February 15, 2014 11:33:59 PM
> > > Subject: RE: Infinispan as Remote server mode with HotRod
> > >
> > > Hi,
> > >
> > >
> > > There is no such variable I could find for TCP even after adding
> > > cartridge in Scaled app as OPENSHIFT_INFINISPAN_TCP_PROXY_PORT.
> > >
> > >
> > > Thanks & Regards
> > >
> > > Priyanka Gupta
> > >
> > > ________________________________
> > > From: Ben Parees [bparees redhat com]
> > > Sent: 15 February 2014 21:27:47
> > > To: wdecoste redhat com; dev lists openshift redhat com; Gupta,
> > > Priyanka E.
> > > Subject: RE: Infinispan as Remote server mode with HotRod
> > >
> > > Resending my reply from a few days ago:
> > >
> > >
> > > Did you see the PROXY_PORT environment variables? That is the
> > > externally exposed port for the cartridge which is what you need
> > > to use when communicating to the gear from a different gear or application:
> > >
> > > OPENSHIFT_INFINISPAN_TCP_PROXY_PORT=38048
> > > OPENSHIFT_INFINISPAN_HTTP_PROXY_PORT=38046
> > > OPENSHIFT_INFINISPAN_CLUSTER_PROXY_PORT=38047
> > >
> > > you also need to be using the external IP/DNS for the gear, which
> > > you can find in OPENSHIFT_GEAR_DNS
> > >
> > > You will only get those PROXY ports exposed if you deploy the
> > > infinispan cartridge in a scaled application.
> > >
> > >
> > >
> > > Sent from my Android phone using TouchDown
> > > (www.nitrodesk.com<UrlBlockedError.aspx>)
> > >
> > >
> > > -----Original Message-----
> > > From: [priyanka e gupta accenture com]
> > > Received: Saturday, 15 Feb 2014, 0:13
> > > To: wdecoste redhat com, dev lists openshift redhat com
> > > Subject: RE: Infinispan as Remote server mode with HotRod
> > >
> > >
> > > Hi,
> > >
> > > Please reply how this can be achieved? waiting for the response.
> > >
> > >
> > > Thanks & Regards
> > >
> > > Priyanka Gupta
> > >
> > > ________________________________
> > > From: Gupta, Priyanka E.
> > > Sent: 12 February 2014 16:08:36
> > > To: wdecoste redhat com; dev lists openshift redhat com
> > > Cc: Ganesh, Rupa; Madathilthattantav, S.
> > > Subject: Infinispan as Remote server mode with HotRod
> > >
> > > Hi,
> > >
> > > I have a Use case where I am using Infinispan as a remote Server
> > > mode with HotRod , where The Infinsiapn will be hosted in one
> > > application gear and should be accessible to application hosted in
> > > other gears.
> > > For testing this use case ,I created a scaled application and
> > > added infinispan as downloadable cartridge from
> > > https://raw.github.com/bdecoste/openshift-origin-cartridge-infinis
> > > pa
> > > n/
> > > master/metadata/manifest.yml
> > > .
> > >
> > > When I ssh and check for the variables required to configure in my
> > > test application hosted in a separate gear to connect to the
> > > hosted remote Infinispan server, these are the variables I came across:
> > >
> > > OPENSHIFT_INFINISPAN_HOST="52fb3fdc----5000021-xyz.rhcloud.com"
> > > OPENSHIFT_INFINISPAN_PORT="43--3"
> > >
> > > As I understand it requires INFINISPAN_TCP_PORT to connect with
> > > the Infinispan HotRod server present in separate gear. But
> > > according to my findings this is not provided as a variable in downloadable cartridge.
> > > Can you please provide the solution for that?
> > >
> > > Is this a  current limitation or an issue?
> > > Or is there any other way to achieve this use case ?
> > > Waiting for your response….
> > >
> > >
> > >
> > > Thanks & Regards,
> > > Priyanka Gupta
> > >
> > > ________________________________
> > >
> > > This message is for the designated recipient only and may contain
> > > privileged, proprietary, or otherwise confidential information. If
> > > you have received it in error, please notify the sender
> > > immediately and delete the original. Any other use of the e-mail
> > > by you is prohibited.
> > > Where allowed by local law, electronic communications with
> > > Accenture and its affiliates, including e-mail and instant
> > > messaging (including content), may be scanned by our systems for
> > > the purposes of information security and assessment of internal
> > > compliance with Accenture policy. .
> > > __________________________________________________________________
> > > __
> > > __
> > > ________________
> > >
> > > www.accenture.com
> > >
> >
> >
> > ________________________________
> >
> > This message is for the designated recipient only and may contain
> > privileged, proprietary, or otherwise confidential information. If
> > you have received it in error, please notify the sender immediately
> > and delete the original. Any other use of the e-mail by you is prohibited.
> > Where allowed by local law, electronic communications with Accenture
> > and its affiliates, including e-mail and instant messaging
> > (including content), may be scanned by our systems for the purposes
> > of information security and assessment of internal compliance with
> > Accenture policy. .
> > ____________________________________________________________________
> > __
> > ________________
> >
> > www.accenture.com
> >
>
>
> ________________________________
>
> This message is for the designated recipient only and may contain
> privileged, proprietary, or otherwise confidential information. If you
> have received it in error, please notify the sender immediately and
> delete the original. Any other use of the e-mail by you is prohibited.
> Where allowed by local law, electronic communications with Accenture
> and its affiliates, including e-mail and instant messaging (including
> content), may be scanned by our systems for the purposes of
> information security and assessment of internal compliance with Accenture policy. .
> ______________________________________________________________________
> ________________
>
> www.accenture.com
>


________________________________

This message is for the designated recipient only and may contain privileged, proprietary, or otherwise confidential information. If you have received it in error, please notify the sender immediately and delete the original. Any other use of the e-mail by you is prohibited. Where allowed by local law, electronic communications with Accenture and its affiliates, including e-mail and instant messaging (including content), may be scanned by our systems for the purposes of information security and assessment of internal compliance with Accenture policy. .
______________________________________________________________________________________

www.accenture.com



_______________________________________________
dev mailing list
dev lists openshift redhat com
http://lists.openshift.redhat.com/openshiftmm/listinfo/dev




--
Mfawa Alfred Onen
M.Sc Telecoms, B.Eng Elect/Elect, CCNA, RHCE(in view)
System Administrator
Department of Computer Science,
Bingham University.

E-Mail: systemadmin binghamuni edu ng
Phone1: +234 805 944 3154
Phone2: +234 803 079 6088


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]