[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: error Moped::Cluster nodes after oo-install



On Feb 18, 2014, at 12:09 PM, Mochamad Yusuf <fearleeee gmail com> wrote:

> content of /etc/openshift/broker-dev.conf
> 
> MONGO_HOST_PORT="localhost:27017"
> MONGO_USER="openshift"
> MONGO_PASSWORD="mooo"
> MONGO_DB="openshift_broker_dev"
> MONGO_TEST_DB="openshift_broker_test"
> MONGO_SSL="false"
> #Enables gear/filesystem resource usage tracking
> ENABLE_USAGE_TRACKING_DATASTORE="true"
> #Log resource usage information
> ENABLE_USAGE_TRACKING_AUDIT_LOG="false"
> USAGE_TRACKING_AUDIT_LOG_FILE="/var/log/openshift/broker/usage.log"
> 
> testing login
> [root broker ~]# mongo localhost:27017/openshift_broker_dev -u openshift -p mooo
> MongoDB shell version: 2.4.6
> connecting to: localhost:27017/openshift_broker_dev
> Tue Feb 18 12:07:47.776 Error: 18 { code: 18, ok: 0.0, errmsg: "auth fails" } at src/mongo/shell/db.js:228
> exception: login failed

Okay, can you verify that mongodb is running? systemctl status mongod.service
Also, what repo did you use for the lo-install yum source? Was it:

https://mirror.openshift.com/pub/openshift-origin/release/3/fedora-19/

As with Aditi’s issues, I’m running out of ideas; broker / mongodb interaction is not my forte, so hopefully someone else can chime in.

> 
> content of /etc/openshift/broker.conf
> #Broker datastore configuration
> MONGO_REPLICA_SETS=false
> # Replica set example: "<host-1>:<port-1> <host-2>:<port-2> ..."
> MONGO_HOST_PORT="broker.openshift.iard.com:27017"
> MONGO_USER="openshift"
> MONGO_PASSWORD="mongopass"
> MONGO_DB="openshift_broker"
> MONGO_TEST_DB="openshift_broker_test"
> MONGO_SSL="false"
> #Enables gear/filesystem resource usage tracking
> ENABLE_USAGE_TRACKING_DATASTORE="true"
> #Log resource usage information
> ENABLE_USAGE_TRACKING_AUDIT_LOG="false"
> USAGE_TRACKING_AUDIT_LOG_FILE="/var/log/openshift/broker/usage.log"
> 
> testing login
> [root broker ~]# mongo localhost:27017/openshift_broker -u openshift -p mongopass
> MongoDB shell version: 2.4.6
> connecting to: localhost:27017/openshift_broker
> Tue Feb 18 12:09:27.530 Error: 18 { code: 18, ok: 0.0, errmsg: "auth fails" } at src/mongo/shell/db.js:228
> exception: login failed
> 
> 
> On 18 February 2014 08:30, N. Harrison Ripps <hripps redhat com> wrote:
> Hi Mochamad—
> 
> On Feb 17, 2014, at 7:09 PM, Mochamad Yusuf <fearleeee gmail com> wrote:
> 
> > hei Harrison, thanks for coming.. :)
> > i'm already write the detail...
> > fedora 19 minimal install,, two machine. 1 broker 1 node.
> 
> Indeed you did! Sorry for missing that.
> 
> > On 17 February 2014 11:59, N. Harrison Ripps <hripps redhat com> wrote:
> > Hi Mochamad—
> > What OS are you trying this on?
> >
> > On Feb 15, 2014, at 7:46 PM, Mochamad Yusuf <fearleeee gmail com> wrote:
> >
> > > i just finished install origin using oo-install
> > > fedora 19 minimal install, two machine ( 1 broker and 1 node)
> > > i get some error when running oo-accept-broker and oo-accept-node
> > > 10.11.227.32 ==> my broker's IP
> > > output from oo-accept-broker
> > > [root broker ~]# oo-accept-broker
> > > NOTICE: SELinux is Enforcing
> > > NOTICE: SELinux is  Enforcing
> > > exception: connect failed
> > > FAIL: error logging into mongo db:   MOPED: Retrying connection to primary for replica set <Moped::Cluster nodes=[<Moped::Node resolved_address="10.11.227.32:27017">]>:  MOPED: Retrying connection to primary for replica set <Moped::Cluster nodes=[<Moped::Node resolved_address="10.11.227.32:27017">]>/MOPED: --username Retrying, exit code: 1
> > > NOTICE: unknown auth class: MOPED: Retrying connection to primary for replica set <Moped::Cluster nodes=[<Moped::Node resolved_address="10.11.227.32:27017">]>
> > > NOTICE: unknown dns class: MOPED: Retrying connection to primary for replica set <Moped::Cluster nodes=[<Moped::Node resolved_address="10.11.227.32:27017">]>
> > > NOTICE: unknown messaging class: MOPED: Retrying connection to primary for replica set <Moped::Cluster nodes=[<Moped::Node resolved_address="10.11.227.32:27017">]>
> > > 1 ERRORS
> 
> This looks like a general MongoDB connectivity problem, so please try the same manual connection that I talked through on this thread:
> 
> http://lists.openshift.redhat.com/openshift-archives/dev/2014-February/msg00078.html
> 
> If you are successful in your attempt to connect manually, then restart the Broker and see if the errors are still raised:
> 
>     systemctl restart openshift-broker.service
> 
> Let me know the outcome of these steps.
> 
> > >
> > > output from oo-accept-node
> > > [root node1 ~]# oo-accept-node
> > > FAIL: /etc/openshift/node.conf: BROKER_HOST broker.openshift.iard.com does not resolve (getaddrinfo: Name or service not known)
> > > FAIL: /etc/openshift/node.conf: PUBLIC_HOSTNAME node1.openshift.iard.com does not resolve as a FQDN (getaddrinfo: Name or service not known)
> > > FAIL: no manifest in the cart repo matches /usr/libexec/openshift/cartridges/php/metadata/manifest.yml
> > > FAIL: no manifest in the cart repo matches /usr/libexec/openshift/cartridges/jenkins-client/metadata/manifest.yml
> > > FAIL: no manifest in the cart repo matches /usr/libexec/openshift/cartridges/perl/metadata/manifest.yml
> > > 5 ERRORS
> > >
> > > mco ping -v
> > > The ping application failed to run, use -v for full error details: undefined method `body' for nil:NilClass
> > >
> > > undefined method `body' for nil:NilClass (NoMethodError)
> > >         from /usr/libexec/mcollective/mcollective/connector/activemq.rb:246:in `receive'  <----
> > >         from /usr/share/ruby/vendor_ruby/mcollective/client.rb:89:in `receive'
> > >         from /usr/share/ruby/vendor_ruby/mcollective/client.rb:152:in `block (2 levels) in req'
> > >         from /usr/share/ruby/vendor_ruby/mcollective/client.rb:151:in `loop'
> > >         from /usr/share/ruby/vendor_ruby/mcollective/client.rb:151:in `block in req'
> > >         from /usr/share/ruby/timeout.rb:66:in `timeout'
> > >         from /usr/share/ruby/vendor_ruby/mcollective/client.rb:148:in `req'
> > >         from /usr/libexec/mcollective/mcollective/application/ping.rb:58:in `main'
> > >         from /usr/share/ruby/vendor_ruby/mcollective/application.rb:285:in `run'
> > >         from /usr/share/ruby/vendor_ruby/mcollective/applications.rb:23:in `run'
> > >         from /usr/sbin/mco:20:in `<main>'
> > >
> > >
> > > what can i do to solve it ??
> > >
> > > _______________________________________________
> > > dev mailing list
> > > dev lists openshift redhat com
> > > http://lists.openshift.redhat.com/openshiftmm/listinfo/dev
> >
> >
> 
> 

Attachment: smime.p7s
Description: S/MIME cryptographic signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]