[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Issues during openshift origin installation



Hi Harrison,

I did not reboot the broker. Is this issue related to activemq.???
When i ran service activemq status, it is not running.


Regards
Srujan




On Thu, Feb 20, 2014 at 9:05 PM, N. Harrison Ripps <hripps redhat com> wrote:
Hey Srujan--
Don't forget to CC the dev list.

On Feb 20, 2014, at 10:05, Sai Srujan <srujanpatha gmail com> wrote:

> Hi Harrison,
>
> I have restarted httpd and openshift-broker and ran the oo-accept-broker -v,still i am getting the error

Out of curiosity, did you reboot the broker after you ran the installation?

> :
> INFO: Broker package is: openshift-origin-broker
> INFO: checking packages
> INFO: checking package rubygem-openshift-origin-common
> INFO: checking package rubygem-openshift-origin-controller
> INFO: checking package openshift-origin-broker
> INFO: checking package ruby193-rubygem-rails
> INFO: checking package ruby193-rubygem-passenger
> INFO: checking package ruby193-rubygems
> INFO: checking ruby requirements
> INFO: checking ruby requirements for openshift-origin-controller
> INFO: checking ruby requirements for config/application
> INFO: checking that selinux modules are loaded
> NOTICE: SELinux is Permissive
> NOTICE: SELinux is  Permissive
> INFO: checking firewall settings
> INFO: checking mongo datastore configuration
> INFO: Datastore Host: localhost.openshift.com
> INFO: Datastore Port: 27017
> INFO: Datastore User: openshift
> INFO: Datastore SSL: false
> INFO: Datastore Password has been set to non-default
> INFO: Datastore DB Name: openshift_broker
> INFO: Datastore: mongo db service is remote
> INFO: checking mongo db login access
> INFO: mongo db login successful: localhost.openshift.com:27017/openshift_broker --username openshift
> INFO: checking services
> INFO: checking cloud user authentication
> INFO: auth plugin = OpenShift::RemoteUserAuthService
> INFO: auth plugin: OpenShift::RemoteUserAuthService
> INFO: checking remote-user auth configuration
> INFO: Auth trusted header: REMOTE_USER
> INFO: Auth passthrough is enabled for OpenShift services
> INFO: Got HTTP 200 response from https://localhost/broker/rest/api
> FAIL: Did not get expected HTTP 200 response from https://localhost/broker/rest/ cartridges
> INFO: Got HTTP 401 response from https://localhost/broker/rest/user
> INFO: Got HTTP 401 response from https://localhost/broker/rest/domains

Does anyone on the OpenShift team know why the basic API URL would succeed, but the other URLs would fail?

> INFO: checking dynamic dns plugin
> INFO: dynamic dns plugin = OpenShift::NsupdatePlugin
> INFO: checking bind dns plugin configuration
> INFO: DNS Server: 173.38.225.182
> INFO: DNS Port: 53
> INFO: DNS Zone: citsa.com
> INFO: DNS Domain Suffix: citsa.com
> INFO: DNS Update Auth: key
> INFO: DNS Key Name: citsa.com
> INFO: DNS Key Value: *****
> INFO: adding txt record named testrecord.citsa.com to server 173.38.225.182: thi                                                                                                                                                 s_is_a_test
> INFO: txt record successfully added
> INFO: deleteing txt record named testrecord.citsa.com to server 173.38.225.182:
> INFO: txt record successfully deleted
> INFO: checking messaging configuration
> INFO: messaging plugin = OpenShift::MCollectiveApplicationContainerProxy
> 1 ERRORS
>
>
> Regards:
> Srujan
>
>
> On Thu, Feb 20, 2014 at 7:28 PM, N. Harrison Ripps <hripps redhat com> wrote:
> Hey Srujan--
>
> On Feb 20, 2014, at 0:27, Sai Srujan <srujanpatha gmail com> wrote:
>
> > Hi,
> >
> > 1)when i run rhc setup --server=localhost --insecure,i am getting the below error:
> >
> > OpenShift Client Tools (RHC) Setup Wizard
> >
> > This wizard will help you upload your SSH keys, set your application namespace, and check that other programs like Git are properly installed.
> >
> > Using an existing token for xxx gmail com to login to local host
> >
> > Saving configuration to /root/.openshift/express.conf ... done
> >
> > Checking for git ... found git version 1.7.1
> >
> > Checking common problems .
> >
> > An error occurred while communicating with the server. This problem may only be temporary. Check that you have correctly specified your OpenShift server 'https://localhost/broker/rest/domains'.
> >
> > Checking for a domain ... An error occurred while communicating with the server. This problem may only be temporary. Check that you have correctly specified your OpenShift server 'https://localhost/broker/rest/domains'.
> >
> >
> > 2) When i run  oo-accept-broker -v:
> >
> > INFO: Broker package is: openshift-origin-broker
> > INFO: checking packages
> > INFO: checking package rubygem-openshift-origin-common
> > INFO: checking package rubygem-openshift-origin-controller
> > INFO: checking package openshift-origin-broker
> > INFO: checking package ruby193-rubygem-rails
> > INFO: checking package ruby193-rubygem-passenger
> > INFO: checking package ruby193-rubygems
> > INFO: checking ruby requirements
> > INFO: checking ruby requirements for openshift-origin-controller
> > INFO: checking ruby requirements for config/application
> > INFO: checking that selinux modules are loaded
> > NOTICE: SELinux is Permissive
> > NOTICE: SELinux is  Permissive
> > INFO: checking firewall settings
> > INFO: checking mongo datastore configuration
> > INFO: Datastore Host: localhost.openshift.citsa.com
> > INFO: Datastore Port: 27017
> > INFO: Datastore User: openshift
> > INFO: Datastore SSL: false
> > INFO: Datastore Password has been set to non-default
> > INFO: Datastore DB Name: openshift_broker
> > INFO: Datastore: mongo db service is remote
> > INFO: checking mongo db login access
> > INFO: mongo db login successful: localhost.openshift.citsa.com:27017/openshift_broker --username openshift
> > INFO: checking services
> > INFO: checking cloud user authentication
> > INFO: auth plugin = OpenShift::RemoteUserAuthService
> > INFO: auth plugin: OpenShift::RemoteUserAuthService
> > INFO: checking remote-user auth configuration
> > INFO: Auth trusted header: REMOTE_USER
> > INFO: Auth passthrough is enabled for OpenShift services
> > FAIL: Did not get expected HTTP 200 response from https://localhost/broker/rest/api
> > FAIL: Did not get expected HTTP 200 response from https://localhost/broker/rest/cartridges
>
> Restart the httpd and openshift-broker services. The 401 error indicates that one of these isn't running.
>
> > INFO: Got HTTP 401 response from https://localhost/broker/rest/user
> > INFO: Got HTTP 401 response from https://localhost/broker/rest/domains
> > INFO: checking dynamic dns plugin
> > INFO: dynamic dns plugin = OpenShift::NsupdatePlugin
> > INFO: checking bind dns plugin configuration
> > INFO: DNS Server: 173.38.225.182
> > INFO: DNS Port: 53
> > INFO: DNS Zone: citsa.com
> > INFO: DNS Domain Suffix: citsa.com
> > INFO: DNS Update Auth: key
> > INFO: DNS Key Name: citsa.com
> > INFO: DNS Key Value: *****
> > INFO: adding txt record named testrecord.citsa.com to server 173.38.225.182: this_is_a_test
> > INFO: txt record successfully added
> > INFO: deleteing txt record named testrecord.citsa.com to server 173.38.225.182:
> > INFO: txt record successfully deleted
> > INFO: checking messaging configuration
> > INFO: messaging plugin = OpenShift::MCollectiveApplicationContainerProxy
> > 2 ERRORS
> >
> > please help me in resolving the issues
> >
> >
> > TIA
> > Regards,
> > Srujan
> > _______________________________________________
> > dev mailing list
> > dev lists openshift redhat com
> > http://lists.openshift.redhat.com/openshiftmm/listinfo/dev
>
>



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]