[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Eclipse integration with Openshift: Issues



Hi Amit

On 02/24/2014 11:03 AM, Amit Aggarwal wrote:

Thanks a lot Andre. I have been able to successfully integrate my eclipse with openshift web console and also manage to create and deploy one application to Cloud :-)


you're welcome :)

 

Just one question:

 

Our organization has created a local Linux VM for Openshift using the zip file (https://mirror.openshift.com/pub/origin-server/release/3/images/openshift-origin.zip).

So we have local instance of Openshift VM in our organization

 

When I am trying to integrate my eclipse kepler with this instance of Openshift ( instead of openshift webconsole) I am getting the following error. Any suggestions will be of great help. Also please let me know in case more details are required.

 


Your error happens when we wait for the application to become reachable. In this step we wait for the DNS name of the application to become available. If this fails consistently I bet that you dont have this setup done right. You should have either a bind daemon that accepts dynamic updates (so that freshly created apps become reachable by their host name via your local dns server) or map the application names in the hosts file on your machine.

Some documentation is available here:
http://openshift.github.io/documentation/oo_install_users_guide.html#post-install-tasks
http://openshift.github.io/documentation-latest/oo_notes_running_a_local_ddns.html
http://cloud-mechanic.blogspot.ch/2012/11/openshift-back-end-services-domain-name.html

Cheers
André

First screen: Making connection to Local VM. This step is fine.

 

 

Second screen: Creating a new application. This step is fine. But when I click the Finish button, third screen comes up.

 

 

 

Error screen:

 

 

 

From: André Dietisheim [mailto:adietish redhat com]
Sent: Friday, February 21, 2014 4:17 PM
To: Amit Aggarwal; dev lists openshift redhat com
Cc: Jainendra Kumar
Subject: Re: Eclipse integration with Openshift: Issues

 

Hi Amit

On 02/21/2014 10:57 AM, Amit Aggarwal wrote:

Hi,

 

I am trying to use eclipse to create new application for my openshift web console.

 

After I input my username and password, eclipse is not able to get my existing applications from Openshift site.

 

When I try to create new application, Type dropdown is empty.


The dropdown being empty is caused by the error that happened right before. The error is a known one and happens with outdated Eclipse plugins. You should update to Eclipse Kepler and install our latest tooling from the following update site: http://download.jboss.org/jbosstools/updates/stable/kepler/


See https://www.openshift.com/blogs/getting-started-with-eclipse-paas-integration?page=1

Cheers
André


 

Any suggestions please ??

 

 

 

 

 

 

 

 

Thanks and Regards,

 

Amit Aggarwal

Pitney Bowes Software

Logix Cyber Park, 5th Floor, Tower-B, C28-29

Sector - 62, Noida (U.P) - 201307 – INDIA

O: +91-120-54856124

www.pb.com

 

Every connection is a new opportunity™

 

 

 






_______________________________________________
dev mailing list
dev lists openshift redhat com
http://lists.openshift.redhat.com/openshiftmm/listinfo/dev

 






[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]