[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: openshift-origin-cartridge-dependencies



On 01/17/2014 04:28 PM, Jason DeTiberus wrote:
On 17/01/14 16:21 -0600, Troy Dawson wrote:
On 01/17/2014 03:47 PM, Andy Goldstein wrote:
What are openshift-origin-cartridge-dependencies-optional and
openshift-origin-cartridge-dependencies-recommended for? Are they
metapackages?


Those are for dependencies that go across all languages.
Examples:
openshift-origin-cartridge-dependencies-recommended
Requires:  libcurl
Requires:  libjpeg

openshift-origin-cartridge-dependencies-optional
Requires:  rpm-build
Requires:  ta-lib-devel

I almost think I would rather us have a dependencies-optional and
dependencies-recommended package for each cartridge that we
package/ship.  Otherwise, I think we are going to create some
interesting documentation around how to get what you need for
optional/recommended dependencies for any given cartridge.  At least
then the deliniation on when you would need/want something is more
clear to the end user installing the cartridge.


I can do that. It would certainly make my life easier figuring out if it's a global dependency or not.


I would at least split out the JBoss dependencies to have EWS vs
AS/EAP… right?


That's my question, I don't know for the jboss packages.  If you say
to, I will.

This would be a good idea, considering the JBoss EAP and JBoss EWS
cartridges depend on RHN subscriptions, and their optional/recommended
dependencies could very likely come from these channels as well.


So, have it just like the cartridges?
-jbossas
-jbosseap
-jbossews

Also, very do-able. It would also make more sense if we get rid of the global recommended/optional packages.

Troy


Troy

On Jan 17, 2014, at 4:38 PM, Troy Dawson <tdawson redhat com> wrote:

Hi,
I have created the following packages, I am hoping that their name
makes it fairly obvious what they are for.

openshift-origin-cartridge-dependencies-optional
openshift-origin-cartridge-dependencies-optional-jboss
openshift-origin-cartridge-dependencies-optional-nodejs
openshift-origin-cartridge-dependencies-optional-perl
openshift-origin-cartridge-dependencies-optional-php
openshift-origin-cartridge-dependencies-optional-python
openshift-origin-cartridge-dependencies-optional-ruby
openshift-origin-cartridge-dependencies-recommended
openshift-origin-cartridge-dependencies-recommended-jboss
openshift-origin-cartridge-dependencies-recommended-nodejs
openshift-origin-cartridge-dependencies-recommended-perl
openshift-origin-cartridge-dependencies-recommended-php
openshift-origin-cartridge-dependencies-recommended-python
openshift-origin-cartridge-dependencies-recommended-ruby

I have only populated the Requires for Perl and Python.

I have not yet started removing Requires from any cartridge
packages.  I figured I'd wait a little bit until documentation
and/or puppet scripts started using these packages.

Questions:
I have just one jboss dependencies package.  Does this seem ok, or
should it be broken out to jbossas, jbosseaw and so forth?

Database cartridges - The only non-essential things in these are the
<database>-devel packages.  I was planning on putting all of these
in the general Optional package.  Does that seem right?

One final thing.  If you don't like the naming of these packages,
now is the time to speak up.  It's much easier to change the names
now before they go into documentation and/or puppet scripts.

Thanks
Troy



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]