[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: For the Brave and the Bold: Advanced Notice on Origin v4



Adding EPEL makes the trick. I thought it would be added automatically.
Shouldn't it be added automatically in the puppet module or at least asserted when checking the host for requirements ?




2014-07-14 13:30 GMT+02:00 cortex93 <cortex93 gmail com>:
Hi all,

I tried to deploy a all-in-one-host configuration on a fresh minimal centos 6.5 installation. I just run a yum update after the installation and run the oo-install script from another host.

deploy logs shows some errors when yum installing some packages due to missing rpms.
Am I missing some repos or subscription config ?

oo-install-cfg.yml:
Subscription:
  type: yum
  jenkins_repo_base: http://pkg.jenkins-ci.org/redhat

As you can see, I unset os_repo, os_optional_repo, jboss_repo_base.

 /tmp/openshift-deploy.log:

Error: Execution of '/usr/bin/yum -d 0 -e 0 -y install rhc' returned 1: Error: Package: rhc-1.26.9.1-1.el6.noarch (openshift-origin)
           Requires: rubygem-parseconfig


Error: Execution of '/usr/bin/yum -d 0 -e 0 -y install openshift-origin-cartridge-postgresql' returned 1: Error: Package: gdal-1.9.2-8.el6oso.x86_64 (openshift-deps)
           Requires: libfreexl.so.1()(64bit)
Error: Package: openshift-origin-cartridge-postgresql-1.26.2.1-1.el6.noarch (openshift-origin)
           Requires: perl-DateTime-Format-Pg
Error: Package: openshift-origin-cartridge-postgresql-1.26.2.1-1.el6.noarch (openshift-origin)
           Requires: postgresql-ip4r
Error: Package: postgresql92-postgis-2.1.0-1.el6oso.x86_64 (openshift-deps)
           Requires: libjson.so.0()(64bit)
Error: Package: openshift-origin-cartridge-postgresql-1.26.2.1-1.el6.noarch (openshift-origin)
           Requires: perl-Class-DBI-Pg
Error: Package: postgresql92-postgis-2.1.0-1.el6oso.x86_64 (openshift-deps)
           Requires: json-c
Error: Package: gdal-libs-1.9.2-8.el6oso.x86_64 (openshift-deps)
           Requires: libfreexl.so.1()(64bit)
Error: Package: openshift-origin-cartridge-postgresql-1.26.2.1-1.el6.noarch (openshift-origin)
           Requires: postgis
Error: Package: openshift-origin-cartridge-postgresql-1.26.2.1-1.el6.noarch (openshift-origin)
           Requires: php-pear-MDB2-Driver-pgsql


Error: Execution of '/usr/bin/yum -d 0 -e 0 -y install openshift-origin-cartridge-phpmyadmin' returned 1: Error: Package: phpMyAdmin-4.0.5-1.el6oso.noarch (openshift-deps)
           Requires: php-php-gettext
Error: Package: phpMyAdmin-4.0.5-1.el6oso.noarch (openshift-deps)
           Requires: php-mcrypt >= 5.2.0
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
Error: /Stage[main]/Openshift_origin::Cartridges/Openshift_origin::Openshift_cartridge[phpmyadmin]/Package[openshift-origin-cartridge-phpmyadmin]/ensure: change from absent to present failed: Execution of '/usr/bin/yum -d 0 -e 0 -y install openshift-origin-cartridge-phpmyadmin' returned 1: Error: Package: phpMyAdmin-4.0.5-1.el6oso.noarch (openshift-deps)
           Requires: php-php-gettext
Error: Package: phpMyAdmin-4.0.5-1.el6oso.noarch (openshift-deps)
           Requires: php-mcrypt >= 5.2.0


Error: Execution of '/usr/bin/yum -d 0 -e 0 -y install openshift-origin-cartridge-haproxy' returned 1: Error: Package: openshift-origin-cartridge-haproxy-1.25.1.1-1.el6.noarch (openshift-origin)
           Requires: socat
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
Error: /Stage[main]/Openshift_origin::Cartridges/Openshift_origin::Openshift_cartridge[haproxy]/Package[openshift-origin-cartridge-haproxy]/ensure: change from absent to present failed: Execution of '/usr/bin/yum -d 0 -e 0 -y install openshift-origin-cartridge-haproxy' returned 1: Error: Package: openshift-origin-cartridge-haproxy-1.25.1.1-1.el6.noarch (openshift-origin)
           Requires: socat

Error: Execution of '/usr/bin/yum -d 0 -e 0 -y install openshift-origin-cartridge-ruby' returned 1: Error: Package: 1:rubygem-passenger-3.0.21-11.el6oso.x86_64 (openshift-deps)
           Requires: rubygem(daemon_controller) >= 1.0.0


Error: Execution of '/usr/bin/yum -d 0 -e 0 -y install openshift-origin-cartridge-10gen-mms-agent' returned 1: Error: Package: mms-agent-1.3.7-3.el6_2.noarch (openshift-deps)
           Requires: pymongo


Error: Execution of '/usr/bin/yum -d 0 -e 0 -y install openshift-origin-cartridge-perl' returned 1: Error: Package: perl-App-cpanminus-1.6922-2.el6oso.noarch (openshift-deps)
           Requires: perl(Module::Signature)




2014-07-11 23:25 GMT+02:00 The Dude <michael mcconachie hotmail com>:

Can't wait to give it a go!

Thanks All!!!


Michael J. McConachie | keys.fedoraproject.org | PubKey: 0xEDE583C4
NOTE: The information included and/or attached in this electronic mail transmission may contain confidential or privileged information and is intended solely for the addressee(s). Any unauthorized disclosure, reproduction, distribution or the taking of action in reliance on the contents of the information are strictly prohibited. If you have received the message in error, please notify the sender by reply transmission and delete the message without copying, disclosing or forwarding.


> From: hripps redhat com
> Subject: For the Brave and the Bold: Advanced Notice on Origin v4
> Date: Fri, 11 Jul 2014 16:34:15 -0400
> To: dev lists openshift redhat com

>
> Hey all--
> As of today, you can find a shiny new set of OpenShift Origin RPMs on our mirror site:
>
> https://mirror.openshift.com/pub/origin-server/release/4/rhel-6/
>
> You can also find a Puppet Module that works with these RPMs right here:
>
> https://forge.puppetlabs.com/openshift/openshift_origin/4.0.5
>
> And if you aren't afraid of a little repo cloning, there's an installer for those RPMs that I first mentioned a few weeks back:
>
> http://lists.openshift.redhat.com/openshift-archives/dev/2014-June/msg00077.html
>
>
> We're not 100% ready to announce Origin v4 for a few reasons:
>
> * The docs aren't fully updated
> * The oo-install code is not up-to-date for Enterprise installations yet
>
> but!
>
> If your middle name is "Adventure"...
> If your daily commute involves base jumping...
> If "accessorizing" means picking a new carabiner for your rappelling harness...
>
> Then we say: Origin v4 is ready for some field testing.
>
> If you have the chance to play around with all of this new hotness over the weekend, please share your experiences with us on the dev list. I will be doing what I can to respond quickly to any technical issues that arise.
>
> I'm getting pretty excited about OpenShift Origin v4, and I'm really looking forward to hearing from you on how to make it even better!
>
> Cheers,
> Harrison
>
>
> _______________________________________________
> dev mailing list
> dev lists openshift redhat com
> http://lists.openshift.redhat.com/openshiftmm/listinfo/dev

_______________________________________________
dev mailing list
dev lists openshift redhat com
http://lists.openshift.redhat.com/openshiftmm/listinfo/dev




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]