[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Ruby Dependencies



Hi, Team

Today I try to deploy OpenShift Origin V4 again  by following http://openshift.github.io/documentation/oo_deployment_guide_comprehensive.html.

but I can’t install ruby .

Package ruby193-v8 is obsoleted by v8314-v8, but obsoleting package does not provide for requirements
--> Finished Dependency Resolution
Error: Package: ruby193-rubygem-therubyracer-0.11.0-0.6.beta5.el6.centos.alt.x86_64 (scl)
           Requires: libv8.so.3()(64bit)
           Available: 1:nodejs010-v8-3.14.5.10-2.el6.x86_64 (openshift-origin-deps)
               libv8.so.3()(64bit)
           Available: 1:nodejs010-v8-3.14.5.10-2.el6.centos.alt.x86_64 (scl)
               libv8.so.3()(64bit)
           Available: 1:ruby193-v8-3.14.5.10-2.el6.x86_64 (openshift-origin-deps)
               libv8.so.3()(64bit)
           Available: 1:ruby193-v8-3.14.5.10-2.el6.centos.alt.x86_64 (scl)
               libv8.so.3()(64bit)
           Available: 1:v8-3.14.5.10-2.el6oso.x86_64 (openshift-origin-deps)
               libv8.so.3()(64bit)
           Available: 1:v8-3.14.5.10-8.el6.x86_64 (epel)
               libv8.so.3()(64bit)
Error: Package: ruby193-rubygem-therubyracer-0.11.0-0.6.beta5.el6.centos.alt.x86_64 (scl)
           Requires: ruby193-v8
           Available: 1:ruby193-v8-3.14.5.10-2.el6.x86_64 (openshift-origin-deps)
               ruby193-v8 = 1:3.14.5.10-2.el6
           Available: 1:ruby193-v8-3.14.5.10-2.el6.centos.alt.x86_64 (scl)
               ruby193-v8 = 1:3.14.5.10-2.el6.centos.alt
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles —nodigest

it is the early step.

Regards,

MrChoke

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]