[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Errors Verifying Ruby Bundler



How can I clean up the rpm dependencies and reinstal them so I get the latest?


On Fri, Jul 25, 2014 at 10:05 AM, N. Harrison Ripps <hripps redhat com> wrote:
Hey all--

> On Jul 25, 2014, at 08:42, Kevin Conaway <kevin conaway gmail com> wrote:
>
> Thanks Josef,
>
> I already have the ruby193-v8 package installed (Package 1:ruby193-v8-3.14.5.10-2.el6.x86_64 is obsoleted by 1:v8314-v8-3.14.5.10-3.6.el6.x86_64 which is already installed)
>
> Running scl enable v8314 ruby193 gives an error:
>
> /var/tmp/sclGc5Olz: line 8: ruby193: command not found
>
> The X_SCLS environment variable is not set on my system.

Just be aware that we identified two problems this week that may be affecting you:

1. As I talked about previously, the RPM dependencies chain in our deps repo was stale. So you may not have completely correct RPMs in play.

2. Our puppet module sets a priority on the EPEL repo (which is written to openshift-optional.repo in /etc/yum.repos.d/ by the module). This is a problem that has been fixed in the latest puppet module version (4.0.6). TO manually fix your repo entry, remove the 'priority' line from the file completely.

>
>
> On Fri, Jul 25, 2014 at 3:01 AM, Josef Stribny <jstribny redhat com> wrote:
> > do you have the v8 engine installed? Therubyracer needs v8.
>
> I will try to be more accurate. We removed v8 from the ruby193 scl and now therubyracer should pick up v8 from v8314 scl. You have to explicitly enable v8 scl with ruby193 (scl enable v8314 ruby193...) to make it work. You can check X_SCLS env variable for enabled collections:
>
> $ env | grep X_SCLS
> X_SCLS=ruby193 v8314
>
> For older versions of RHSCL, you should be able to install ruby193-v8 package.
>
> I hope it's clearer now, but how this is handled by the OpenShift broker I have no idea.
>
> Josef
>
> ----- Original Message -----
> From: "Josef Stribny" <jstribny redhat com>
> To: "Kevin Conaway" <kevin conaway gmail com>
> Cc: dev lists openshift redhat com
> Sent: Friday, July 25, 2014 8:44:13 AM
> Subject: Re: Errors Verifying Ruby Bundler
>
> Hi,
>
> do you have the v8 engine installed? Therubyracer needs v8.
>
> Josef
>
> ----- Original Message -----
> From: "Kevin Conaway" <kevin conaway gmail com>
> To: dev lists openshift redhat com
> Sent: Thursday, July 24, 2014 9:16:34 PM
> Subject: Errors Verifying Ruby Bundler
>
> I'm running in to issues verifying the Ruby bundler:
>
> http://openshift.github.io/documentation/oo_deployment_guide_comprehensive.html#prerequisite-mcollective-client
>
> Here is the pastebin output: http://pastebin.com/Xu2vywZg
>
> >From reading the documentation on execjs, it should be picking up therubyracer impl by default. I see that included in the bundle --local output so I'm not sure why its not found.
>
> _______________________________________________
> dev mailing list
> dev lists openshift redhat com
> http://lists.openshift.redhat.com/openshiftmm/listinfo/dev
>
> _______________________________________________
> dev mailing list
> dev lists openshift redhat com
> http://lists.openshift.redhat.com/openshiftmm/listinfo/dev
>
> _______________________________________________
> dev mailing list
> dev lists openshift redhat com
> http://lists.openshift.redhat.com/openshiftmm/listinfo/dev



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]