[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: New installation of V4, No cartridges



Hey Pan--


> On Jul 25, 2014, at 14:31, Pan Luo <luopan81 gmail com> wrote:
> 
> I can finally install V4 with oo-install and puppet. However, when I login with demo user, there is no cartridge available. I can only see "instant App" and "Other types". I tried to clear the cache with
> 
> cd /var/www/openshift/broker
> bundle exec rake tmp:clear
> 
> Still the same. Where should I troubleshoot? Any advise? Thanks.

Sounds like the post-install steps may not have worked for you. The installer may have outputted some info if it wasn't able to:

* Create districts
* Add Nodes to districts
* Register available carts with the Broker

All of these involve MCollective and ActiveMQ, which unfortunately seem to be the most fragile part of new deployments.

So for starters, try:

oo-mco ping

And if no Nodes are found, we know there's an MCollective/ActiveMQ problem to solve first.

Once the message queue layer is sorted out you should be able to manually perform the post install tasks:

Create a district:
	oo-admin-ctl-district -c create -n <district_name> -p <gear_size>

Add Nodes to district:
	oo-admin-ctl-district -c add-node -n <district_name> -a

Register carts with Broker:
	oo-admin-ctl-cartridge -c import-node --activate

After that you will see the full list of available cartridges.

--Harrison


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]