[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: New installation of V4, No cartridges

On Fri, Jul 25, 2014 at 11:31:43AM -0700, Pan Luo wrote:
I can finally install V4 with oo-install and puppet. However, when I login
with demo user, there is no cartridge available. I can only see "instant
App" and "Other types". I tried to clear the cache with

cd /var/www/openshift/broker
bundle exec rake tmp:clear

Still the same. Where should I troubleshoot? Any advise? Thanks.


The general starting point to troubleshoot problems on an OpenShift
installation is to run `oo-diagnostics -v`.

Is your host an all-in-one installation (broker and node on the same
host)? If so, it sounds like the problem may be that the broker did not
import the cartridges from the node.  Try performing the post-install
steps in the deployment guide, specifically the oo-admin-ctl-cartridge
import command:

    oo-admin-ctl-cartridge -c import-node --activate


oo-install should have performed that step, but it may have encountered
an error.  You may be able to find the output in oo-install's log file,

If you are not performing an all-in-one installation, then the output of
`oo-mco ping` and `oo-diagnostics -v` may help to determine the problem.

Best regards,

Miciah Dashiel Butler Masters <mmasters redhat com>

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]