[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

New Cartridges Not Returned by Broker API



After setting up my broker and node, I went back later to add a few more cartridges.  I cannot get these cartridges to be listed by the broker (via rhc cartridges).  

I tried running oo-admin-ctl-cartridge -c import-node --activate but it said everything was up to date.

I restarted mcollective on the node host and reran oo-admin-ctl-cartridge -c import-node --activate and the cartridges came over to the broker.  However, the cartridges were still not listed via rhc cartridges.

I cleared the broker cache (via http://openshift.github.io/documentation/oo_administration_guide.html#clear-the-broker-application-cache) and restarted the broker service but still no luck.

I took a look in the broker Mongo DB and the cartridges are in fact listed in the cartridge_types collection.  I can even query them by name via the API:

curl -u ... http://localhost:8080/broker/rest/cartridges?name=postgresql-9.2

This returns one of the new cartridges that I installed.

But listing all of the cartridges doesn't show the new ones:

http://localhost:8080/broker/rest/cartridges

Any thoughts?

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]