[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Origin V4 Install with oo-install : Unable to create application

Hi Harrison

To help you with more information ,I tried with  a fresh Install today :CentOS 6.5 - One Broker Host +One Node Host


ran oo- install --->  Got Completed successfully without errors.

Steps to reproduce error

1. Accessed Broker console ---> Origin Console  came without any issues  , Default cartridges were listed ,did not install any Java cartridge

2. Created an application with PHP web cartridge ----> Successfully created.

3.  Created an application with Ruby cartridge ---> Successfully created

4.  Added Mysql cartrdige to PHP application created in step 2  --->Successfully created.

5. Try to create another application with PHP -->Fails with error  :
6. All subsequent application creation fails !!

So in this fresh install  Step 4 triggered this action  ie addition of MySQL  - Not very convince if this is the culprit ,

But no additional post install step done ,hence something amiss wrt V4 install .

I guess ,cartridge developers may have pointers ???

Thanks a lot for support 

On Tue, Nov 11, 2014 at 9:52 AM, Shabna M <shabsrh gmail com> wrote:
Thanks for the response !
Nope,Its not just for Java based app.All kind of applications give the same issue.

I had tried a fresh install without installing any of Java based cartridges,but hits the same kind of error with PHP and all quick starts.


On Mon, Nov 10, 2014 at 5:19 PM, N. Harrison Ripps <nhr redhat com> wrote:
Hey Shabna--

On 11/10/2014 06:46 AM, Shabna M wrote:
Hi All

Have been struggling to get the Origin V4 Install up and running -The
Set up tried is 1 Broker Host + 1  Node Host ( ec2 - CentOs6.4 )

Has anyone got  Origin V4 working  with Broker and Node in separate
host. All in one node does not cause any issues.

The installation runs smooth,the diagnostics all run fine ,The console
comes up

but while attempting to create app - it throws the error :

  * Unexpected error: Failed to create the following private endpoints
    due to existing process bindings:

I am not able to find any clues after a lot of debugging and trial and
error. Had earlier worked with v2,v3 but never faced this-

Sorry to hear that you are running into trouble with Origin M4.

It looks like you are trying to start up a Java-based app. Have you tried, as a test of the system, creating any other kind of application? It would be helpful to figure out whether the issue is the system as a whole or just the Java configuration.


Looking forward for some pointers from people who have worked with V4.

Even without any post install step,with default available cartridges ,it
gives this error which makes me feel something is going wrong during
installation process itself.

Thanks for the Support!

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]