[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Stuck with OpenShift origin V3 deployment in Fedora 20 running in AWS



The code/steps for the sample-app in origin master should definitely work, that is part of our merge tests so it gets exercised on every merged commit.  Are you following the steps from the sample-app readme?  they are slightly different from what is in the blog (in particular make sure you're launching openshift using sudo as that is a new requirement since the blog post):
https://github.com/openshift/origin/blob/master/examples/sample-app/README.md

you also might want to check out this troubleshooting guide:
https://github.com/openshift/origin/blob/master/docs/debugging-openshift.md



Ben Parees | OpenShift

----- Original Message -----
> From: "priyanka Gupta" <priyanka4openshift gmail com>
> To: "Ben Parees" <bparees redhat com>, "Maciej Szulik" <maszulik redhat com>, dev lists openshift redhat com
> Sent: Friday, January 16, 2015 6:45:08 AM
> Subject: Re: Stuck with OpenShift origin V3 deployment in Fedora 20 running in AWS
> 
> Hi Ben,
> 
> Its working for me now :) Thanku so much, you are amazing ! don't know what
> was the issue before, tried same steps again from the blog "
> https://blog.openshift.com/openshift-v3-deep-dive-docker-kubernetes/"; and
> it WORKED! though I am not able to work with latest release from "
> https://github.com/openshift/origin/releases"; as I wanted to see my app
> running through web console, may be there is some bug in that, would be
> great if u can confirm this so that I can try this too :)
> 
> 
> Thanks,
> Priya
> 
> On Thu, Jan 15, 2015 at 9:46 PM, Ben Parees <bparees redhat com> wrote:
> 
> > What does show up in list pods?
> >
> > do you have an openshift/kube-deploy container showing up in "docker ps
> > -a"?   what are the logs from it?
> >
> > Ben Parees | OpenShift
> >
> > ----- Original Message -----
> > > From: "priyanka Gupta" <priyanka4openshift gmail com>
> > > To: "Ben Parees" <bparees redhat com>
> > > Sent: Thursday, January 15, 2015 6:02:05 AM
> > > Subject: Re: Stuck with OpenShift origin V3 deployment in Fedora 20
> > running in AWS
> > >
> > > Hey , image has also been pushed to the repository , below confirms this
> > ,
> > > but again no t able to run app :
> > >
> > > # curl localhost:5001/v1/search
> > > {"num_results": 1, "query": "", "results": [{"description": "", "name":
> > > "openshift/origin-ruby-sample"}]}
> > >
> > > but not getting while retrieving pods
> > >
> > > ./openshift kube list pods
> > >
> > >
> > > will be very helpful if you can tell what could be the issue?
> > >
> > > Thanks,
> > > Priya
> > >
> > >
> > > On Thu, Jan 15, 2015 at 3:21 PM, priyanka Gupta <
> > > priyanka4openshift gmail com> wrote:
> > >
> > > > Hi Ben ,
> > > >
> > > > Thanks, Yes I did run the build successfully following below from blog
> > > > post, but seems image has not been pushed to docker resgistry any
> > > > pointers??:
> > > >
> > > >  curl -s -A "GitHub-Hookshot/github" -H
> > "Content-Type:application/json" -H
> > > >  "X-Github-Event:push" -d @github-webhook-example.json
> > > >
> > http://localhost:8080/osapi/v1beta1/buildConfigHooks/build100/secret101/github
> > > >
> > > > Once you’ve triggered a build, you should see OpenShift building your
> > > > application:
> > > >
> > > >  $ ./openshift kube list builds
> > > >
> > > > It may take a few minutes for the build to transition from the
> > > > new/pending/running states to the “complete” state, at which point the
> > > > output will look like this:
> > > >
> > > > ID                                     Status              Pod ID
> > > > ----------                             ----------          ----------
> > > > 20f54507-3dcd-11e4-984b-3c970e3bf0b7   complete
> > > > build-docker-20f54507-3dcd-11e4-984b-3c970e3bf0b7
> > > >
> > > >
> > > > On Wed, Jan 14, 2015 at 7:16 PM, Ben Parees <bparees redhat com>
> > wrote:
> > > >
> > > >> Did you run a build successfully?  The image won't exist in the
> > > >> 127.0.0.1:5001 registry until you do that.
> > > >>
> > > >> Ben Parees | OpenShift
> > > >>
> > > >> ----- Original Message -----
> > > >> > From: "priyanka Gupta" <priyanka4openshift gmail com>
> > > >> > To: "Maciej Szulik" <maszulik redhat com>
> > > >> > Cc: "Ben Parees" <bparees redhat com>,
> > dev lists openshift redhat com
> > > >> > Sent: Wednesday, January 14, 2015 1:08:09 AM
> > > >> > Subject: Re: Stuck with OpenShift origin V3 deployment in Fedora 20
> > > >> running in AWS
> > > >> >
> > > >> > Hi Maciej,
> > > >> >
> > > >> > Thankyou so much docker registry deployment is working for me now
> > :) ,
> > > >> as I
> > > >> > am running on Fedora 20 had to disable iptables too by running
> > > >> "systemctl
> > > >> > stop iptables.service"
> > > >> >
> > > >> > But after this not able to deploy sample ruby app described in
> > blog, its
> > > >> > not able to pull image, below are the error logs , would be really
> > > >> really
> > > >> > helpful if you can give pointers on this
> > > >> >
> > > >> > *I0114 05:59:50.699858 00712 controller.go:83] Synchronizing
> > deployment
> > > >> id:
> > > >> > docker-registry state: complete resourceVersion: 17*
> > > >> > *I0114 05:59:50.705148 00712 controller.go:83] Synchronizing
> > deployment
> > > >> id:
> > > >> > frontend state: complete resourceVersion: 39*
> > > >> > *E0114 05:59:52.837808 00712 kubelet.go:550] Failed to pull image
> > > >> > 127.0.0.1:5001/openshift/origin-ruby-sample
> > > >> > <http://127.0.0.1:5001/openshift/origin-ruby-sample>: Error: image
> > > >> > openshift/origin-ruby-sample:latest not found skipping pod
> > > >> > 6439a4f2-9bb2-11e4-a03a-22000a498d44.etcd container
> > ruby-helloworld.*
> > > >> >
> > > >> > can you also tell  how we can see all images present in the docker
> > > >> registry
> > > >> > running at "*127.0.0.1:5001 <http://127.0.0.1:5001>*", is there a
> > way
> > > >> to
> > > >> > list all images?
> > > >> >
> > > >> >
> > > >> > Thanks a ton!
> > > >> > Priya
> > > >> >
> > > >> >
> > > >> > On Tue, Jan 13, 2015 at 3:34 PM, Maciej Szulik <maszulik redhat com
> > >
> > > >> wrote:
> > > >> >
> > > >> > > Looking at the output, especially this line:
> > > >> > >
> > > >> > > I0113 04:56:02.355284 00918 etcd.go:152] Got service:
> > docker-registry
> > > >> on
> > > >> > > localport 5001 mapping to: {{ docker-registry 2015-01-13 04:51:33
> > > >> +0000
> > > >> > > UTC  %!s(uint64=0)  } []}
> > > >> > >
> > > >> > > I'm assuming you already run openshift before and deployed the
> > docker
> > > >> > > registry sample service. I'd suggest to look for directories
> > named:
> > > >> > > openshift.local.etcd
> > > >> > > openshift.local.volumes
> > > >> > > in the directory you run openshift from and remove them. Then
> > start
> > > >> > > openshfit once again and try deploying the docker registry.
> > > >> > > It should work, if not, please let us know :)
> > > >> > >
> > > >> > > Maciej
> > > >> > >
> > > >> > >
> > > >> > >
> > > >> > > On 01/13/2015 06:39 AM, priyanka Gupta wrote:
> > > >> > >
> > > >> > >> Thanks Ben, even after disabling selinux and stopping firewall I
> > am
> > > >> > >> getting
> > > >> > >> this error, don't know what is the cause. is it related to AWS
> > as my
> > > >> > >> fedora
> > > >> > >> 20 in running in AWS instance. below is the error i am
> > continuously
> > > >> > >> getting
> > > >> > >> and also attached the complete logs. please have a look. Thank
> > you
> > > >> so much
> > > >> > >> for giving your time for this.
> > > >> > >>
> > > >> > >> error logs:
> > > >> > >> I0113 05:33:54.576660 00918 controller.go:83] Synchronizing
> > > >> deployment id:
> > > >> > >> docker-registry state: failed resourceVersion: 10
> > > >> > >> I0113 05:33:54.685854 00918 log.go:151] GET
> > > >> /api/v1beta1/services?labels=:
> > > >> > >> (973.921us) 200
> > > >> > >> I0113 05:33:54.688238 00918 log.go:151] GET
> > > >> > >> /api/v1beta1/pods?labels=name%3DregistryPod: (1.571336ms) 200
> > > >> > >> I0113 05:33:54.689864 00918 log.go:151] GET
> > > >> > >> /api/v1beta1/endpoints/docker-registry: (818.775us) 200
> > > >> > >> I0113 05:33:54.690439 00918 endpoints_controller.go:102]
> > endpoints
> > > >> are
> > > >> > >> equal for docker-registry, skipping update
> > > >> > >>
> > > >> > >> On Mon, Jan 12, 2015 at 7:09 PM, Ben Parees <bparees redhat com>
> > > >> wrote:
> > > >> > >>
> > > >> > >>  It would be best to capture the full openshift server logs.
> > even
> > > >> better,
> > > >> > >>> with verbose logging:
> > > >> > >>>
> > > >> > >>> openshift start --loglevel=4 &> /tmp/openshift.log   (and any
> > other
> > > >> > >>> arguments you passed to openshift)
> > > >> > >>>
> > > >> > >>> also right now you need to disable selinux:
> > > >> > >>> $ setenforce 0
> > > >> > >>>
> > > >> > >>> and shutdown firewalld (there is a way to configure it, but
> > > >> shutting it
> > > >> > >>> down is the simplest way to see if it's the issue):
> > > >> > >>> $ systemctl stop firewalld
> > > >> > >>>
> > > >> > >>>
> > > >> > >>>
> > > >> > >>> Ben Parees | OpenShift
> > > >> > >>>
> > > >> > >>> ----- Original Message -----
> > > >> > >>>
> > > >> > >>>> From: "priyanka Gupta" <priyanka4openshift gmail com>
> > > >> > >>>> To: dev lists openshift redhat com, "Ben Parees" <
> > > >> bparees redhat com>
> > > >> > >>>> Sent: Monday, January 12, 2015 4:07:08 AM
> > > >> > >>>> Subject: Stuck with OpenShift origin V3 deployment in Fedora 20
> > > >> running
> > > >> > >>>>
> > > >> > >>> in AWS
> > > >> > >>>
> > > >> > >>>>
> > > >> > >>>> Hi,
> > > >> > >>>>
> > > >> > >>>> I am trying to install origin V3 in an AWS instance having
> > Fedora
> > > >> 20,
> > > >> > >>>> following steps from the blog
> > > >> > >>>>
> > > >> https://blog.openshift.com/openshift-v3-deep-dive-docker-kubernetes/
> > > >> > >>>>
> > > >> > >>>> but stuck with an strange issue while deploying docker-registry
> > > >> after
> > > >> > >>>> running the command:
> > > >> > >>>>
> > > >> > >>>> ./openshift kube apply -c docker-registry-config.json
> > > >> > >>>>
> > > >> > >>>> Error logs are:
> > > >> > >>>>
> > > >> > >>>> *I0112 08:54:54.971026 00656 controller.go:83] Synchronizing
> > > >> deployment
> > > >> > >>>>
> > > >> > >>> id:
> > > >> > >>>
> > > >> > >>>> docke r-registry state: failed resourceVersion: 10 E0112
> > > >> 08:55:04.831443
> > > >> > >>>> 00656 pod_cache.go:84] Error synchronizing container:
> > > >> > >>>> Get
> > > >> > >>>>
> > > >> > >>>>  http://ip----3-119.ec2.internal:10250/podInfo?podID=
> > > >> > >>> deploy-docker-registry
> > > >> > >>>
> > > >> > >>>> <
> > > >> > >>>>
> > > >> > >>> http://ip----3-119.ec2.internal:10250/podInfo?podID=
> > > >> > >>> deploy-docker-registry
> > > >> > >>>
> > > >> > >>>> :
> > > >> > >>>> dial tcp 10.1---.119:10250: i/o timeout I0112 08:55:04.979403
> > 00656
> > > >> > >>>> controller.go:83] Synchronizing deployment id: docke r-registry
> > > >> state:
> > > >> > >>>> failed resourceVersion: 10*
> > > >> > >>>>
> > > >> > >>>> will be great if anyone can help me on this.
> > > >> > >>>>
> > > >> > >>>>
> > > >> > >>>> Thanks,
> > > >> > >>>>
> > > >> > >>>> priya
> > > >> > >>>>
> > > >> > >>>>
> > > >> > >>>
> > > >> > >>
> > > >> > >>
> > > >> > >> _______________________________________________
> > > >> > >> dev mailing list
> > > >> > >> dev lists openshift redhat com
> > > >> > >> http://lists.openshift.redhat.com/openshiftmm/listinfo/dev
> > > >> > >>
> > > >> > >>
> > > >> >
> > > >>
> > > >
> > > >
> > >
> >
> 


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]