[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

v1beta3 is now the default API for client/server interactions



The v1beta3 OpenShift API is now enabled in master with https://github.com/openshift/origin/pull/1986.  All of the server code and the clients will default to v1beta3.  This may have an impact on scripts you run from the osc command line (because the default values returned for the --template flag will be different).

The v1beta3 API is still considered experimental, so for the time being we will continue to store v1beta1 as the default underlying version in etcd.  Once we have good enough feedback that we know v1beta3 is solid for folks (correcting typos), we'll make it official and create a v1 candidate API.

The swagger documentation is much improved - from the CLI you can retrieve it via cURL with `curl https://localhost:8443/swaggerapi/osapi/v1beta3` (or the appropriate server name and port for your server).

If you encounter any flakiness in your use cases it's probably a bug introduced by v1beta3 - let us know and we'll try to get it resolved.

v0.5.1 will be coming very soon - remember if you are upgrading from v0.5 that no etcd data is preserved across that upgrade boundary so you'll need to export your applications and recreate them, or manually copy those records in etcd.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]