[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

ImageStream loses tags when exported



Hi,

I am working on o2n and I am experiencing problem exporting and
importing ImageStreams. When I export BuildConfig and ImageStreams,
ImageStream is exported without tags and BuildConfig is unable to
produce build [1].

I have used simple ruby-hello-world example [1]. This is the state of
ImageStream "ruby-22-centos7" in the original and unmodified project
(it has tag "latest"):

$ oc describe is ruby-22-centos7 --namespace=original-project
Name:			ruby-22-centos7
Docker Pull Spec:	172.30.179.182:5000/original-project/ruby-22-
centos7
Tag	Spec		Created		PullSpec		
			Image
latest	<pushed>	17 hours ago	centos/ruby-22-centos
7 sha256:898b024be2bc70...	<same>

After I export it and import it into another project in the same
cluster by running:
$ oc export is ruby-22-centos7 --namespace=original-project | oc create
-f - --namespace=import

ImageStream is missing tag "latest":
$ oc describe is ruby-22-centos7 --namespace=import
Name:			ruby-22-centos7
Tags:			<none>

Is this the expected behaviour? After exporting whole project by o2n it
fails to build with error: 
"An error occurred while starting the build.imageStreamTag 'ruby-22-
centos7:latest' not found"


Although if I do the same for ImageStream "ruby-hello-world" the tags
survive export/import just fine:
$ oc export is ruby-hello-world --namespace=original-project | oc
create -f - --namespace=import

$ oc describe is ruby-hello-world --namespace=import
Name:			ruby-hello-world
Docker Pull Spec:	172.30.179.182:5000/import/ruby-hello-world

Tag	Spec								
Created	PullSpec	Image
latest	172.30.179.182:5000/original-project/ruby-hello-
world:latest
		<not available>	<not available>


Thanks,
Tomas Nozicka


[1] https://github.com/projectatomic/openshift2nulecule/issues/56
[2] https://github.com/openshift/ruby-hello-world


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]