[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Ping to localhost(127.0.0.1) fails periodically on openshift node



sorry, am a newbie here..Is this the right forum to post this question? If not, can you help me with the right alias.

regards,
Dilipan

On Mon, Feb 19, 2018 at 7:26 PM J Dilipan <jdilipan gmail com> wrote:
Hi Experts,
In my openshift setup, ping to localhost is failing...this is causing curl localhost/healthz failing, ending up router to "CrashLoopBackOff". When atomic-openshift-node service is disabled on this node, ping to localhost is not affected. Any idea what is happening here?

64 bytes from ose-appnode3.avi-ose-systest.local--se--holy-sea-3nkgb (127.0.0.1): icmp_seq=33 ttl=64 time=0.061 ms
64 bytes from ose-appnode3.avi-ose-systest.local--se--holy-sea-3nkgb (127.0.0.1): icmp_seq=34 ttl=64 time=0.059 ms
ping: sendmsg: Invalid argument
ping: sendmsg: Invalid argument
ping: sendmsg: Invalid argument
ping: sendmsg: Invalid argument
64 bytes from ose-appnode3.avi-ose-systest.local--se--holy-sea-3nkgb (127.0.0.1): icmp_seq=39 ttl=64 time=0.194 ms
ping: sendmsg: Invalid argument
ping: sendmsg: Invalid argument

When I tried to strace the ping process, it has the following error.

sendmsg(3, {msg_name(16)={sa_family=AF_INET, sin_port=htons(0), sin_addr=inet_addr("127.0.0.1")}, msg_iov(1)=[{"\10\0w\264u\214\1N\366O\212Z\0\0\0\0\306\363\3\0\0\0\0\0\20\21\22\23\24\25\26\27\30\31\32\33\34\35\36\37 !\"#$%&'()*+,-./01234567", 64}], msg_controllen=0, msg_flags=0}, 0) = -1 EINVAL (Invalid argument)
recvmsg(3, 0x7ffc5bde94c0, MSG_DONTWAIT|MSG_ERRQUEUE) = -1 EAGAIN (Resource temporarily unavailable)
dup(2)                                  = 4
fcntl(4, F_GETFL)                       = 0x8002 (flags O_RDWR|O_LARGEFILE)
fstat(4, {st_mode=S_IFCHR|0600, st_rdev=makedev(136, 16), ...}) = 0
mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x7f9876c28000
lseek(4, 0, SEEK_CUR)                   = -1 ESPIPE (Illegal seek)
write(4, "ping: sendmsg: Invalid argument\n", 32) = 32
close(4)                                = 0
munmap(0x7f9876c28000, 4096)            = 0
recvmsg(3, 0x7ffc5bde97c0, 0)           = -1 EAGAIN (Resource temporarily unavailable)

The setup is running the following version.
[root ose-master1 ~]# oc version
oc v3.6.173.0.96
kubernetes v1.6.1+5115d708d7
features: Basic-Auth GSSAPI Kerberos SPNEGO

openshift v3.6.173.0.96
kubernetes v1.6.1+5115d708d7
[root ose-master1 ~]#

We have applications on this host which connects to localhost which is affected due to this issue...your help is much appreciated. thanks.

Regards,
Dilipan

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]