[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Failed to push image: unauthorized: authentication required



Thanks for your feedback.
The project I created 1 weeks ago, it also some application which already build success. The issue happen when I add a new app to project, and the first or second build fail to push image, try to build third time, it success.
I think it related to this bug. https://access.redhat.com/solutions/3340571. But try with workaround solution, I did not see  no_proxy section of the docker registry's deployment config.

Regards
Dung.

On Thu, May 31, 2018 at 8:28 PM, Ben Parees <bparees redhat com> wrote:
Had you recently created the project? It takes some time for the default secrets to be created after a new project/namespace is created and if you start a build before then, you can see this issue. 


Ben Parees | OpenShift

On Thu, May 31, 2018, 02:57 Tran Tien Dung <tiendungitd gmail com> wrote:
Hi,
Something my build job failed to push image with the error:  "unauthorized: authentication required", after that, I rebuild 2,3 times, this issue is gone.
Beside that, i also see the error: Missing push secret


I'm using v3.7.0+7ed6862 and docker v 1.12.6. when I run oc adm diagnostics, I found a lot of warning related to docker-registry. Please see https://pastebin.com/609dLUaj
Please adive me how to fix it?
Thanks.
Dung

_______________________________________________
dev mailing list
dev lists openshift redhat com
http://lists.openshift.redhat.com/openshiftmm/listinfo/dev


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]