[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [v4]: v4.1.4 is using internal registry, is this a bug?



We generally bump "latest" symlink once it's in the stable channel, which 4.1.6 is not in.  4.1.6 is still considered pre-release.

For your first error message, which installer binary were you using?  Can you link to it directly?

On Thu, Jul 18, 2019 at 3:55 PM Daniel Comnea <comnea dani gmail com> wrote:
Hi,

Trying a new fresh deployment by downloading a new secret together with the installer from try.openshift.com i end up in a failure state with bootstrap node caused by 

error pulling image "registry.svc.ci.openshift.org/ocp/release sha256:a6c177eb007d20bb00bfd8f829e99bd40137167480112bd5ae1c25e40a4a163a": unable to pull registry.svc.ci.openshift.org/ocp/release sha256:a6c177eb007d20bb00bfd8f829e99bd40137167480112bd5ae1c25e40a4a163a: unable to pull image: Error determining manifest MIME type for docker://registry.svc.ci.openshift.org/ocp/release sha256:a6c177eb007d20bb00bfd8f829e99bd40137167480112bd5ae1c25e40a4a163a: Error reading manifest sha256:a6c177eb007d20bb00bfd8f829e99bd40137167480112bd5ae1c25e40a4a163a in registry.svc.ci.openshift.org/ocp/release: unauthorized: authentication required

Manually trying from withing bootstrap node to check if it works .. i get same negative result

skopeo inspect --authfile /root/.docker/config.json docker://registry.svc.ci.openshift.org/ocp/release sha256:a6c177eb007d20bb00bfd8f829e99bd40137167480112bd5ae1c25e40a4a163a

Switching to installer 4.1.0/ 4.1.3/ 4.1.6 with the same pull secret am able to get bootstrap node up with is MCO and the other pods up.

One interesting bit is that 4.1.4 points to a release image hosted internally
./openshift-install version
./openshift-install v4.1.4-201906271212-dirty
built from commit bf47826c077d16798c556b1bd143a5bbfac14271
release image registry.svc.ci.openshift.org/ocp/release sha256:a6c177eb007d20bb00bfd8f829e99bd40137167480112bd5ae1c25e40a4a163a

but 4.1.6 for example points to quay.io (as expected).
Is this a bug?

On a slightly different note, would be nice to update try.openshift.com to latest stable 4.1 release which is .6 and not .4.

Cheers,
Dani

_______________________________________________
dev mailing list
dev lists openshift redhat com
http://lists.openshift.redhat.com/openshiftmm/listinfo/dev

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]