[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

RE: Source Code repository could not be cloned when creating a new app from a quickstart



Thank Guys ;-)

I add :
git config --system http.proxy http://<proxy>:<port>
git config --system https.proxy http:// <proxy>:<port>

Then it works!!!

Now I have a new issue in the build phase hahaha I will keep it for tomorrow ;-)

Cheers,

Julien

-----Original Message-----
From: Luke Meyer [mailto:lmeyer redhat com] 
Sent: mercredi 11 décembre 2013 16:53
To: Aaron Knister
Cc: users lists openshift redhat com; Piccaluga Julien
Subject: Re: Source Code repository could not be cloned when creating a new app from a quickstart

Actually, setting /etc/gitconfig *does* seem to work... at least, when I put this in /etc/gitconfig, it failed appropriately while trying to use the proxy:

[http]
        proxy = http://wrooooooooong:1234/ [https]
        proxy = http://wrooooooooong:1234/

Presumably it would work correctly with a correct proxy :) Thanks!

Feels unsatisfying as a total answer, but it should suffice for this particular problem.

----- Original Message -----
From: "Aaron Knister" <aaron knister gmail com>
To: "Piccaluga Julien" <Julien Piccaluga nagra com>
Cc: users lists openshift redhat com
Sent: Wednesday, December 11, 2013 10:25:54 AM
Subject: Re: Source Code repository could not be cloned when creating a new	app	from a quickstart


I had an openshift cluster on a network that required a proxy server and I could never get quickstarts from external repos to successfully clone. By setting proxy variables in /etc/openshift/env/* I was able to get most everything else to work (pi p, cpan, gem). I ended up mirroring the quick starts locally. Maybe that would work for you, and you could just update the URL in quickstarts.json. Looking back at it now I wonder if setting http.proxy in /etc/gitconfig would have done the trick. 




On Dec 11, 2013, at 10:12 AM, Piccaluga Julien < Julien Piccaluga nagra com > wrote: 


Ok I make shells script http_proxy.sh and https_proxy.sh for node1,node2 and broker. Then I restart the whole infrastructure for make sure all user accounts are load with new profile. 
I still have the same issue. I am wondering if ruby set the proxy by another config file which override the system env variables. 

-----Original Message-----
From: Luke Meyer [mailto:lmeyer@ redhat.com ]
Sent: mercredi 11 décembre 2013 15:43
To: Piccaluga Julien
Cc: users lists openshift redhat com
Subject: Re: Source Code repository could not be cloned when creating a new app from a quickstart 

That clone must be running from a different context than the gear user - mcollective. In fact, I forgot to mention - restart (ruby193-)mcollective on the node and see if that makes a difference. 

If not, you might need to make it more system-wide by creating a shell script in /etc/profile.d/ to export the variable or something like that - sorry, I don't have a system that requires an http proxy or I would test it rather than just speculate... 

----- Original Message -----
From: "Piccaluga Julien" < Julien Piccaluga nagra com >
To: "Luke Meyer" < lmeyer redhat com >
Cc: users lists openshift redhat com
Sent: Wednesday, December 11, 2013 9:35:30 AM
Subject: RE: Source Code repository could not be cloned when creating a new app from a quickstart 

Thanks Luke, 

I add the http_proxy and https_proxy in the /etc/openshift/env directory and then I can see my variable set in my gear. 

Unfortunately it doesn't solved my issue. I still can't create a new wordpress app from quickstart. 
Same error message appear : 

Source Code repository could not be cloned: ' https://github.com/openshift/wordpress-example.git' . Please verify the repository is correct and contact support. 

So I don't know where this issue is throw during the process? In my understood the git clone is perform inside the gear. 
So I try to create a simple php app, connect to ssh and proceed a "git clone https://github.com/openshift/wordpress-example.git " and here it's works. So why it still failed when trying to create an wordpress app from the web console? 

Regards, 

Julien 



-----Original Message-----
From: Luke Meyer [mailto:lmeyer@ redhat.com ]
Sent: mercredi 11 décembre 2013 14:30
To: Piccaluga Julien
Cc: users lists openshift redhat com
Subject: Re: Source Code repository could not be cloned when creating a new app from a quickstart 

This has come up before and I believe the answer was to set http_proxy and https_proxy environment variables on the node (since that's where the clone happens). I *believe* you can do this globally by putting your proxy in /etc/openshift/env/http{,s}_proxy. 

----- Original Message -----
From: "Piccaluga Julien" < Julien Piccaluga nagra com >
To: users lists openshift redhat com
Sent: Wednesday, December 11, 2013 8:02:33 AM
Subject: Source Code repository could not be cloned when creating a new app from a quickstart 





Hi all, 



I just configure quickstarts.json to access quickstarts form the broker console. 



Here is the content of quickstarts.json : 

[ 

{"quickstart":{ 

"id": "7", 

"name":"WordPress", 

"website":" http://wordpress.org ", 

"initial_git_url":" https://github.com/openshift/wordpress-example.git ", 

"cartridges":["php-5.3","mysql-5.1"], 

"summary":"A semantic personal publishing platform written in PHP with a MySQL back end, focusing on aesthetics, web standards, and usability.", 

"tags":["php","wordpress","blog","framework","instant_app"], 

"admin_tags":[] 

}} 

] 



When I try to create a new wordpress app from the console, I got the following message : 



· Source Code repository could not be cloned: ' https://github.com/openshift/wordpress-example.git' . Please verify the repository is correct and contact support. 

I think I have to configure openshift to use my corporate proxy to be able to clone this github repository. My problem is that I have no idea on how to configure it in the openshift platform. Someone can point me to right config file? 



Best Regards, 



Julien 


_______________________________________________
users mailing list
users lists openshift redhat com
http://lists.openshift.redhat.com/openshiftmm/listinfo/users 

_______________________________________________
users mailing list
users lists openshift redhat com
http://lists.openshift.redhat.com/openshiftmm/listinfo/users 


_______________________________________________
users mailing list
users lists openshift redhat com
http://lists.openshift.redhat.com/openshiftmm/listinfo/users


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]