[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: error while removing custom cartridge



If you remove the cartridge using the cartridge name (as shown by rhc app-show appname) as opposed to the cartridge url, the remove will succeed. For example:

rhc app create php php-5.3
rhc cartridge add -a php https://raw.github.com/openshift/downloadable-mock-plugin/master/metadata/manifest.yml
rhc cartridge remove -a php openshift-downloadable-mock-plugin-0.1

I opened a bug to fix the behavior of cartridge-remove when specifying the cartridge url:
https://bugzilla.redhat.com/show_bug.cgi?id=1041313


Jordan






On 12/12/2013 04:38 AM, priyanka e gupta accenture com wrote:

Hi,

 

I have created custom cartridge and successfully added that to Jboss Application as downloadable cartridge.

 

But when I remove the cartridge using remove below command, it gives error:

 

$ rhc cartridge-remove –a appname  https://raw.github.com/ffdfdf45/Cartridge/master/metadata/manifest

 

Removing  from 'app…' ... /usr/lib/ruby/gems/1.9.1/gems/rhc-1.11.4/lib/rhc/rest/base.rb:21:in `rest_method': No link defined for DELETE (RuntimeError)

        from /usr/lib/ruby/gems/1.9.1/gems/rhc-1.11.4/lib/rhc/rest/cartridge.rb:109:in `destroy'

        from /usr/lib/ruby/gems/1.9.1/gems/rhc-1.11.4/lib/rhc/commands/cartridge.rb:123:in `remove'

        from /usr/lib/ruby/gems/1.9.1/gems/rhc-1.11.4/lib/rhc/commands.rb:257:in `execute'

        from /usr/lib/ruby/gems/1.9.1/gems/rhc-1.11.4/lib/rhc/commands.rb:248:in `block (3 levels) in to_commander'

        from /usr/lib/ruby/gems/1.9.1/gems/commander-4.1.2/lib/commander/command.rb:180:in `call'

        from /usr/lib/ruby/gems/1.9.1/gems/commander-4.1.2/lib/commander/command.rb:180:in `call'

        from /usr/lib/ruby/gems/1.9.1/gems/commander-4.1.2/lib/commander/command.rb:155:in `run'

        from /usr/lib/ruby/gems/1.9.1/gems/commander-4.1.2/lib/commander/runner.rb:402:in `run_active_command'

        from /usr/lib/ruby/gems/1.9.1/gems/rhc-1.11.4/lib/rhc/command_runner.rb:73:in `run!'

        from /usr/lib/ruby/gems/1.9.1/gems/commander-4.1.2/lib/commander/delegates.rb:11:in `run!'

        from /usr/lib/ruby/gems/1.9.1/gems/rhc-1.11.4/lib/rhc/cli.rb:36:in `start'

        from /usr/lib/ruby/gems/1.9.1/gems/rhc-1.11.4/bin/rhc:20:in `<top (required)>'

        from /usr/bin/rhc:23:in `load'

        from /usr/bin/rhc:23:in `<main>'

 

 

 

 

Why it happens and what configuration is required to achieve the same? Please help..

 

 

 

Thanks & Regards,

Priyanka Gupta

 




This message is for the designated recipient only and may contain privileged, proprietary, or otherwise confidential information. If you have received it in error, please notify the sender immediately and delete the original. Any other use of the e-mail by you is prohibited. Where allowed by local law, electronic communications with Accenture and its affiliates, including e-mail and instant messaging (including content), may be scanned by our systems for the purposes of information security and assessment of internal compliance with Accenture policy. .
______________________________________________________________________________________

www.accenture.com


_______________________________________________
dev mailing list
dev lists openshift redhat com
http://lists.openshift.redhat.com/openshiftmm/listinfo/dev


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]