[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Openshift Origin Manually deploy fail. Follow oo_deploy_guide_comprehensive



Hi, I need some help!

When I follow the http://openshift.github.io/documentation/oo_deployment_guide_comprehensive.html to deploy origin manually, I suffer some error.

I deploy broker and node separated. When I finish the guide, the broker is not work well. I can see the console web site, but when I click "create your first application" it will wait for a long time and reach proxy error finally. I find that it should activemq not work correctly:

when I use "mco ping", it will print

transmit to localhost failed: Broken pipe

connection.receive returning EOF as nil - resetting connection.

connect to localhost failed: Broken pipe will retry(#0) in 5


the /var/log/openshift/broker/httpd/error_log will look like above error.

As a result, when I finish section 9(conf node mcollective), the mco ping is ok and it can receive the node's response.But it turn fail when I finish all section. 

  and the /var/log/activemq/activemq.log will show the below info again and again

///////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////

2013-12-13 20:13:52,450 | WARN | Exception occurred processing:

CONNECT

content-type:text/plain; charset=UTF-8

content-length:0

passcode:*****

login:mcollective

: java.lang.SecurityException: User name [mcollective] or password is invalid. | org.apache.activemq.transport.stomp.ProtocolConverter | ActiveMQ Transport: tcp:///0:0:0:0:0:0:0:1:41684 61613

2013-12-13 20:13:52,451 | WARN | Transport Connection to: tcp://0:0:0:0:0:0:0:1:41684 failed: java.io.IOException: User name [mcollective] or password is invalid. | org.apache.activemq.broker.TransportConnection.Transport | ActiveMQ Transport:tcp:///0:0:0:0:0:0:0:1:41684 61613

2013-12-13 20:13:54,450 | INFO | Stopping tcp://0:0:0:0:0:0:0:1:41684 because Failed with SecurityException: User name [mcollective] or password is invalid. | org.apache.activemq.broker.TransportConnection | ActiveMQ BrokerService[broker.example.com] Task-36

2013-12-13 20:13:57,459 | WARN | Failed to add Connection ID:localhost.localdomain-33070-1386935489311-3:14, reason: java.lang.SecurityException: User name [mcollective] or password is invalid. | org.apache.activemq.broker.TransportConnection | ActiveMQ Transport: tcp:///0:0:0:0:0:0:0:1:41685 61613

////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////// 

I doublecheck my work, it not worng.

I follow the guide exactly, and the mcollective conf is correct

I try to solve this problem by editing /etc/activemq/activemq.xml, jetty-realm.properties, /etc/mcollective/client.cfg on broker or /etc/mcollective/server.cfg on node, but it fail 

What can I do to solve this problem?thanks for help!! 

I have tried oo-install and puppet depolyment, but they not work, so I have to try manual guide and get the problem.

I use the repo that the guide offer(https://mirror.openshift.com/pub/openshift-origin/nightly/rhel-6/dependencies/x86_64/), so the ActiveMq version is 5.8 and mcollective version is 2.2.1


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]