[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Why does mysql cartridge requires mysql55



I found my issue was from this recent commit https://github.com/openshift/origin-server/commit/c2c1029ae9c3c32e86f1b2655ce9dfa01ffa253c

centos doesn't seem to have mysql55 but I assume rhel does. I managed to do a temporary work around by grabbing the older version https://mirror.openshift.com/pub/openshift-origin/nightly/rhel-6/packages/2013-12-08/x86_64/openshift-origin-cartridge-mysql-1.19.1-1.git.0.4c14b09.el6.noarch.rpm

On a slightly different note, would it be possible to run MariaDB on centos? I'm not familiar with the compatibility, but would it be possible to MariaDB-server packages from mariadb repos and change some deps in the spec file (MariaDB-server vs mariadb-server for fedora) https://github.com/openshift/origin-server/blob/master/cartridges/openshift-origin-cartridge-mariadb/openshift-origin-cartridge-mariadb.spec

Thanks,
Andrew.

On Sat, Dec 14, 2013 at 6:23 PM, Andrew Lau <andrew andrewklau com> wrote:
Hi,

I'm adding some nodes to my openshift cluster, but there are some issues with the dependicies.

It seems the mysql cartridge now requires mysql55, but it seems only the webtatic repo has mysql55

msg: Error: Package: openshift-origin-cartridge-mysql-1.19.1-1.git.65.edb7b7b.el6.noarch (openshift-origin)
           Requires: mysql55-mysql-devel
Error: Package: openshift-origin-cartridge-mysql-1.19.1-1.git.65.edb7b7b.el6.noarch (openshift-origin)
           Requires: mysql55


Neither my centos 6.5 or fedora 19 repos seem to have this package.

Thanks.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]