[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Error parsing "ntpd.pp"



Hi all,
I use Scientific Linux EL 6, and installed puppet version 2.7.22.
After installing openshift module using puppet-module, and trying to run the manifest suggested by this link http://openshift.github.io/origin/file.install_origin_using_puppet.html#Installing_Puppet , I got the following result:

> puppet apply --verbose configure_origin.pp

> Puppet::Parser::AST::Resource failed with error ArgumentError: Could not find declared class ntp at /usr/share/puppet/modules/openshift_origin/manifests/ntpd.pp:44 on node cloud.bourbon.dcs.shef.ac.uk

file ntpd.pp lines 40 to 44:
===
  class { 'ntp':
    ensure     => running,
    servers    => ['time.apple.com iburst', 'pool.ntp.org iburst', 'clock.redhat.com iburst'],
    autoupdate => true,
  }
===

Could someone please help me on how to fix it?
--ja



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]