[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Error can't find gems dependencies



Hi all,

I'm trying to install openshift origin following the official website instructions on a Scientific Linux EL 6 with puppet version 2.7.22

I've been trying to run

> puppet apply --verbose configure_origin.pp

and I've come across that problem:

>> Could not find dependency Package[rubygem-sass-rails] for Exec[Console gem dependencies] at /usr/share/puppet/modules/openshift_origin/manifests/console.pp:283

Even though I have installed this gem after 

> gem install sass-rails

… and it installed successfully, however while running the puppet manifest, it couldn't find the dependency.
Could someone please help me?

Where does puppet search for dependencies declared in Package[xxx] , where could I configure it, or is there any other solution?

--ja



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]