[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

RE: DNS problems with installer?



And if all else fails don't forget to check /var/named/dynamic/(domain).db for the appropriate CNAME.  Make sure it's being mapped back to the appropriate A record (for whatever broker contains the app).  If it's missing add it, and restart named.


Sent from my T-Mobile 4G LTE Device



-------- Original message --------
From: Luke Meyer <lmeyer redhat com>
Date: 2013/11/11 19:23 (GMT-05:00)
To: "Kyle Crumpton (kcrumpto)" <kcrumpto cisco com>
Cc: users lists openshift redhat com
Subject: Re: DNS problems with installer?


So, the new app name isn't resolving in DNS. You can use dig to find out where it's going wrong. From the same host, just run "dig test-dsx.dsx.org".

When things are right, the response will look something like this:

# dig foo-bar.example.com
; <<>> DiG 9.8.2rc1-RedHat-9.8.2-0.17.rc1.el6_4.6 <<>> foo-bar.example.com
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 61430
;; flags: qr aa rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 1, ADDITIONAL: 1

;; QUESTION SECTION:
;foo-bar.example.com.           IN      A

;; ANSWER SECTION:
foo-bar.example.com.    1800    IN      CNAME   broker.example.com.
broker.example.com.     180     IN      A       172.16.4.52

;; AUTHORITY SECTION:
example.com.            1800    IN      NS      ns1.example.com.

;; ADDITIONAL SECTION:
ns1.example.com.        1800    IN      A       127.0.0.1

;; Query time: 0 msec
;; SERVER: 172.16.4.52#53(172.16.4.52)
;; WHEN: Mon Nov 11 17:08:09 2013
;; MSG SIZE  rcvd: 108


This is not the most intuitive format at first but there's a lot of info in here.
In the question section, it just repeats what we're asking for - the address for foo-bar.
In the answer section, we actually get two answers. First we see that foo-bar.example.com is and alias for the CNAME broker.example.com. (with a period at the end; it's always possible that without the terminating period, it might resolve to broker.example.com.something.totally.different.com based on the search domains in your /etc/resolv.conf). And then the second answer is the IP address for that CNAME.

The authority section tells us which server is considered the authority for this domain; should be your OpenShift DNS server. You could have two here if you have a different authority for the host vs. the application domains.

Finally it tells you which server answered, which should be the first server in your /etc/resolv.conf, unless it's not taking requests in which case the next is tried.

Look at all those and see if any of them are surprises. For example, here's a dig where the CNAME isn't defined:

# dig foo-bar2.example.com

; <<>> DiG 9.8.2rc1-RedHat-9.8.2-0.17.rc1.el6_4.6 <<>> foo-bar2.example.com
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 50521
;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 1, ADDITIONAL: 0

;; QUESTION SECTION:
;foo-bar2.example.com.          IN      A

;; ANSWER SECTION:
foo-bar2.example.com.   1800    IN      CNAME   bogus.example.com.

;; AUTHORITY SECTION:
example.com.            10      IN      SOA     ns1.example.com. hostmaster.example.com. 2011112913 60 15 1800 10

So you get one answer giving you the CNAME, but nothing translating that into an actual IP.

If the application DNS record itself hasn't been defined, then you just get no answer section at all.

So, use dig to find out not just that your address isn't working, but what part of the DNS is not giving the answer you expect. Is it asking the right server? Is that server consulting the right authority? Does the application record exist? Does the CNAME it's pointing at exist?

----- Original Message -----
From: "Kyle Crumpton (kcrumpto)" <kcrumpto cisco com>
To: users lists openshift redhat com
Sent: Monday, November 11, 2013 5:34:37 PM
Subject: DNS problems with installer?



Hi. I have successfully spun up a new broker / node.
I am using the broker as an internal bind server and Rackspace for infrastructure. So after running the install I went ahead and tried to create an app. I was given the following error:


http://pastebin.com/YAyr08H5

I changed my /etc/resolv.conf to point to the broker for name server (for some reason it wasn't..)
Also changed forwarders.conf to contain the Rackspace name servers instead of google. I then ran into this: http://pastebin.com/2U422iHr


Has anyone experienced same issues with DNS and creating apps?




_______________________________________________
users mailing list
users lists openshift redhat com
http://lists.openshift.redhat.com/openshiftmm/listinfo/users

_______________________________________________
users mailing list
users lists openshift redhat com
http://lists.openshift.redhat.com/openshiftmm/listinfo/users

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]