[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

"Maintenance in progress" message when trying to create a gear.



-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

After working through my activemq problem, i'm now met with a new
problem.  Now i'm able to attempt to create a gear, but after
submitting the form, i'm given a "Maintenance in progress" error in my
browser.

It seems like my broker cannot contact my node (even though theyre
both on the same machine).

In /var/log/openshift/broker/httpd/error_log i see:

==> httpd/error_log <==

No request sent, we did not discover any nodes.
No request sent, we did not discover any nodes.

/var/log/openshift/broker/production.log shows a ruby trace.

2013-11-20 12:04:34.780 [ERROR] No nodes available (pid:1890)
2013-11-20 12:04:34.791 [ERROR]
["/opt/rh/ruby193/root/usr/share/gems/gems/openshift-origin-msg-broker-mcollective-1.16.1/lib/openshift/mcollective_application_container_proxy.rb:77:in
`find_available_impl'", "
....  lots of data...

2013-11-20 12:04:34.793 [ERROR] No nodes available (pid:1890)
2013-11-20 12:04:34.268 [ERROR] Got Node Unavailable Exception (pid:1890)
2013-11-20 12:04:34.269 [ERROR] Reference ID:
9f3e4af42fbbe15c3bd78fddd767fea4 - No nodes available

Do i need to tell openshift about my node after an all-in-one install
via puppet? I may have missed it, but i dont see anything in the
install doc about that.

Thanks!
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.15 (GNU/Linux)
Comment: Using GnuPG with Thunderbird - http://www.enigmail.net/

iEYEARECAAYFAlKM9XcACgkQsZqG4IN3sum70QCcDLwCe9cbbTlB63qperm/EV4x
gHsAnRi4B+ZLuRjSryse3uNAEz/CzyhH
=7wlX
-----END PGP SIGNATURE-----


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]