[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

oo-install problems with repos



Hi all,

Sorry I didn't realize there was more to the log output from earlier. Here is my current run of this script:


----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

Running Puppet deployment

Command "puppet module list" on target localhost completed.
Command "puppet module install openshift/openshift_origin" on target localhost completed.
Warning: Config file /etc/puppet/hiera.yaml not found, using Hiera defaults
Warning: Augeas[Tune Sysctl knobs](provider=augeas): Loading failed for one or more files, see debug for /augeas//error output
Error: /Stage[main]/Openshift_origin::Node/Augeas[Tune Sysctl knobs]: Could not evaluate: Save failed with return code false, see debug
Error: Execution of '/usr/bin/yum -d 0 -e 0 -y install rubygem-openshift-origin-frontend-apache-mod-rewrite' returned 1: Error: Nothing to do

Error: /Stage[main]/Openshift_origin::Plugins::Frontend::Apache_mod_rewrite/Package[rubygem-openshift-origin-frontend-apache-mod-rewrite]/ensure: change from absent to present failed: Execution of '/usr/bin/yum -d 0 -e 0 -y install rubygem-openshift-origin-frontend-apache-mod-rewrite' returned 1: Error: Nothing to do

Error: Execution of '/usr/bin/yum -d 0 -e 0 -y install rubygem-openshift-origin-frontend-nodejs-websocket' returned 1: Error: Nothing to do

Error: /Stage[main]/Openshift_origin::Plugins::Frontend::Nodejs_websocket/Package[rubygem-openshift-origin-frontend-nodejs-websocket]/ensure: change from absent to present failed: Execution of '/usr/bin/yum -d 0 -e 0 -y install rubygem-openshift-origin-frontend-nodejs-websocket' returned 1: Error: Nothing to do

Error: Execution of '/usr/bin/yum -d 0 -e 0 -y install ruby193-mcollective' returned 1: Error: Nothing to do

Error: /Stage[main]/Openshift_origin::Mcollective_server/Package[ruby193-mcollective]/ensure: change from absent to present failed: Execution of '/usr/bin/yum -d 0 -e 0 -y install ruby193-mcollective' returned 1: Error: Nothing to do

Warning: /File[mcollective server config]: Skipping because of failed dependencies
Warning: /Stage[main]/Openshift_origin::Node/Exec[Reload sysctl]: Skipping because of failed dependencies
Error: Execution of '/usr/bin/yum -d 0 -e 0 -y install ruby193-mcollective-client' returned 1: Error: Nothing to do

Error: /Stage[main]/Openshift_origin::Mcollective_client/Package[ruby193-mcollective-client]/ensure: change from absent to present failed: Execution of '/usr/bin/yum -d 0 -e 0 -y install ruby193-mcollective-client' returned 1: Error: Nothing to do

Warning: /Stage[main]/Openshift_origin::Plugins::Frontend::Apache_mod_rewrite/File[broker and console route for node]: Skipping because of failed dependencies
Warning: /Stage[main]/Openshift_origin::Plugins::Frontend::Apache_mod_rewrite/Exec[regen node routes]: Skipping because of failed dependencies
Error: Cannot create /var/lib/openshift/.settings; parent directory /var/lib/openshift does not exist
Error: /File[create node setting markers dir]/ensure: change from absent to directory failed: Cannot create /var/lib/openshift/.settings; parent directory /var/lib/openshift does not exist
Error: Execution of '/usr/bin/yum -d 0 -e 0 -y install openshift-origin-msg-node-mcollective' returned 1: Error: Package: ruby193-mcollective-common-2.2.1-1.el6_3.noarch (openshift-origin-deps)
           Requires: mcollective-common = 2.2.1
           Installed: mcollective-common-2.2.4-1.el6.noarch (@puppetlabs-products)
               mcollective-common = 2.2.4-1.el6
           Available: mcollective-common-1.2.1-1.el6.noarch (puppetlabs-products)
               mcollective-common = 1.2.1-1.el6
           Available: mcollective-common-2.0.0-1.el6.noarch (puppetlabs-products)
               mcollective-common = 2.0.0-1.el6
           Available: mcollective-common-2.0.1-1.el6.noarch (puppetlabs-products)
               mcollective-common = 2.0.1-1.el6
           Available: mcollective-common-2.2.0-1.el6.noarch (puppetlabs-products)
               mcollective-common = 2.2.0-1.el6
           Available: mcollective-common-2.2.1-1.el6.noarch (puppetlabs-products)
               mcollective-common = 2.2.1-1.el6
           Available: mcollective-common-2.2.1-1.el6_3.noarch (openshift-origin-deps)
               mcollective-common = 2.2.1-1.el6_3
           Available: mcollective-common-2.2.2-1.el6.noarch (puppetlabs-products)
               mcollective-common = 2.2.2-1.el6
           Available: mcollective-common-2.2.3-1.el6.noarch (puppetlabs-products)
               mcollective-common = 2.2.3-1.el6
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Error: /Stage[main]/Openshift_origin::Node/Package[openshift-origin-msg-node-mcollective]/ensure: change from absent to present failed: Execution of '/usr/bin/yum -d 0 -e 0 -y install openshift-origin-msg-node-mcollective' returned 1: Error: Package: ruby193-mcollective-common-2.2.1-1.el6_3.noarch (openshift-origin-deps)
           Requires: mcollective-common = 2.2.1
           Installed: mcollective-common-2.2.4-1.el6.noarch (@puppetlabs-products)
               mcollective-common = 2.2.4-1.el6
           Available: mcollective-common-1.2.1-1.el6.noarch (puppetlabs-products)
               mcollective-common = 1.2.1-1.el6
           Available: mcollective-common-2.0.0-1.el6.noarch (puppetlabs-products)
               mcollective-common = 2.0.0-1.el6
           Available: mcollective-common-2.0.1-1.el6.noarch (puppetlabs-products)
               mcollective-common = 2.0.1-1.el6
           Available: mcollective-common-2.2.0-1.el6.noarch (puppetlabs-products)
               mcollective-common = 2.2.0-1.el6
           Available: mcollective-common-2.2.1-1.el6.noarch (puppetlabs-products)
               mcollective-common = 2.2.1-1.el6
           Available: mcollective-common-2.2.1-1.el6_3.noarch (openshift-origin-deps)
               mcollective-common = 2.2.1-1.el6_3
           Available: mcollective-common-2.2.2-1.el6.noarch (puppetlabs-products)
               mcollective-common = 2.2.2-1.el6
           Available: mcollective-common-2.2.3-1.el6.noarch (puppetlabs-products)
               mcollective-common = 2.2.3-1.el6
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Error: /usr/sbin/oo-init-quota returned 2 instead of one of [0]
Error: /Stage[main]/Openshift_origin::Node/Exec[Initialize quota DB]/returns: change from notrun to 0 failed: /usr/sbin/oo-init-quota returned 2 instead of one of [0]
Warning: /Stage[main]/Openshift_origin::Node/Service[sshd]: Skipping because of failed dependencies
Warning: /Stage[main]/Openshift_origin::Node/Service[openshift-tc]: Skipping because of failed dependencies
Warning: /Stage[main]/Openshift_origin::Node/Service[openshift-iptables-port-proxy]: Skipping because of failed dependencies
Warning: /Stage[main]/Openshift_origin::Node/Service[oddjobd]: Skipping because of failed dependencies
Error: Execution of '/usr/bin/yum -d 0 -e 0 -y install rubygem-openshift-origin-msg-broker-mcollective' returned 1: Error: Package: ruby193-mcollective-common-2.2.1-1.el6_3.noarch (openshift-origin-deps)
           Requires: mcollective-common = 2.2.1
           Installed: mcollective-common-2.2.4-1.el6.noarch (@puppetlabs-products)
               mcollective-common = 2.2.4-1.el6
           Available: mcollective-common-1.2.1-1.el6.noarch (puppetlabs-products)
               mcollective-common = 1.2.1-1.el6
           Available: mcollective-common-2.0.0-1.el6.noarch (puppetlabs-products)
               mcollective-common = 2.0.0-1.el6
           Available: mcollective-common-2.0.1-1.el6.noarch (puppetlabs-products)
               mcollective-common = 2.0.1-1.el6
           Available: mcollective-common-2.2.0-1.el6.noarch (puppetlabs-products)
               mcollective-common = 2.2.0-1.el6
           Available: mcollective-common-2.2.1-1.el6.noarch (puppetlabs-products)
               mcollective-common = 2.2.1-1.el6
           Available: mcollective-common-2.2.1-1.el6_3.noarch (openshift-origin-deps)
               mcollective-common = 2.2.1-1.el6_3
           Available: mcollective-common-2.2.2-1.el6.noarch (puppetlabs-products)
               mcollective-common = 2.2.2-1.el6
           Available: mcollective-common-2.2.3-1.el6.noarch (puppetlabs-products)
               mcollective-common = 2.2.3-1.el6
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Error: /Stage[main]/Openshift_origin::Broker/Package[rubygem-openshift-origin-msg-broker-mcollective]/ensure: change from absent to present failed: Execution of '/usr/bin/yum -d 0 -e 0 -y install rubygem-openshift-origin-msg-broker-mcollective' returned 1: Error: Package: ruby193-mcollective-common-2.2.1-1.el6_3.noarch (openshift-origin-deps)
           Requires: mcollective-common = 2.2.1
           Installed: mcollective-common-2.2.4-1.el6.noarch (@puppetlabs-products)
               mcollective-common = 2.2.4-1.el6
           Available: mcollective-common-1.2.1-1.el6.noarch (puppetlabs-products)
               mcollective-common = 1.2.1-1.el6
           Available: mcollective-common-2.0.0-1.el6.noarch (puppetlabs-products)
               mcollective-common = 2.0.0-1.el6
           Available: mcollective-common-2.0.1-1.el6.noarch (puppetlabs-products)
               mcollective-common = 2.0.1-1.el6
           Available: mcollective-common-2.2.0-1.el6.noarch (puppetlabs-products)
               mcollective-common = 2.2.0-1.el6
           Available: mcollective-common-2.2.1-1.el6.noarch (puppetlabs-products)
               mcollective-common = 2.2.1-1.el6
           Available: mcollective-common-2.2.1-1.el6_3.noarch (openshift-origin-deps)
               mcollective-common = 2.2.1-1.el6_3
           Available: mcollective-common-2.2.2-1.el6.noarch (puppetlabs-products)
               mcollective-common = 2.2.2-1.el6
           Available: mcollective-common-2.2.3-1.el6.noarch (puppetlabs-products)
               mcollective-common = 2.2.3-1.el6
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Warning: /File[mcollective broker plugin config]: Skipping because of failed dependencies
Error: /Stage[main]/Openshift_origin::Console/Exec[Console gem dependencies]: Failed to call refresh: /bin/rm -f Gemfile.lock &&     /usr/bin/scl enable ruby193 "bundle show" &&     /bin/chown apache:apache Gemfile.lock &&     /bin/rm -rf tmp/cache/* &&     /usr/bin/scl enable ruby193 "rake assets:precompile" &&     /bin/chown -R apache:apache /var/www/openshift/console returned 1 instead of one of [0]
Error: /Stage[main]/Openshift_origin::Console/Exec[Console gem dependencies]: /bin/rm -f Gemfile.lock &&     /usr/bin/scl enable ruby193 "bundle show" &&     /bin/chown apache:apache Gemfile.lock &&     /bin/rm -rf tmp/cache/* &&     /usr/bin/scl enable ruby193 "rake assets:precompile" &&     /bin/chown -R apache:apache /var/www/openshift/console returned 1 instead of one of [0]
Warning: /Stage[main]/Openshift_origin::Broker/Exec[Broker gem dependencies]: Skipping because of failed dependencies
Warning: /File[/var/www/openshift/broker/Gemfile.lock]: Skipping because of failed dependencies
Error: /Stage[main]/Openshift_origin::Cartridges/Exec[oo-admin-cartridge]: Failed to call refresh: /usr/sbin/oo-admin-cartridge --recursive -a install -s /usr/libexec/openshift/cartridges/ returned 1 instead of one of [0]
Error: /Stage[main]/Openshift_origin::Cartridges/Exec[oo-admin-cartridge]: /usr/sbin/oo-admin-cartridge --recursive -a install -s /usr/libexec/openshift/cartridges/ returned 1 instead of one of [0]
Warning: /Stage[main]/Openshift_origin::Mcollective_server/Exec[openshift-facts]: Skipping because of failed dependencies
Error: /Stage[main]/Openshift_origin::Mcollective_server/Exec[openshift-facts]: Failed to call refresh: /var/tmp/sclnCmL9h: line 8: /opt/rh/ruby193/root/usr/libexec/mcollective/update_yaml.rb: No such file or directory

Error: /Stage[main]/Openshift_origin::Mcollective_server/Exec[openshift-facts]: /var/tmp/sclnCmL9h: line 8: /opt/rh/ruby193/root/usr/libexec/mcollective/update_yaml.rb: No such file or directory

Warning: /File[mcollective client config]: Skipping because of failed dependencies
Warning: /Stage[main]/Openshift_origin::Mcollective_server/Service[ruby193-mcollective]: Skipping because of failed dependencies
Warning: /Stage[main]/Openshift_origin::Node/Service[messagebus]: Skipping because of failed dependencies
Error: /usr/bin/scl enable ruby193 /usr/sbin/oo-mongo-setup returned 1 instead of one of [0]
Error: /Stage[main]/Openshift_origin::Mongo/Exec[/usr/sbin/oo-mongo-setup]/returns: change from notrun to 0 failed: /usr/bin/scl enable ruby193 /usr/sbin/oo-mongo-setup returned 1 instead of one of [0]
Command "puppet apply --verbose ~/oo_install_configure_localhost.pp" on target localhost completed.
Command "rm ~/oo_install_configure_localhost.pp" on target localhost completed.
OpenShift Origin deployment completed.

Installation completed.
oo-install exited; removing temporary assets.

---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

Looks like we need to modify the puppet repos before the run to force the downgraded MCollective?


Kyle Crumpton

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]