[...]>Any specific error information that you can provide for the straight puppet installation path would be great. That said, oo-install uses the latest puppet scripts and part of oo-install is to write a *.pp file that configures the openshift/openshift_origin puppet module.
> So far I've tried with Fedora 18, Fedora 19, Centos 6.4.
> I tried the Puppet method described at the blog, but it has some issues with links and versions. I fixed some but I couldn't make it work.
> I've also tried with the oo-install gem (which isn't at rubygems and you have to buid yourself, despite what the doc says), but nothing.I use the bundler as a way of bootstrapping the app in development, but I believe that in the long term, the curl-to-shell method will be the supported approach for delivery. That said, if you want to work from your own copy of the source, you can always:
1. clone [openshift-extras]
2. cd to [openshift-extras]/oo-install
3. bundle install
4. bundle exec bin/oo-install
That's a bummer. Let's figure out what happened there.
> But Puppet finished without success.
Actually for log files, are you familiar with the Fedora pastebin? https://paste.fedoraproject.org/ - Just throw log files there and send the URL to the list.
> I can provide you logs, but I guess it's better do it at the Github project, right?
> One thing I discovered is that Fedora 19 (most o my tests were with that distro) has Ruby 2.0.0 and the script search for Ruby 1.8 or 1.9.2. And later for a fixed path /opt/rh/ruby193/ which I didn't have in any distro.oo-install is "vendored everything", meaning that all of its gem requirements are packaged with it. (I took care -not- to use any gems that need to be natively compiled.) Because of the differences between Ruby 1.8.7 and Ruby 1.9.x, I vendored two sets of gems. The bootstrapper chooses which set to make available through the $GEM_PATH based on some very simple logic: "Ruby 1.8.7" or "Everything Else".
That's a long way of saying, if you are using the curl-to-shell method (or using bundler) with Ruby 2.0.0 and you are running into problems, please send me some log files. I may need to vendor in gems expressly for Ruby 2.0.0, but my own recent experience with oo-install on Ruby 2.0.0 led me to believe that I wouldn't need to.
Glad to have the feedback. I hope we can get you up and running!