[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Ansible Origin Install Error Code 500



Hi Benno,

I had a closer look at the install, it seems the mongodb account wasn't created properly but it was "ignored". I went on and followed the rest of the "verifying installation" section and many pointed to a failure to connect to mongodb.

The error from ansible was:

failed: [10.0.4.251] => {"failed": true, "item": "", "parsed": false}
invalid output was: Traceback (most recent call last):
  File "/root/.ansible/tmp/ansible-1383197329.79-18968974800337/mongodb_user", line 1147, in <module>
    main()
  File "/root/.ansible/tmp/ansible-1383197329.79-18968974800337/mongodb_user", line 208, in main
    if user_add(module, client, db_name, user, password, roles) is not True:
  File "/root/.ansible/tmp/ansible-1383197329.79-18968974800337/mongodb_user", line 120, in user_add
    db.add_user(user, password, False)
  File "/usr/lib64/python2.6/site-packages/pymongo/database.py", line 646, in add_user
    user = self.system.users.find_one({"user": name}) or {"user": name}
  File "/usr/lib64/python2.6/site-packages/pymongo/collection.py", line 604, in find_one
    for result in self.find(spec_or_id, *args, **kwargs).limit(-1):
  File "/usr/lib64/python2.6/site-packages/pymongo/cursor.py", line 904, in next
    if len(self.__data) or self._refresh():
  File "/usr/lib64/python2.6/site-packages/pymongo/cursor.py", line 848, in _refresh
    self.__uuid_subtype))
  File "/usr/lib64/python2.6/site-packages/pymongo/cursor.py", line 800, in __send_message
    self.__uuid_subtype)
  File "/usr/lib64/python2.6/site-packages/pymongo/helpers.py", line 98, in _unpack_response
    raise AutoReconnect(error_object["$err"])
pymongo.errors.AutoReconnect: not master and slaveOk=false

...ignoring


Thanks,
Andrew



On Thu, Oct 31, 2013 at 3:24 PM, benno joy <bennojoy gmail com> wrote:
Hi Andrew,

Did you run the tests given in the "verifying the installation" section, especially

oo-accept-broker -v   on the broker node
and  oo-accept-node -v on the nodes.

Do they look fine ?

Regards,
Benno



On Thu, Oct 31, 2013 at 9:44 AM, Andrew Lau <andrew andrewklau com> wrote:
Hi all,

I used the ansible origin playbook which was blogged a few days ago because I wanted to try get a HA origin deployment without the fuss. The puppet modules (although our environment completely puppetised)  kept giving errors everywhere which was a disappointment.

After a few trial and errors I got a non-error install (from ansible). But the broker seems to be returning a error code 500 https://paste.fedoraproject.org/50671/19245413/ any ideas?

Thanks,
Andrew


_______________________________________________
users mailing list
users lists openshift redhat com
http://lists.openshift.redhat.com/openshiftmm/listinfo/users




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]