[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Installing Openshift Origin on a RHEL 6.5 Server



Greetings,


The error you are seeing is due to the Openshift install trying to locate RHEL specific resources (it's trying to install the enterprise version of Openshift) which it cannot locate. It's doing a little bit of auto-detection based on your platform...since you are executing this on RHEL, the assumption is that you have it registered with RHN or a local Redhat Satellite server. Otherwise, on CentOS, the exact same script will instead install Openshift Origin (OSS version) that does not require RHN subscriptions.

If you were to build a CentOS system and run the exact same script (sh <(curl -s https://install.openshift.com/)) will install Openshift Origin.



Britt


On Tue, Dec 2, 2014 at 11:59 AM, Klaus Raizer <klaus cpqd com br> wrote:
Hello Matteo,  thank you for the quick response.

It seem my system does not come with subscription-manager.
I'm having a hard time trying to install it.

Meanwhile, I've found this tutorial on how to install Openshift on CentoOS:

https://www.digitalocean.com/community/tutorials/how-to-install-and-configure-openshift-origin-on-centos-6-5

It seems to be unfriendlier.
Do you believe it would be worthwhile insisting on RHEL for a little longer, or should I ask my IT department to change the os the CentOS?

Thanks again for the help.


Regards,

Klaus


2014-12-02 12:43 GMT-02:00 <users-request lists openshift redhat com>:
Send users mailing list submissions to
        users lists openshift redhat com

To subscribe or unsubscribe via the World Wide Web, visit
        http://lists.openshift.redhat.com/openshiftmm/listinfo/users
or, via email, send a message with subject or body 'help' to
        users-request lists openshift redhat com

You can reach the person managing the list at
        users-owner lists openshift redhat com

When replying, please edit your Subject line so it is more specific
than "Re: Contents of users digest..."


Today's Topics:

   1. FAIL: user ..... does not have quotas imposed (patrick)
   2. Installing Openshift Origin on a RHEL 6.5 Server (Klaus Raizer)
   3. Re: Installing Openshift Origin on a RHEL 6.5 Server
      (Matteo Piccinini)
   4. Re: FAIL: user ..... does not have quotas imposed
      (Brenton Leanhardt)
   5. Re: FAIL: user ..... does not have quotas imposed (patrick)


----------------------------------------------------------------------

Message: 1
Date: Tue, 2 Dec 2014 10:02:52 +0100
From: patrick <chapat gmail com>
To: users <users lists openshift redhat com>
Subject: FAIL: user ..... does not have quotas imposed
Message-ID: <7BF848B2-51CD-4C65-98D7-037A1A42D848 gmail com>
Content-Type: text/plain; charset="us-ascii"

Hi list I got this errors on one node does somebody have a pointe on how to fix the user quota ?

Thanks

patrick

 root::node01 # oo-diagnostics
FAIL: run_script
oo-accept-node had errors:
--BEGIN OUTPUT--
FAIL: user 546081c38e8f5d2cdf000089 does not have quotas imposed
1 ERRORS

--END oo-accept-node OUTPUT--



-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openshift.redhat.com/openshift-archives/users/attachments/20141202/7ae9972d/attachment.html>

------------------------------

Message: 2
Date: Tue, 2 Dec 2014 10:52:35 -0200
From: Klaus Raizer <klaus cpqd com br>
To: users lists openshift redhat com
Subject: Installing Openshift Origin on a RHEL 6.5 Server
Message-ID:
        <CAMNTzHSbotHo4FuX_SXre+k=LMPnBBFAeJ-AHxkbgD4mnJ+GSQ mail gmail com>
Content-Type: text/plain; charset="utf-8"

Greetings,

I am trying to install Openshift Origin on a RHEL 6.5 Server (using the
following: *sh <(curl -s https://install.openshift.com/
<https://install.openshift.com/>)* ), but got stuck at the last part.

oo-install is producing the following errors:

*"ERROR: Unable to read system ID"*

Apparently my system is not registered at "Red Hat Network".

Looking for a solution, google sent me to the following site:

https://access.redhat.com/solutions/8036

Where I could find instructions on how to register my RHEL to the "Red Hat
Network", which allegedly would solve the problem.

Do I really need to register at RHN in order to install Openshift Origin on
a RHEL single-machine?
If yes, is there an alternative to it? For instance, would changing it to
CentOS help in any way?
Or am I doing something wrong?

Thank you in advance for your help!

Klaus
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openshift.redhat.com/openshift-archives/users/attachments/20141202/9c113ac5/attachment.html>

------------------------------

Message: 3
Date: Tue, 02 Dec 2014 14:54:35 +0100
From: Matteo Piccinini <matteo piccinini jnet2000 it>
To: users lists openshift redhat com
Subject: Re: Installing Openshift Origin on a RHEL 6.5 Server
Message-ID: <547DC49B 1010608 jnet2000 it>
Content-Type: text/plain; charset=windows-1252

On 12/02/2014 01:52 PM, Klaus Raizer wrote:
[...]
> Where I could find instructions on how to register my RHEL to the "Red
> Hat Network", which allegedly would solve the problem.

You need to esecute the following command:

subscription-manager register --username=<YOUR USERNAME> --auto-attach

For additional info you can read the RHEL 6 deployment guide. [%]

> Do I really need to register at RHN in order to install Openshift Origin
> on a RHEL single-machine?

I hope not to be wrong but the answer is yes because you need to install
some package dependency provided by red hat base channels.
During the installation you will be asked to provide the link for
external repository like the EPEL, jenkins, puppet etc...

> If yes, is there an alternative to it? For instance, would changing it
> to CentOS help in any way?

If you try to install on CentOS 6.x you will find the Base repository
configured by default.

SyS,
./mp

[%]
https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux/6/html/Deployment_Guide/entitlements.html




------------------------------

Message: 4
Date: Tue, 2 Dec 2014 08:54:43 -0500
From: Brenton Leanhardt <bleanhar redhat com>
To: patrick <chapat gmail com>
Cc: users <users lists openshift redhat com>
Subject: Re: FAIL: user ..... does not have quotas imposed
Message-ID: <20141202135442 GB29600 harbin rdu redhat com>
Content-Type: text/plain; charset=us-ascii; format=flowed

+++ patrick [02/12/14 10:02 +0100]:
>Hi list I got this errors on one node does somebody have a pointe on how to fix the user quota ?

What version of openshift-origin-node-util are you using?

Newer versions provide a more helpful message:
https://github.com/openshift/origin-server/blob/master/node-util/sbin/oo-accept-node#L609

If you check /etc/openshift/resource_limits.conf you will be able to
find the appropriate values to fill in for --blocks and --inodes.  If
oo-devel-node returns an error that might give some indication as to
how this Node got in to this situation.

--Brenton

>
>Thanks
>
>patrick
>
> root::node01 # oo-diagnostics
>FAIL: run_script
>oo-accept-node had errors:
>--BEGIN OUTPUT--
>FAIL: user 546081c38e8f5d2cdf000089 does not have quotas imposed
>1 ERRORS
>
>--END oo-accept-node OUTPUT--
>
>
>

>_______________________________________________
>users mailing list
>users lists openshift redhat com
>http://lists.openshift.redhat.com/openshiftmm/listinfo/users



------------------------------

Message: 5
Date: Tue, 2 Dec 2014 15:43:23 +0100
From: patrick <chapat gmail com>
To: Brenton Leanhardt <bleanhar redhat com>
Cc: users <users lists openshift redhat com>
Subject: Re: FAIL: user ..... does not have quotas imposed
Message-ID: <65A678F1-51B9-470A-A33F-B50600320BF3 gmail com>
Content-Type: text/plain; charset="utf-8"

I?m running  OO version 3 on RedHat 6.5  I now that is not the last but i?ve spent to much time to get everything working that I?ve not courage to event thing to an update ;)

The strange things is that i?ve this error only for one gears ?



> On 02 Dec 2014, at 14:54, Brenton Leanhardt <bleanhar redhat com> wrote:
>
> +++ patrick [02/12/14 10:02 +0100]:
>> Hi list I got this errors on one node does somebody have a pointe on how to fix the user quota ?
>
> What version of openshift-origin-node-util are you using?
>
> Newer versions provide a more helpful message:
> https://github.com/openshift/origin-server/blob/master/node-util/sbin/oo-accept-node#L609 <https://github.com/openshift/origin-server/blob/master/node-util/sbin/oo-accept-node#L609>
>
> If you check /etc/openshift/resource_limits.conf you will be able to
> find the appropriate values to fill in for --blocks and --inodes.  If
> oo-devel-node returns an error that might give some indication as to
> how this Node got in to this situation.
>
> --Brenton
>
>>
>> Thanks
>>
>> patrick
>>
>> root::node01 # oo-diagnostics
>> FAIL: run_script
>> oo-accept-node had errors:
>> --BEGIN OUTPUT--
>> FAIL: user 546081c38e8f5d2cdf000089 does not have quotas imposed
>> 1 ERRORS
>>
>> --END oo-accept-node OUTPUT--
>>
>>
>>
>
>> _______________________________________________
>> users mailing list
>> users lists openshift redhat com <mailto:users lists openshift redhat com>
>> http://lists.openshift.redhat.com/openshiftmm/listinfo/users <http://lists.openshift.redhat.com/openshiftmm/listinfo/users>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openshift.redhat.com/openshift-archives/users/attachments/20141202/f3120852/attachment.html>

------------------------------

_______________________________________________
users mailing list
users lists openshift redhat com
http://lists.openshift.redhat.com/openshiftmm/listinfo/users


End of users Digest, Vol 29, Issue 2
************************************



--
Klaus Raizer, MSc
Researcher, CPqD 

_______________________________________________
users mailing list
users lists openshift redhat com
http://lists.openshift.redhat.com/openshiftmm/listinfo/users



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]