[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

RE: OpenShift Origin Version v3



Thanks a lot for the response. Can you please help me with the steps for the same

Also ,I hope it won't have an impact on my existing install -I got it working with quite some effort and want to save it for some time :)
Have some deployed application as well.

But then need to use administration console feature as well ,but stuck due to this-
Any help is really appreciated.

Thanks
Shabna

-----Original Message-----
From: N. Harrison Ripps [mailto:hripps redhat com] 
Sent: Monday, January 20, 2014 11:09 PM
To: Madathilthattantav, S.
Cc: users lists openshift redhat com; dev lists openshift redhat com
Subject: Re: OpenShift Origin Version v3

Hey Shabna--

On Jan 20, 2014, at 8:07 , s madathilthattantav accenture com wrote:

> After installing the require package also , I am getting  the 
> following error [root broker fedora]# sudo oo-register-user -l admin 
> -p admin --username cshift --userpass chsift 
> /usr/share/gems/gems/activeresource-3.2.13/lib/active_resource/connection.rb:132:in `handle_response': Failed.  Response code = 401.  Response message = Unauthorized. (ActiveResource::UnauthorizedAccess)
>         from /usr/share/gems/gems/activeresource-3.2.13/lib/active_resource/connection.rb:115:in `request'
>         from /usr/share/gems/gems/activeresource-3.2.13/lib/active_resource/connection.rb:98:in `block in post'
>         from /usr/share/gems/gems/activeresource-3.2.13/lib/active_resource/connection.rb:218:in `with_auth'
>         from /usr/share/gems/gems/activeresource-3.2.13/lib/active_resource/connection.rb:98:in `post'
>         from /usr/share/gems/gems/activeresource-3.2.13/lib/active_resource/base.rb:1360:in `create'
>         from /usr/share/gems/gems/activeresource-3.2.13/lib/active_resource/observing.rb:19:in `create_with_notifications'
>         from /usr/share/gems/gems/activeresource-3.2.13/lib/active_resource/base.rb:1155:in `save'
>         from /usr/share/gems/gems/activeresource-3.2.13/lib/active_resource/validations.rb:79:in `save_with_validation'
>         from /usr/share/gems/gems/activeresource-3.2.13/lib/active_resource/observing.rb:19:in `save_with_notifications'
>         from /bin/oo-register-user:101:in `<main>'
>  
> Saw a similar issue reported : https://bugzilla.redhat.com/show_bug.cgi?id=1011974  Any ideas ?

Krishna is out today, but I -think- this problem is related to a bug that Krishna fixed in the puppet module last week. Specifically with this commit:
https://github.com/openshift/puppet-openshift_origin/commit/80b77f07f80ae93eb296d3a659d85ce3a2088235

The bug prevents authentication against the Broker REST API, which prevents a lot of things from working correctly.

You should be able to fix it by reinstalling and reapplying the puppet module; the latest version of the module at PuppetForge has this correction.

--Harrison

>  
> Thanks
> Shabna
>  
> From: Madathilthattantav, S. 
> Sent: Monday, January 20, 2014 6:13 PM
> To: 'users lists openshift redhat com'; 'dev lists openshift redhat com'
> Subject: OpenShift Origin Version v3
>  
> Hi All
>  
> I am trying to use the feature 
> https://www.openshift.com/blogs/announcing-the-openshift-administratio
> n-console
> In OpenShift version 3.
>  
> I am facing a strange issue with th Origin Install (version 3 in 
> Fedora 19 using oo-install) I am unable to create admin user.
>  
> I created  a default user after the install using the following command  :
> htpasswd -c /etc/openshift/htpasswd demo
>  
> I was able to login and deploy application without any issue.
> But when I try to give admin access,with the following command 
> oo-register-user -l admin -p admin --username demo --userpass demo
>  
> I get the error :  bash: oo-register-user: command not found , Looks like something is missing-Any pointers on the same.
>  
> Couple of other doubts as well
>  
> 1.If I have to add one more user , and do htpasswd -c /etc/openshift/htpasswd test ,it overwrites the file,how to avoid this?
> 2.How to get access to openshift-administration-console.Pointers to the same?
> 3.After the install,is there a default admin user  created? I used oo-install for the Installation.
>  
> Thanks a lot for any help on the same.
>  
> Shabna
>  
>  
> 
> 
> This message is for the designated recipient only and may contain privileged, proprietary, or otherwise confidential information. If you have received it in error, please notify the sender immediately and delete the original. Any other use of the e-mail by you is prohibited. Where allowed by local law, electronic communications with Accenture and its affiliates, including e-mail and instant messaging (including content), may be scanned by our systems for the purposes of information security and assessment of internal compliance with Accenture policy. .
> ______________________________________________________________________
> ________________
> 
> www.accenture.com
> _______________________________________________
> dev mailing list
> dev lists openshift redhat com
> http://lists.openshift.redhat.com/openshiftmm/listinfo/dev





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]