[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: OO post install : broker's console missing icons [solved]



Hi Brice--

On Jan 31, 2014, at 9:06 , brice vandeputte orange com wrote:

> Hi,
>  
> For the missing icons onto the broker’s console [CentOS 6.5], I just found a fix : see under.
>  
> @dev: maybe the comprehensive deployment guide should be updated... I don’t know.
>  I have noticed 2 old bugs which are maybe so closed:
> -          1011693 [Origin] icon can't be rendered under UI management console
> -          1011702 [Origin] The app restart icon is not rendered correctly under the UI app management console.
>  
>  
> Missing icons fix :
>  
> First :
> -          Into /etc/httpd/conf.d/ssl.conf
> o   don’t forget to remove entirely the VirtualHost section “*:443” since she is already defined by the following file :
> §  /etc/httpd/conf.d/000002_openshift_origin_broker_proxy.conf
> Second :
> -          Into /etc/httpd/conf.d/000002_openshift_origin_broker_proxy.conf
> -          Following this post, I add some ProxyPass directives (more details under) :
>  
>   ProxyPass /assets http://127.0.0.1:8118/console/assets
>   ProxyPassReverse /assets http://127.0.0.1:8118/console/assets

This is a great find; thanks for sharing it with the list. Would you be willing to submit a pull request for the doc change? The source for the Comprehensive Deployment Guide is here:

https://github.com/openshift/origin-server/blob/master/documentation/oo_deployment_guide_comprehensive.adoc

We would probably want to put this in the section starting on line 1711 ("Configure Authentication for the Console") since that section discusses the files under /etc/httpd/conf.d

If you have the time to put this together, you can ping me via e-mail or IRC ('nhr' on #openshift-dev in FreeNode) to review the pull request.

Cheers,
Harrison

>  
> NB: thanks @ Gordan Ristic ^^
>  
> That’s all.
> Regards
> Brice
>  
>  
>  
>  
>  
> Httpd conf details :
> -----------------------
>  
> Here is the diff between original file and the fixed one:
>  
> <   ProxyPassReverse / http://127.0.0.1:8080/
> ---
> >   ProxyPassReverse /broker http://127.0.0.1:8080/broker
> > 
> >   ProxyPass /assets http://127.0.0.1:8118/console/assets
> >   ProxyPassReverse /assets http://127.0.0.1:8118/console/assets
>  
> The final result for me (end of  /etc/httpd/conf.d/000002_openshift_origin_broker_proxy.conf ):
>  
> <VirtualHost *:443>
>   # ServerName we will inherit from other config;
>   # ServerAlias is to make sure "localhost" traffic goes here regardless.
>   ServerAlias localhost
>   ServerAdmin root localhost
>   DocumentRoot /var/www/html
>   RewriteEngine              On
>   RewriteRule     ^/$    https://%{HTTP_HOST}/console [R,L]
>   SSLEngine on
>   SSLProxyEngine on
>   SSLCertificateFile /etc/pki/tls/certs/localhost.crt
>   SSLCertificateKeyFile /etc/pki/tls/private/localhost.key
>   RequestHeader set X_FORWARDED_PROTO 'https'
>   RequestHeader set Front-End-Https "On"
>   ProxyTimeout 300
>   ProxyPass /console http://127.0.0.1:8118/console
>   ProxyPassReverse /console http://127.0.0.1:8118/console
>  
>   ProxyPass /broker http://127.0.0.1:8080/broker
>   ProxyPassReverse /broker http://127.0.0.1:8080/broker
>  
>   ProxyPass /assets http://127.0.0.1:8118/console/assets
>   ProxyPassReverse /assets http://127.0.0.1:8118/console/assets
> </VirtualHost>
>  
>  
>  
>  
>  
>  
> De : users-bounces lists openshift redhat com [mailto:users-bounces lists openshift redhat com] De la part de brice vandeputte orange com
> Envoyé : jeudi 30 janvier 2014 11:00
> À : users lists openshift redhat com
> Objet : OO post install : broker's console missing icons & "bson_ext not loaded" message
>  
> Hi all,
> I just install openshift origin on CentOS 6.5 and I got 2 problems with the broker :
>  
> -          A) The broker’s console doesn’t display icons (ex. Gear, or “(?)” symbols…) .
>  
>  cf screenshot  (gg+) http://goo.gl/AgGLWK  (img direct link) http://goo.gl/KW2Tu3
>  
> It’s seems maybe assets or webfont problem ?
> I can’t see console icons with ggchrome and firefox. I could see without any pb the same icon on openshift.redhat.com website.
> I find this post but my broker’s httpd console configuration seems correct. I can download webfont files for example.
> I do a console cache clear, service restart or “rake assets:precompile” + chmod without error.
> I don’t know how to fix this.
> _________________________________________________________________________________________________________________________
> 
> Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
> pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
> a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
> Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.
> 
> This message and its attachments may contain confidential or privileged information that may be protected by law;
> they should not be distributed, used or copied without authorisation.
> If you have received this email in error, please notify the sender and delete this message and its attachments.
> As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
> Thank you.
> 
> _______________________________________________
> users mailing list
> users lists openshift redhat com
> http://lists.openshift.redhat.com/openshiftmm/listinfo/users



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]